summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-08-28 14:11:09 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-08-28 14:11:09 +0000
commit024c82ee04a5b2e67b653afffce945bfa8c6ec04 (patch)
tree5d411f4d9de9e73b0261ade26e0282b28a50c475 /pkgs/development
parent3a993e2f8effa53480de4f27ceb07b7eac99c169 (diff)
downloadnixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar.gz
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar.bz2
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar.lz
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar.xz
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.tar.zst
nixlib-024c82ee04a5b2e67b653afffce945bfa8c6ec04.zip
* lcov 1.7.
svn path=/nixpkgs/trunk/; revision=16888
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/analysis/lcov/builder.sh7
-rw-r--r--pkgs/development/tools/analysis/lcov/default.nix14
-rw-r--r--pkgs/development/tools/analysis/lcov/string.patch10
3 files changed, 4 insertions, 27 deletions
diff --git a/pkgs/development/tools/analysis/lcov/builder.sh b/pkgs/development/tools/analysis/lcov/builder.sh
deleted file mode 100644
index b0092e002556..000000000000
--- a/pkgs/development/tools/analysis/lcov/builder.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-source $stdenv/setup
-
-
-preInstall() {
-}
-
-genericBuild
diff --git a/pkgs/development/tools/analysis/lcov/default.nix b/pkgs/development/tools/analysis/lcov/default.nix
index 9834b8a5a2b5..439238b524f6 100644
--- a/pkgs/development/tools/analysis/lcov/default.nix
+++ b/pkgs/development/tools/analysis/lcov/default.nix
@@ -1,18 +1,13 @@
 {stdenv, fetchurl, perl}:
 
-stdenv.mkDerivation {
-  name = "lcov-1.6";
+stdenv.mkDerivation rec {
+  name = "lcov-1.7";
   
   src = fetchurl {
-    url = mirror://sourceforge/ltp/lcov-1.6.tar.gz;
-    sha256 = "0d6lb0vlj3lvqmm678jic9h25q4dnlkbv37wg5yj311hdr9ls1kx";
+    url = "mirror://sourceforge/ltp/${name}.tar.gz";
+    sha256 = "1cx3haizs0rw6wjsn486qcn50f3qpybflkkb1780cg6s8jzcwdin";
   };
 
-  patches = [
-    # http://ltp.cvs.sourceforge.net/ltp/utils/analysis/lcov/bin/geninfo?revision=1.33&view=markup&pathrev=HEAD
-    ./string.patch
-  ];
-
   preBuild = ''
     makeFlagsArray=(PREFIX=$out BIN_DIR=$out/bin MAN_DIR=$out/share/man)
   '';
@@ -31,5 +26,4 @@ stdenv.mkDerivation {
     description = "A code coverage tool for Linux";
     homepage = http://ltp.sourceforge.net/coverage/lcov.php;
   };
-
 }
diff --git a/pkgs/development/tools/analysis/lcov/string.patch b/pkgs/development/tools/analysis/lcov/string.patch
deleted file mode 100644
index db753c5dab26..000000000000
--- a/pkgs/development/tools/analysis/lcov/string.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/bin/geninfo	2007/10/04 08:18:07	1.32
-+++ b/bin/geninfo	2007/11/01 16:29:39	1.33
-@@ -1478,6 +1478,7 @@
- 					}
- 					next;
- 				}
-+				last if ($length == 0);
- 				($blocks, $string) =
- 					read_gcno_string(*INPUT, $endianness);
- 				if (defined($string))