summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2012-03-06 20:04:58 +0000
committerPeter Simons <simons@cryp.to>2012-03-06 20:04:58 +0000
commitf7896f322e4d3d6d1e65a7cf50ffdc1801e95e43 (patch)
tree01f46263d6670e798ab901449fcb07af7324c6e1 /pkgs/desktops
parent38615a16e902f6819e9540a9e9cf512279e4e4d7 (diff)
downloadnixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar.gz
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar.bz2
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar.lz
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar.xz
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.tar.zst
nixlib-f7896f322e4d3d6d1e65a7cf50ffdc1801e95e43.zip
libgnomeprint: fix gcc 4.6 compilation error
svn path=/nixpkgs/trunk/; revision=32832
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-2/platform/libgnomeprint/bug653388.patch21
-rw-r--r--pkgs/desktops/gnome-2/platform/libgnomeprint/default.nix2
2 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-2/platform/libgnomeprint/bug653388.patch b/pkgs/desktops/gnome-2/platform/libgnomeprint/bug653388.patch
new file mode 100644
index 000000000000..468f8e287a7c
--- /dev/null
+++ b/pkgs/desktops/gnome-2/platform/libgnomeprint/bug653388.patch
@@ -0,0 +1,21 @@
+From 9b82b7e75b83395e7c5692085e1934202cf7f65f Mon Sep 17 00:00:00 2001
+From: Jeremy Huddleston <jeremyhu@freedesktop.org>
+Date: Wed, 12 Oct 2011 15:08:59 +0000
+Subject: Add missing include
+
+https://bugzilla.gnome.org/show_bug.cgi?id=653388
+---
+diff --git a/libgnomeprint/modules/cups/gnome-print-cups-transport.c b/libgnomeprint/modules/cups/gnome-print-cups-transport.c
+index aeb7111..85de91b 100644
+--- a/libgnomeprint/modules/cups/gnome-print-cups-transport.c
++++ b/libgnomeprint/modules/cups/gnome-print-cups-transport.c
+@@ -34,6 +34,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <stdio.h>
+ #include <unistd.h>
+ #include <locale.h>
+ 
+--
+cgit v0.9.0.2
diff --git a/pkgs/desktops/gnome-2/platform/libgnomeprint/default.nix b/pkgs/desktops/gnome-2/platform/libgnomeprint/default.nix
index 54b5d6382428..410e408baa3d 100644
--- a/pkgs/desktops/gnome-2/platform/libgnomeprint/default.nix
+++ b/pkgs/desktops/gnome-2/platform/libgnomeprint/default.nix
@@ -12,6 +12,8 @@ stdenv.mkDerivation {
     sha256 = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691";
   };
 
+  patches = [ ./bug653388.patch ];
+
   buildInputs = [ pkgconfig gtk gettext intltool libart_lgpl libgnomecups bison flex ];
   propagatedBuildInputs = [ libxml2 ];
 }