summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-03-25 22:25:51 +0000
committerLudovic Courtès <ludo@gnu.org>2009-03-25 22:25:51 +0000
commitf1500cd96079b4f2a91f9cc2a519aaa8a63e13d4 (patch)
tree024c9c4223f116f9709869d0078ddd4f15c05583 /pkgs/desktops
parentedec8307f355ebcc7826ff768fa8bc4743497f66 (diff)
downloadnixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar.gz
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar.bz2
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar.lz
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar.xz
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.tar.zst
nixlib-f1500cd96079b4f2a91f9cc2a519aaa8a63e13d4.zip
Add libglademm, C++ bindings for libglade.
svn path=/nixpkgs/branches/stdenv-updates/; revision=14718
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome/default.nix5
-rw-r--r--pkgs/desktops/gnome/libglademm.nix30
2 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome/default.nix b/pkgs/desktops/gnome/default.nix
index 369712cdaae5..a94146fdfd52 100644
--- a/pkgs/desktops/gnome/default.nix
+++ b/pkgs/desktops/gnome/default.nix
@@ -92,6 +92,11 @@ rec {
     input = platform.libglade;
   };
 
+  libglademm = import ./libglademm.nix {
+    inherit fetchurl stdenv pkgconfig libglade;
+    inherit (gtkLibs) gtkmm;
+  };
+
   libgnomecanvas = stdenv.mkDerivation {
     inherit (platform.libgnomecanvas) name src;
     buildInputs = [
diff --git a/pkgs/desktops/gnome/libglademm.nix b/pkgs/desktops/gnome/libglademm.nix
new file mode 100644
index 000000000000..ed3834562715
--- /dev/null
+++ b/pkgs/desktops/gnome/libglademm.nix
@@ -0,0 +1,30 @@
+{ fetchurl, stdenv, pkgconfig, libglade, gtkmm }:
+
+stdenv.mkDerivation rec {
+  name = "libglademm-2.6.7";
+
+  src = fetchurl {
+    url = "http://ftp.gnome.org/pub/GNOME/sources/libglademm/2.6/${name}.tar.bz2";
+    sha256 = "1hrbg9l5qb7w0xvr7013qamkckyj0fqc426c851l69zpmhakqm1q";
+  };
+
+  buildInputs = [ pkgconfig libglade gtkmm ];
+
+  meta = {
+    description = "C++ interface to the libglade graphical user interface library";
+
+    longDescription = ''
+      gtkmm is the official C++ interface for the popular GUI library
+      GTK+.  Highlights include typesafe callbacks, and a
+      comprehensive set of widgets that are easily extensible via
+      inheritance.  You can create user interfaces either in code or
+      with the Glade User Interface designer, using libglademm.
+      There's extensive documentation, including API reference and a
+      tutorial.
+    '';
+
+    homepage = http://gtkmm.org/;
+
+    license = "LGPLv2+";
+  };
+}