summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2014-04-06 12:33:28 +0200
committerLuca Bruno <lucabru@src.gnome.org>2014-04-06 15:23:11 +0200
commitc70c038624dcefecfc9736d39eba30f516f88dc5 (patch)
treef238091df1fbcec169d32c28ea9e2ec85e6943c3 /pkgs/desktops
parent5174e6db807f36e3024adeaa1107c0486e88b135 (diff)
downloadnixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar.gz
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar.bz2
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar.lz
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar.xz
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.tar.zst
nixlib-c70c038624dcefecfc9736d39eba30f516f88dc5.zip
gnome-dictionary: new package
Dictionary is the GNOME application to look up definitions

https://wiki.gnome.org/Apps/Dictionary
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/core/gnome-dictionary/default.nix38
-rw-r--r--pkgs/desktops/gnome-3/default.nix2
2 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/core/gnome-dictionary/default.nix b/pkgs/desktops/gnome-3/core/gnome-dictionary/default.nix
new file mode 100644
index 000000000000..6f68916b781e
--- /dev/null
+++ b/pkgs/desktops/gnome-3/core/gnome-dictionary/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, intltool, fetchurl
+, pkgconfig, gtk3, glib, hicolor_icon_theme
+, bash, makeWrapper, itstool, libxml2
+, gnome3, librsvg, gdk_pixbuf, file }:
+
+stdenv.mkDerivation rec {
+  name = "gnome-dictionary-3.10.0";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/gnome-dictionary/3.10/${name}.tar.xz";
+    sha256 = "258b60fe50f7d0580a7dc3bb83f7fe2f6f0597d4013d97ac083c3f062c350ed7";
+  };
+
+  doCheck = true;
+
+  NIX_CFLAGS_COMPILE = "-I${gnome3.glib}/include/gio-unix-2.0";
+
+  propagatedUserEnvPkgs = [ gnome3.gnome_themes_standard ];
+  propagatedBuildInputs = [ gdk_pixbuf gnome3.gnome_icon_theme librsvg
+                            hicolor_icon_theme gnome3.gnome_icon_theme_symbolic ];
+
+  buildInputs = [ pkgconfig gtk3 glib intltool itstool libxml2 file
+                  gnome3.gsettings_desktop_schemas makeWrapper ];
+
+  preFixup = ''
+    wrapProgram "$out/bin/gnome-dictionary" \
+      --set GDK_PIXBUF_MODULE_FILE "$GDK_PIXBUF_MODULE_FILE" \
+      --prefix XDG_DATA_DIRS : "${gtk3}/share:${gnome3.gnome_themes_standard}/share:$out/share:$XDG_ICON_DIRS:$GSETTINGS_SCHEMAS_PATH"
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://wiki.gnome.org/Apps/Dictionary;
+    description = "Dictionary is the GNOME application to look up definitions";
+    maintainers = with maintainers; [ lethalman ];
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/desktops/gnome-3/default.nix b/pkgs/desktops/gnome-3/default.nix
index 00bc653c1f92..4f902a96358c 100644
--- a/pkgs/desktops/gnome-3/default.nix
+++ b/pkgs/desktops/gnome-3/default.nix
@@ -46,6 +46,8 @@ rec {
 
   gnome_common = callPackage ./core/gnome-common { };
 
+  gnome-dictionary = callPackage ./core/gnome-dictionary { };
+
   gnome-disk-utility = callPackage ./core/gnome-disk-utility { };
 
   gnome-font-viewer = callPackage ./core/gnome-font-viewer { };