summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2018-10-21 18:42:02 -0300
committerJosé Romildo Malaquias <malaquias@gmail.com>2018-10-22 21:15:00 -0300
commitc3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d (patch)
tree9c4cfc29d532675ee8e6d4283fbe0cd613cf6621 /pkgs/desktops
parent66760c7c5c08c9d632e5a786a88626c97299a6a4 (diff)
downloadnixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar.gz
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar.bz2
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar.lz
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar.xz
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.tar.zst
nixlib-c3fe5bd0885f4bc1e2b7249c9a4351cb2efc756d.zip
dde-daemon: init at 3.2.24.7
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/deepin/dde-daemon/default.nix90
-rw-r--r--pkgs/desktops/deepin/dde-daemon/deps.nix102
-rw-r--r--pkgs/desktops/deepin/default.nix1
3 files changed, 193 insertions, 0 deletions
diff --git a/pkgs/desktops/deepin/dde-daemon/default.nix b/pkgs/desktops/deepin/dde-daemon/default.nix
new file mode 100644
index 000000000000..fe2c5f8f55a1
--- /dev/null
+++ b/pkgs/desktops/deepin/dde-daemon/default.nix
@@ -0,0 +1,90 @@
+{ stdenv, buildGoPackage, fetchFromGitHub, fetchpatch, pkgconfig,
+  dbus-factory, go-dbus-factory, go-gir-generator, go-lib,
+  deepin-gettext-tools, dde-api, alsaLib, glib, gtk3, libinput, libnl,
+  librsvg, linux-pam, networkmanager, pulseaudio, xorg, gnome3,
+  python3Packages, hicolor-icon-theme, go }:
+
+buildGoPackage rec {
+  name = "${pname}-${version}";
+  pname = "dde-daemon";
+  version = "3.2.24.7";
+
+  goPackagePath = "pkg.deepin.io/dde/daemon";
+
+  src = fetchFromGitHub {
+    owner = "linuxdeepin";
+    repo = pname;
+    rev = version;
+    sha256 = "17dvhqrw0dqy3d0wd9ailb18y2rg7575g3ffy0d5rg9m3y65y1y6";
+  };
+
+  patches = [
+    # https://github.com/linuxdeepin/dde-daemon/issues/51
+    (fetchpatch {
+      name = "dde-daemon_3.2.3.patch";
+      url = https://github.com/jouyouyun/tap-gesture-patches/raw/master/patches/dde-daemon_3.2.3.patch;
+      sha256 = "0a3xb15czpfl2vajpf7ycw37vr7fbw2png1a67mvjjkgx7d1k7dg";
+    })
+  ];
+
+  goDeps = ./deps.nix;
+
+  outputs = [ "out" ];
+
+  nativeBuildInputs = [
+    pkgconfig
+    dbus-factory
+    go-dbus-factory
+    go-gir-generator
+    go-lib
+    deepin-gettext-tools
+    dde-api
+    linux-pam
+    networkmanager
+    networkmanager.dev
+    python3Packages.python
+  ];
+
+  buildInputs = [
+    alsaLib
+    glib
+    gnome3.libgudev
+    gtk3
+    hicolor-icon-theme
+    libinput
+    libnl
+    librsvg
+    pulseaudio
+  ];
+
+  postPatch = ''
+    patchShebangs .
+
+    sed -i network/nm_generator/Makefile -e 's,/usr/share/gir-1.0/NM-1.0.gir,${networkmanager.dev}/share/gir-1.0/NM-1.0.gir,'
+
+    sed -i -e "s|{DESTDIR}/etc|{DESTDIR}$out/etc|" Makefile
+    sed -i -e "s|{DESTDIR}/var|{DESTDIR}$out/var|" Makefile
+    sed -i -e "s|{DESTDIR}/lib|{DESTDIR}$out/lib|" Makefile
+
+    find -type f -exec sed -i -e "s,/usr/lib/deepin-daemon,$out/lib/deepin-daemon," {} +
+  '';
+
+  buildPhase = ''
+    make -C go/src/${goPackagePath}
+    # compilation of the nm module is failing
+    #make -C go/src/${goPackagePath}/network/nm_generator gen-nm-code
+  '';
+
+  installPhase = ''
+    make install PREFIX="$out" -C go/src/${goPackagePath}
+    remove-references-to -t ${go} $out/lib/deepin-daemon/*
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Daemon for handling Deepin Desktop Environment session settings";
+    homepage = https://github.com/linuxdeepin/dde-daemon;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ romildo ];
+  };
+}
diff --git a/pkgs/desktops/deepin/dde-daemon/deps.nix b/pkgs/desktops/deepin/dde-daemon/deps.nix
new file mode 100644
index 000000000000..5ffecc28882d
--- /dev/null
+++ b/pkgs/desktops/deepin/dde-daemon/deps.nix
@@ -0,0 +1,102 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+[
+  {
+    goPackagePath = "github.com/alecthomas/template";
+    fetch = {
+      type = "git";
+      url = "https://github.com/alecthomas/template";
+      rev = "a0175ee3bccc567396460bf5acd36800cb10c49c";
+      sha256 = "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj";
+    };
+  }
+  {
+    goPackagePath = "github.com/alecthomas/units";
+    fetch = {
+      type = "git";
+      url = "https://github.com/alecthomas/units";
+      rev = "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a";
+      sha256 = "1j65b91qb9sbrml9cpabfrcf07wmgzzghrl7809hjjhrmbzri5bl";
+    };
+  }
+  {
+    goPackagePath = "github.com/axgle/mahonia";
+    fetch = {
+      type = "git";
+      url = "https://github.com/axgle/mahonia";
+      rev = "3358181d7394e26beccfae0ffde05193ef3be33a";
+      sha256 = "0b8wsrxmv8a0cqbnsg55lpf29pxy2zw8azvgh3ck664lqpcfybhq";
+    };
+  }
+  {
+    goPackagePath = "github.com/cryptix/wav";
+    fetch = {
+      type = "git";
+      url = "https://github.com/cryptix/wav";
+      rev = "8bdace674401f0bd3b63c65479b6a6ff1f9d5e44";
+      sha256 = "18nyqv0ic35fs9fny8sj84c00vbxs8mnric6vr6yl42624fh5id6";
+    };
+  }
+  {
+    goPackagePath = "github.com/linuxdeepin/go-x11-client";
+    fetch = {
+      type = "git";
+      url = "https://github.com/linuxdeepin/go-x11-client";
+      rev = "8f12fd35ff10b391f0321aa41b94db6acd951ea3";
+      sha256 = "1axxzzhbiwvi76d19bix3zm5wv3qmlq0wgji9mwjbmkb4bvp0v3d";
+    };
+  }
+  {
+    goPackagePath = "github.com/msteinert/pam";
+    fetch = {
+      type = "git";
+      url = "https://github.com/msteinert/pam";
+      rev = "f4cd9f5e29232537a12db1678f48c702ad6896b7";
+      sha256 = "1vjawxswy3f23v4d72kk95y3b557580670ai9ffvrwy6wy85qync";
+    };
+  }
+  {
+    goPackagePath = "github.com/nfnt/resize";
+    fetch = {
+      type = "git";
+      url = "https://github.com/nfnt/resize";
+      rev = "83c6a9932646f83e3267f353373d47347b6036b2";
+      sha256 = "005cpiwq28krbjf0zjwpfh63rp4s4is58700idn24fs3g7wdbwya";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/image";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/image";
+      rev = "991ec62608f3c0da01d400756917825d1e2fd528";
+      sha256 = "0jipi9czjczi6hlqb5kchgml8r6h6qyb4gqrb0nnb63m25510019";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/net";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/net";
+      rev = "04a2e542c03f1d053ab3e4d6e5abcd4b66e2be8e";
+      sha256 = "040i9f6ymj4z25957h20id9kfmlrcp35y4sfd99hngw9li50ihql";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/text";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/text";
+      rev = "4d1c5fb19474adfe9562c9847ba425e7da817e81";
+      sha256 = "1y4rf9cmjyf8r56khr1sz0chbq1v0ynaj63i2z1mq6k6h6ww45da";
+    };
+  }
+  {
+    goPackagePath = "gopkg.in/alecthomas/kingpin.v2";
+    fetch = {
+      type = "git";
+      url = "https://gopkg.in/alecthomas/kingpin.v2";
+      rev = "947dcec5ba9c011838740e680966fd7087a71d0d";
+      sha256 = "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r";
+    };
+  }
+]
diff --git a/pkgs/desktops/deepin/default.nix b/pkgs/desktops/deepin/default.nix
index 86e5fc37fa54..a6163cd32e20 100644
--- a/pkgs/desktops/deepin/default.nix
+++ b/pkgs/desktops/deepin/default.nix
@@ -6,6 +6,7 @@ let
     dbus-factory = callPackage ./dbus-factory { };
     dde-api = callPackage ./dde-api { };
     dde-calendar = callPackage ./dde-calendar { };
+    dde-daemon = callPackage ./dde-daemon { };
     dde-polkit-agent = callPackage ./dde-polkit-agent { };
     dde-qt-dbus-factory = callPackage ./dde-qt-dbus-factory { };
     dde-session-ui = callPackage ./dde-session-ui { };