summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorPascal Wittmann <PascalWittmann@gmx.net>2017-11-18 14:06:35 +0100
committerGitHub <noreply@github.com>2017-11-18 14:06:35 +0100
commitc1dd363a3d61352baa633b240552737d6c96efae (patch)
treea97b697a5aa87cce62004f39add0b2a9f1cb3802 /pkgs/desktops
parent457306d9cde5081b7e123c888a7bc71bce5597e1 (diff)
parente8712da846bfff3b278d8c8fa387f35050624823 (diff)
downloadnixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar.gz
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar.bz2
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar.lz
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar.xz
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.tar.zst
nixlib-c1dd363a3d61352baa633b240552737d6c96efae.zip
Merge pull request #31793 from romildo/new.lxtask
lxtask: init at 0.1.8
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/lxde/core/lxtask/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/desktops/lxde/core/lxtask/default.nix b/pkgs/desktops/lxde/core/lxtask/default.nix
new file mode 100644
index 000000000000..ef95f6035b27
--- /dev/null
+++ b/pkgs/desktops/lxde/core/lxtask/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl, pkgconfig, intltool, gtk3 }:
+
+stdenv.mkDerivation rec {
+  name = "lxtask-${version}";
+  version = "0.1.8";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/lxde/${name}.tar.xz";
+    sha256 = "0h7g1fdngv939z1d05nzs86dplww5a3bpm0isxd7p1bjby047d6z";
+  };
+
+  nativeBuildInputs = [ pkgconfig intltool ];
+  
+  buildInputs = [ gtk3 ];
+
+  configureFlags = [ "--enable-gtk3" ];
+
+  meta = {
+    description = "Lightweight and desktop independent task manager";
+    longDescription = ''
+      LXTask is a lightweight task manager derived from xfce4 task manager
+      with all xfce4 dependencies removed, some bugs fixed, and some
+      improvement of UI. Although being part of LXDE, the Lightweight X11
+      Desktop Environment, it's totally desktop independent and only
+      requires pure gtk+.
+    '';
+    homepage = https://wiki.lxde.org/en/LXTask; 
+    license = stdenv.lib.licenses.gpl2Plus;
+    platforms = stdenv.lib.platforms.unix;
+    maintainers = [ stdenv.lib.maintainers.romildo ];
+  };
+}