summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-05-03 23:12:48 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-05-03 23:12:48 +0300
commitaadaa913792b0fdeb68b02425e4f03d2f8286a1f (patch)
treeea582b078a00e6ba27e2c887a9df5a792c37fb0e /pkgs/desktops
parent2362891dc815160e343e52458f25db22508ac487 (diff)
parente7d3166656af0d98da9f59c78e2213cec842d743 (diff)
downloadnixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar.gz
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar.bz2
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar.lz
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar.xz
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.tar.zst
nixlib-aadaa913792b0fdeb68b02425e4f03d2f8286a1f.zip
Merge remote-tracking branch 'upstream/master' into staging
Conflicts:
	pkgs/applications/networking/browsers/vivaldi/default.nix
	pkgs/misc/emulators/wine/base.nix
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce/core/gtk-xfce-engine.nix12
-rw-r--r--pkgs/desktops/xfce/default.nix2
2 files changed, 8 insertions, 6 deletions
diff --git a/pkgs/desktops/xfce/core/gtk-xfce-engine.nix b/pkgs/desktops/xfce/core/gtk-xfce-engine.nix
index b66faf2390b9..6e5ac7c55ea1 100644
--- a/pkgs/desktops/xfce/core/gtk-xfce-engine.nix
+++ b/pkgs/desktops/xfce/core/gtk-xfce-engine.nix
@@ -1,17 +1,19 @@
-{ stdenv, fetchurl, pkgconfig, intltool, gtk }:
+{ stdenv, fetchurl, pkgconfig, intltool, gtk, withGtk3 ? false, gtk3 }:
 
 stdenv.mkDerivation rec {
   p_name  = "gtk-xfce-engine";
-  ver_maj = "2.10";
-  ver_min = "1";
+  ver_maj = "3.2";
+  ver_min = "0";
 
   src = fetchurl {
     url = "mirror://xfce/src/xfce/${p_name}/${ver_maj}/${name}.tar.bz2";
-    sha256 = "4a92910205881f707f2cc8d3c9b00a95feb58eb9084d932c841f3ed027f7063d";
+    sha256 = "1va71f3gpl8gikfkmqsd5ikgp7qj8b64jii2l98g1ylnv8xrqp47";
   };
   name = "${p_name}-${ver_maj}.${ver_min}";
 
-  buildInputs = [ pkgconfig intltool gtk ];
+  buildInputs = [ pkgconfig intltool gtk ] ++ stdenv.lib.optional withGtk3 gtk3;
+  
+  configureFlags = stdenv.lib.optional withGtk3 "--enable-gtk3";
 
   meta = {
     homepage = http://www.xfce.org/;
diff --git a/pkgs/desktops/xfce/default.nix b/pkgs/desktops/xfce/default.nix
index 96e6c55162a5..3ea3721362bc 100644
--- a/pkgs/desktops/xfce/default.nix
+++ b/pkgs/desktops/xfce/default.nix
@@ -21,7 +21,7 @@ xfce_self = rec { # the lines are very long but it seems better than the even-od
 
   exo             = callPackage ./core/exo.nix { };
   garcon          = callPackage ./core/garcon.nix { };
-  gtk_xfce_engine = callPackage ./core/gtk-xfce-engine.nix { }; # ToDo: when should be used?
+  gtk_xfce_engine = callPackage ./core/gtk-xfce-engine.nix { withGtk3 = true; }; # ToDo: when should be used?
   libxfce4ui      = callPackage ./core/libxfce4ui.nix { };
   libxfce4ui_gtk3 = libxfce4ui.override { withGtk3 = true; };
   libxfce4util    = callPackage ./core/libxfce4util.nix { };