summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-12-10 09:37:33 -0600
committerThomas Tuegel <ttuegel@gmail.com>2015-12-11 07:08:33 -0600
commit9678f78056c93fa835459593ef7b4756b090f8bc (patch)
treee6b2b1bc1d4214af98fcdb25a514bddb5c80bdd3 /pkgs/desktops
parent8ec4b45dbd2992e78cec15361acff4cfa8395c6b (diff)
downloadnixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar.gz
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar.bz2
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar.lz
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar.xz
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.tar.zst
nixlib-9678f78056c93fa835459593ef7b4756b090f8bc.zip
plasma55.breeze-gtk: init at 5.5.0.1
The GTK themes do not depend on GTK at compile time, so they are also
now included in plasma55.breeze at no cost.
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.5/breeze-gtk.nix8
-rw-r--r--pkgs/desktops/plasma-5.5/default.nix3
2 files changed, 10 insertions, 1 deletions
diff --git a/pkgs/desktops/plasma-5.5/breeze-gtk.nix b/pkgs/desktops/plasma-5.5/breeze-gtk.nix
new file mode 100644
index 000000000000..179f15dc8763
--- /dev/null
+++ b/pkgs/desktops/plasma-5.5/breeze-gtk.nix
@@ -0,0 +1,8 @@
+{ plasmaPackage
+, extra-cmake-modules
+}:
+
+plasmaPackage {
+  name = "breeze-gtk";
+  nativeBuildInputs = [ extra-cmake-modules ];
+}
diff --git a/pkgs/desktops/plasma-5.5/default.nix b/pkgs/desktops/plasma-5.5/default.nix
index 33937aa32200..812c70c2b004 100644
--- a/pkgs/desktops/plasma-5.5/default.nix
+++ b/pkgs/desktops/plasma-5.5/default.nix
@@ -44,11 +44,12 @@ let
 
   addPackages = self: with self; {
     bluedevil = callPackage ./bluedevil.nix {};
+    breeze-gtk = callPackage ./breeze-gtk.nix {};
     breeze-qt4 = callPackage ./breeze-qt4.nix {};
     breeze-qt5 = callPackage ./breeze-qt5.nix {};
     breeze =
       let version = (builtins.parseDrvName breeze-qt5.name).version;
-      in symlinkJoin "breeze-${version}" [ breeze-qt4 breeze-qt5 ];
+      in symlinkJoin "breeze-${version}" [ breeze-gtk breeze-qt4 breeze-qt5 ];
     kde-cli-tools = callPackage ./kde-cli-tools.nix {};
     kde-gtk-config = callPackage ./kde-gtk-config {};
     kdecoration = callPackage ./kdecoration.nix {};