summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-09-29 16:58:59 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-09-29 16:58:59 -0500
commit8e9fca18e320d8e48547569b291bfdc93ce2be74 (patch)
treeb4f051e235a7596147521ea5dfd2c6221a7e480a /pkgs/desktops
parent5ba93bd4c3e49d5275288cc41e1c59e8015eabb6 (diff)
downloadnixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar.gz
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar.bz2
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar.lz
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar.xz
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.tar.zst
nixlib-8e9fca18e320d8e48547569b291bfdc93ce2be74.zip
plasma54: don't override mkDerivation
Provides a globally unique name (plasmaPackage) instead of using
attribute paths as namespaces and locally overloading the mkDerivation
name.
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.4/bluedevil.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/breeze-qt4.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/breeze-qt5.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/default.nix7
-rw-r--r--pkgs/desktops/plasma-5.4/kde-cli-tools.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kde-gtk-config.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kdecoration.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kdeplasma-addons.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kgamma5.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/khelpcenter.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/khotkeys.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kinfocenter.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kmenuedit.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kscreen.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/ksshaskpass.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/ksysguard.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kwayland.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kwin/default.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/kwrited.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/libkscreen/default.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/libksysguard.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/milou.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/oxygen-fonts.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/oxygen.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-desktop/default.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-mediacenter.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-nm.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-pa.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-workspace-wallpapers.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-workspace/default.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/polkit-kde-agent.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/powerdevil.nix4
-rw-r--r--pkgs/desktops/plasma-5.4/systemsettings.nix4
33 files changed, 67 insertions, 68 deletions
diff --git a/pkgs/desktops/plasma-5.4/bluedevil.nix b/pkgs/desktops/plasma-5.4/bluedevil.nix
index 83b0ab64b657..208540c4c796 100644
--- a/pkgs/desktops/plasma-5.4/bluedevil.nix
+++ b/pkgs/desktops/plasma-5.4/bluedevil.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , bluez-qt
 , kcoreaddons
@@ -15,7 +15,7 @@
 , shared_mime_info
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "bluedevil";
   nativeBuildInputs = [ extra-cmake-modules shared_mime_info ];
   buildInputs = [
diff --git a/pkgs/desktops/plasma-5.4/breeze-qt4.nix b/pkgs/desktops/plasma-5.4/breeze-qt4.nix
index c7a11fa0ff10..f8092bc9d376 100644
--- a/pkgs/desktops/plasma-5.4/breeze-qt4.nix
+++ b/pkgs/desktops/plasma-5.4/breeze-qt4.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , automoc4
 , cmake
 , perl
@@ -8,7 +8,7 @@
 , xproto
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "breeze-qt4";
   sname = "breeze";
   buildInputs = [
diff --git a/pkgs/desktops/plasma-5.4/breeze-qt5.nix b/pkgs/desktops/plasma-5.4/breeze-qt5.nix
index 993f0826dda1..ea769b1e282c 100644
--- a/pkgs/desktops/plasma-5.4/breeze-qt5.nix
+++ b/pkgs/desktops/plasma-5.4/breeze-qt5.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , frameworkintegration
 , kcmutils
@@ -11,7 +11,7 @@
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "breeze-qt5";
   sname = "breeze";
   nativeBuildInputs = [
diff --git a/pkgs/desktops/plasma-5.4/default.nix b/pkgs/desktops/plasma-5.4/default.nix
index 172acb08a053..db8747d74bd2 100644
--- a/pkgs/desktops/plasma-5.4/default.nix
+++ b/pkgs/desktops/plasma-5.4/default.nix
@@ -17,13 +17,12 @@ let
   srcs = import ./srcs.nix { inherit (pkgs) fetchurl; inherit mirror; };
   mirror = "mirror://kde";
 
-  mkDerivation = args:
+  plasmaPackage = args:
     let
-      inherit (stdenv) mkDerivation;
       inherit (args) name;
       sname = args.sname or name;
       inherit (srcs."${sname}") src version;
-    in mkDerivation (args // {
+    in stdenv.mkDerivation (args // {
       name = "${name}-${version}";
       inherit src;
 
@@ -82,6 +81,6 @@ let
     systemsettings = callPackage ./systemsettings.nix {};
   };
 
-  newScope = scope: kdeApps.newScope ({ inherit mkDerivation; } // scope);
+  newScope = scope: kdeApps.newScope ({ inherit plasmaPackage; } // scope);
 
 in lib.makeScope newScope addPackages
diff --git a/pkgs/desktops/plasma-5.4/kde-cli-tools.nix b/pkgs/desktops/plasma-5.4/kde-cli-tools.nix
index 404d86618d9a..ce93bb86b325 100644
--- a/pkgs/desktops/plasma-5.4/kde-cli-tools.nix
+++ b/pkgs/desktops/plasma-5.4/kde-cli-tools.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kcmutils
 , kconfig
@@ -12,7 +12,7 @@
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kde-cli-tools";
   nativeBuildInputs = [ extra-cmake-modules kdoctools ];
   buildInputs = [
diff --git a/pkgs/desktops/plasma-5.4/kde-gtk-config.nix b/pkgs/desktops/plasma-5.4/kde-gtk-config.nix
index 7be329eb0163..9c59665f1a0c 100644
--- a/pkgs/desktops/plasma-5.4/kde-gtk-config.nix
+++ b/pkgs/desktops/plasma-5.4/kde-gtk-config.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , glib
 , gtk2
@@ -12,7 +12,7 @@
 , knewstuff
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kde-gtk-config";
   nativeBuildInputs = [ extra-cmake-modules ];
   buildInputs = [
diff --git a/pkgs/desktops/plasma-5.4/kdecoration.nix b/pkgs/desktops/plasma-5.4/kdecoration.nix
index 7e2ebb705a76..eb65f7f90afb 100644
--- a/pkgs/desktops/plasma-5.4/kdecoration.nix
+++ b/pkgs/desktops/plasma-5.4/kdecoration.nix
@@ -1,6 +1,6 @@
-{ mkDerivation, extra-cmake-modules }:
+{ plasmaPackage, extra-cmake-modules }:
 
-mkDerivation {
+plasmaPackage {
   name = "kdecoration";
   nativeBuildInputs = [ extra-cmake-modules ];
 }
diff --git a/pkgs/desktops/plasma-5.4/kdeplasma-addons.nix b/pkgs/desktops/plasma-5.4/kdeplasma-addons.nix
index 335e5d3298c4..3e7058315e57 100644
--- a/pkgs/desktops/plasma-5.4/kdeplasma-addons.nix
+++ b/pkgs/desktops/plasma-5.4/kdeplasma-addons.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , ibus
@@ -19,7 +19,7 @@
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kdeplasma-addons";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kgamma5.nix b/pkgs/desktops/plasma-5.4/kgamma5.nix
index a82673fc7fa8..8d954cc145a0 100644
--- a/pkgs/desktops/plasma-5.4/kgamma5.nix
+++ b/pkgs/desktops/plasma-5.4/kgamma5.nix
@@ -1,11 +1,11 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kdelibs4support
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kgamma5";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/khelpcenter.nix b/pkgs/desktops/plasma-5.4/khelpcenter.nix
index 75a713090b75..dc7afd348c45 100644
--- a/pkgs/desktops/plasma-5.4/khelpcenter.nix
+++ b/pkgs/desktops/plasma-5.4/khelpcenter.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kconfig
@@ -12,7 +12,7 @@
 , kservice
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "khelpcenter";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/khotkeys.nix b/pkgs/desktops/plasma-5.4/khotkeys.nix
index b10618614954..02c43efd27e8 100644
--- a/pkgs/desktops/plasma-5.4/khotkeys.nix
+++ b/pkgs/desktops/plasma-5.4/khotkeys.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kcmutils
@@ -13,7 +13,7 @@
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "khotkeys";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kinfocenter.nix b/pkgs/desktops/plasma-5.4/kinfocenter.nix
index 0c71ee022daf..89a3b4643830 100644
--- a/pkgs/desktops/plasma-5.4/kinfocenter.nix
+++ b/pkgs/desktops/plasma-5.4/kinfocenter.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kcmutils
@@ -21,7 +21,7 @@
 , solid
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kinfocenter";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kmenuedit.nix b/pkgs/desktops/plasma-5.4/kmenuedit.nix
index 043ef0407acb..d5eeb3c35730 100644
--- a/pkgs/desktops/plasma-5.4/kmenuedit.nix
+++ b/pkgs/desktops/plasma-5.4/kmenuedit.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , ki18n
@@ -10,7 +10,7 @@
 , kdelibs4support
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kmenuedit";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kscreen.nix b/pkgs/desktops/plasma-5.4/kscreen.nix
index caf84e96a0a9..f221f66f03f6 100644
--- a/pkgs/desktops/plasma-5.4/kscreen.nix
+++ b/pkgs/desktops/plasma-5.4/kscreen.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kconfig
 , kconfigwidgets
@@ -11,7 +11,7 @@
 , qtdeclarative
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kscreen";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/ksshaskpass.nix b/pkgs/desktops/plasma-5.4/ksshaskpass.nix
index 5593cebabf3b..d20a44df0ac8 100644
--- a/pkgs/desktops/plasma-5.4/ksshaskpass.nix
+++ b/pkgs/desktops/plasma-5.4/ksshaskpass.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kcoreaddons
@@ -7,7 +7,7 @@
 , kwidgetsaddons
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "ksshaskpass";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/ksysguard.nix b/pkgs/desktops/plasma-5.4/ksysguard.nix
index 8e6dc42c77b6..23a7c04cca20 100644
--- a/pkgs/desktops/plasma-5.4/ksysguard.nix
+++ b/pkgs/desktops/plasma-5.4/ksysguard.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kconfig
@@ -11,7 +11,7 @@
 , libksysguard
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "ksysguard";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kwayland.nix b/pkgs/desktops/plasma-5.4/kwayland.nix
index bb18e31d3ab3..e4d6eb631f95 100644
--- a/pkgs/desktops/plasma-5.4/kwayland.nix
+++ b/pkgs/desktops/plasma-5.4/kwayland.nix
@@ -1,9 +1,9 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , wayland
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kwayland";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kwin/default.nix b/pkgs/desktops/plasma-5.4/kwin/default.nix
index b4663e3c4372..429d336f661a 100644
--- a/pkgs/desktops/plasma-5.4/kwin/default.nix
+++ b/pkgs/desktops/plasma-5.4/kwin/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , epoxy
@@ -36,7 +36,7 @@
 , xcb-util-cursor
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kwin";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/kwrited.nix b/pkgs/desktops/plasma-5.4/kwrited.nix
index 7ab1de77760c..afd69073227c 100644
--- a/pkgs/desktops/plasma-5.4/kwrited.nix
+++ b/pkgs/desktops/plasma-5.4/kwrited.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kcoreaddons
 , ki18n
@@ -7,7 +7,7 @@
 , kdbusaddons
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "kwrited";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/libkscreen/default.nix b/pkgs/desktops/plasma-5.4/libkscreen/default.nix
index ea6a0b0b0fbf..8f5212e76c85 100644
--- a/pkgs/desktops/plasma-5.4/libkscreen/default.nix
+++ b/pkgs/desktops/plasma-5.4/libkscreen/default.nix
@@ -1,10 +1,10 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , libXrandr
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "libkscreen";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/libksysguard.nix b/pkgs/desktops/plasma-5.4/libksysguard.nix
index ab8a1f3323ed..d36eadb3b4f8 100644
--- a/pkgs/desktops/plasma-5.4/libksysguard.nix
+++ b/pkgs/desktops/plasma-5.4/libksysguard.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kauth
 , kcompletion
@@ -16,7 +16,7 @@
 , kiconthemes
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "libksysguard";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/milou.nix b/pkgs/desktops/plasma-5.4/milou.nix
index c9219a1d9f25..86698e8aee63 100644
--- a/pkgs/desktops/plasma-5.4/milou.nix
+++ b/pkgs/desktops/plasma-5.4/milou.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , qtscript
 , qtdeclarative
@@ -10,7 +10,7 @@
 , krunner
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "milou";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/oxygen-fonts.nix b/pkgs/desktops/plasma-5.4/oxygen-fonts.nix
index 627cc9e420f3..b1ccb6f5ffd5 100644
--- a/pkgs/desktops/plasma-5.4/oxygen-fonts.nix
+++ b/pkgs/desktops/plasma-5.4/oxygen-fonts.nix
@@ -1,9 +1,9 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , fontforge
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "oxygen-fonts";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/oxygen.nix b/pkgs/desktops/plasma-5.4/oxygen.nix
index 445cb673f4e5..5d221bc92b63 100644
--- a/pkgs/desktops/plasma-5.4/oxygen.nix
+++ b/pkgs/desktops/plasma-5.4/oxygen.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , ki18n
 , kcmutils
@@ -13,7 +13,7 @@
 , qtx11extras
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "oxygen";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix b/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
index 2051a5060b81..b89496dfd795 100644
--- a/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , substituteAll
 , extra-cmake-modules
 , kdoctools
@@ -43,7 +43,7 @@
 , utillinux
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-desktop";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix b/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
index 6db9ec9289b4..6b21eed5a957 100644
--- a/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , baloo
 , kactivities
@@ -16,7 +16,7 @@
 , taglib
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-mediacenter";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-nm.nix b/pkgs/desktops/plasma-5.4/plasma-nm.nix
index fc0d9b670a49..1cf3ec27b36e 100644
--- a/pkgs/desktops/plasma-5.4/plasma-nm.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-nm.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kcompletion
@@ -27,7 +27,7 @@
 , solid
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-nm";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-pa.nix b/pkgs/desktops/plasma-5.4/plasma-pa.nix
index c7fe02952cd6..e82a5b814a6a 100644
--- a/pkgs/desktops/plasma-5.4/plasma-pa.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-pa.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , glib
 , kconfigwidgets
@@ -10,7 +10,7 @@
 , plasma-framework
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-pa";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-workspace-wallpapers.nix b/pkgs/desktops/plasma-5.4/plasma-workspace-wallpapers.nix
index f3cfd16e299d..bc87abcad153 100644
--- a/pkgs/desktops/plasma-5.4/plasma-workspace-wallpapers.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-workspace-wallpapers.nix
@@ -1,8 +1,8 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-workspace-wallpapers";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
index 39c77862a76e..f9339f808062 100644
--- a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , baloo
@@ -53,7 +53,7 @@
 , xsetroot
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "plasma-workspace";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/polkit-kde-agent.nix b/pkgs/desktops/plasma-5.4/polkit-kde-agent.nix
index e4075c0776ef..a38c68d62dcc 100644
--- a/pkgs/desktops/plasma-5.4/polkit-kde-agent.nix
+++ b/pkgs/desktops/plasma-5.4/polkit-kde-agent.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , ki18n
 , kwindowsystem
@@ -12,7 +12,7 @@
 , polkitQt
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "polkit-kde-agent";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/powerdevil.nix b/pkgs/desktops/plasma-5.4/powerdevil.nix
index b3ce095f5db2..9427638936e5 100644
--- a/pkgs/desktops/plasma-5.4/powerdevil.nix
+++ b/pkgs/desktops/plasma-5.4/powerdevil.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kactivities
@@ -18,7 +18,7 @@
 , udev
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "powerdevil";
   nativeBuildInputs = [
     extra-cmake-modules
diff --git a/pkgs/desktops/plasma-5.4/systemsettings.nix b/pkgs/desktops/plasma-5.4/systemsettings.nix
index 45821aaf9347..089dc2790665 100644
--- a/pkgs/desktops/plasma-5.4/systemsettings.nix
+++ b/pkgs/desktops/plasma-5.4/systemsettings.nix
@@ -1,4 +1,4 @@
-{ mkDerivation
+{ plasmaPackage
 , extra-cmake-modules
 , kdoctools
 , kitemviews
@@ -14,7 +14,7 @@
 , khtml
 }:
 
-mkDerivation {
+plasmaPackage {
   name = "systemsettings";
   nativeBuildInputs = [
     extra-cmake-modules