summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2015-05-02 14:53:37 +0200
committerLuca Bruno <lucabru@src.gnome.org>2015-05-02 14:53:37 +0200
commit8882805b07c0d71dfd7232cafea875fa6fb3751f (patch)
tree4125a3939b91fdbfba25dd7e4f6fd545fb716856 /pkgs/desktops
parent473628b2203635b2f8b7e119a59bcd65b843eab3 (diff)
downloadnixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar.gz
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar.bz2
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar.lz
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar.xz
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.tar.zst
nixlib-8882805b07c0d71dfd7232cafea875fa6fb3751f.zip
Add vte 2.90 to gnome 3.16 in case anybody still wants it
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.16/core/vte/2.90.nix40
-rw-r--r--pkgs/desktops/gnome-3/3.16/default.nix2
2 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/3.16/core/vte/2.90.nix b/pkgs/desktops/gnome-3/3.16/core/vte/2.90.nix
new file mode 100644
index 000000000000..5ccca36bcaad
--- /dev/null
+++ b/pkgs/desktops/gnome-3/3.16/core/vte/2.90.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, intltool, pkgconfig, gnome3, ncurses, gobjectIntrospection }:
+
+stdenv.mkDerivation rec {
+  versionMajor = "0.36";
+  versionMinor = "3";
+  moduleName   = "vte";
+
+  name = "${moduleName}-${versionMajor}.${versionMinor}";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${moduleName}/${versionMajor}/${name}.tar.xz";
+    sha256 = "54e5b07be3c0f7b158302f54ee79d4de1cb002f4259b6642b79b1e0e314a959c";
+  };
+
+  buildInputs = [ gobjectIntrospection intltool pkgconfig gnome3.glib gnome3.gtk3 ncurses ];
+
+  configureFlags = [ "--enable-introspection" ];
+
+  enableParallelBuilding = true;
+
+  postInstall = ''
+    substituteInPlace $out/lib/libvte2_90.la --replace "-lncurses" "-L${ncurses}/lib -lncurses"
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://www.gnome.org/;
+    description = "A library implementing a terminal emulator widget for GTK+";
+    longDescription = ''
+      VTE is a library (libvte) implementing a terminal emulator widget for
+      GTK+, and a minimal sample application (vte) using that.  Vte is
+      mainly used in gnome-terminal, but can also be used to embed a
+      console/terminal in games, editors, IDEs, etc. VTE supports Unicode and
+      character set conversion, as well as emulating any terminal known to
+      the system's terminfo database.
+    '';
+    license = licenses.lgpl2;
+    maintainers = with maintainers; [ astsmtl antono lethalman ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/desktops/gnome-3/3.16/default.nix b/pkgs/desktops/gnome-3/3.16/default.nix
index 937d73b9421c..933e89dcd647 100644
--- a/pkgs/desktops/gnome-3/3.16/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/default.nix
@@ -222,6 +222,8 @@ rec {
 
   vte = callPackage ./core/vte { };
 
+  vte_290 = callPackage ./core/vte/2.90.nix { };
+
   vte-select-text = vte.override { selectTextPatch = true; };
 
   vino = callPackage ./core/vino { };