summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2017-04-24 08:14:21 +0200
committerGitHub <noreply@github.com>2017-04-24 08:14:21 +0200
commit80828429d70e2cfd6bc41c9f2dd5e364c9ab706c (patch)
tree98e6935c3a2730aca768c283d0e2adeeac79d2f7 /pkgs/desktops
parent2df7f1b5b5ad5c1a4805f6d756ede50e0930e9eb (diff)
parent2060f5b1fc2897e4fe2c48f9da3048865f5764c6 (diff)
downloadnixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar.gz
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar.bz2
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar.lz
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar.xz
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.tar.zst
nixlib-80828429d70e2cfd6bc41c9f2dd5e364c9ab706c.zip
Merge pull request #25066 from matthewbauer/less-darwin-eval-errors
Add Darwin as platform to various "broken" packages that actually build
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.22/core/dconf/default.nix7
-rw-r--r--pkgs/desktops/gnome-3/3.22/core/vte/default.nix4
2 files changed, 8 insertions, 3 deletions
diff --git a/pkgs/desktops/gnome-3/3.22/core/dconf/default.nix b/pkgs/desktops/gnome-3/3.22/core/dconf/default.nix
index f67dc7e32ae0..9200c4180bd2 100644
--- a/pkgs/desktops/gnome-3/3.22/core/dconf/default.nix
+++ b/pkgs/desktops/gnome-3/3.22/core/dconf/default.nix
@@ -18,8 +18,13 @@ stdenv.mkDerivation rec {
   buildInputs = [ vala_0_32 libxslt pkgconfig glib dbus_glib gnome3.gtk libxml2
                   intltool docbook_xsl docbook_xsl_ns makeWrapper ];
 
+  postConfigure = stdenv.lib.optionalString stdenv.isDarwin ''
+    substituteInPlace client/Makefile \
+      --replace "-soname=libdconf.so.1" "-install_name,libdconf.so.1"
+  '';
+
   meta = with stdenv.lib; {
-    platforms = platforms.linux;
+    platforms = platforms.linux ++ platforms.darwin;
     maintainers = gnome3.maintainers;
   };
 }
diff --git a/pkgs/desktops/gnome-3/3.22/core/vte/default.nix b/pkgs/desktops/gnome-3/3.22/core/vte/default.nix
index 50aef658713a..3181348d843c 100644
--- a/pkgs/desktops/gnome-3/3.22/core/vte/default.nix
+++ b/pkgs/desktops/gnome-3/3.22/core/vte/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
 
   preConfigure = "patchShebangs .";
 
-  configureFlags = [ "--enable-introspection" ];
+  configureFlags = [ "--enable-introspection" "--disable-Bsymbolic" ];
 
   enableParallelBuilding = true;
 
@@ -30,7 +30,7 @@ stdenv.mkDerivation rec {
     '';
     license = licenses.lgpl2;
     maintainers = with maintainers; [ astsmtl antono lethalman ];
-    platforms = platforms.linux;
+    platforms = platforms.linux ++ platforms.darwin;
   };
 }