summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJoachim Schiele <js@lastlog.de>2013-07-31 18:15:53 +0000
committerJoachim Schiele <js@lastlog.de>2013-08-15 16:25:02 +0000
commit7b5a92c49d752a8bed755aae0c11fd95e0c09c51 (patch)
treedf932b9205964c8cf5e4560e716f2181e663d34f /pkgs/desktops
parent91ad63716cc6ea27598023493b542b086d3bd428 (diff)
downloadnixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar.gz
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar.bz2
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar.lz
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar.xz
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.tar.zst
nixlib-7b5a92c49d752a8bed755aae0c11fd95e0c09c51.zip
fixed patch rejection and added RPATH magic
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/kde-4.10/kdebindings/smokegen-CMakeLists.txt-nix.patch14
-rw-r--r--pkgs/desktops/kde-4.10/kdebindings/smokegen-SmokeConfig.cmake.in-nix.patch (renamed from pkgs/desktops/kde-4.10/kdebindings/smokegen-nix.patch)0
-rw-r--r--pkgs/desktops/kde-4.10/kdebindings/smokegen.nix2
3 files changed, 15 insertions, 1 deletions
diff --git a/pkgs/desktops/kde-4.10/kdebindings/smokegen-CMakeLists.txt-nix.patch b/pkgs/desktops/kde-4.10/kdebindings/smokegen-CMakeLists.txt-nix.patch
new file mode 100644
index 000000000000..33ec3df6452d
--- /dev/null
+++ b/pkgs/desktops/kde-4.10/kdebindings/smokegen-CMakeLists.txt-nix.patch
@@ -0,0 +1,14 @@
+--- smokegen-4.10.5.orig/CMakeLists.txt 2013-06-28 17:14:50.000000000 +0000
++++ smokegen-4.10.5/CMakeLists.txt      2013-07-31 19:15:17.000000000 +0000
+@@ -36,6 +36,10 @@
+ set (CMAKE_SKIP_BUILD_RPATH FALSE)
+ set (CMAKE_SKIP_RPATH FALSE)
+
++# add the automatically determined parts of the RPATH
++# which point to directories outside the build tree to the install RPATH
++SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
++
+ configure_file( ${CMAKE_CURRENT_SOURCE_DIR}/config.h.in config.h @ONLY )
+
+ add_executable(smokegen ${generator_SRC})
+
diff --git a/pkgs/desktops/kde-4.10/kdebindings/smokegen-nix.patch b/pkgs/desktops/kde-4.10/kdebindings/smokegen-SmokeConfig.cmake.in-nix.patch
index 53257e836e04..53257e836e04 100644
--- a/pkgs/desktops/kde-4.10/kdebindings/smokegen-nix.patch
+++ b/pkgs/desktops/kde-4.10/kdebindings/smokegen-SmokeConfig.cmake.in-nix.patch
diff --git a/pkgs/desktops/kde-4.10/kdebindings/smokegen.nix b/pkgs/desktops/kde-4.10/kdebindings/smokegen.nix
index 8b5da2a641dd..0a3f2a85efaf 100644
--- a/pkgs/desktops/kde-4.10/kdebindings/smokegen.nix
+++ b/pkgs/desktops/kde-4.10/kdebindings/smokegen.nix
@@ -4,7 +4,7 @@ kde {
   buildInputs = [ qt4 ];
   nativeBuildInputs = [ cmake ];
 
-  patches = [ ./smokegen-nix.patch ];
+  patches = [ ./smokegen-SmokeConfig.cmake.in-nix.patch ./smokegen-CMakeLists.txt-nix.patch ];
 
   meta = {
     description = "C++ parser used to generate language bindings for Qt/KDE";