summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorNicolas Petton <nicolas@petton.fr>2016-04-15 10:49:43 +0200
committerDamien Cassou <damien@cassou.me>2016-07-08 17:26:15 +0200
commit75492617979f9bd11889bc980024ee62acdf52e8 (patch)
tree07c41844eb7edcabf24049e36bb9b8a1ac4ecf1f /pkgs/desktops
parent7f41dca05ad1ca4e84930a0f8e3891f4cb5a23a2 (diff)
downloadnixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar.gz
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar.bz2
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar.lz
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar.xz
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.tar.zst
nixlib-75492617979f9bd11889bc980024ee62acdf52e8.zip
gnome-shell: add missing python3 deps for gnome-shell-extension-tool
Fix #14651
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.20/core/gnome-shell/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/pkgs/desktops/gnome-3/3.20/core/gnome-shell/default.nix b/pkgs/desktops/gnome-3/3.20/core/gnome-shell/default.nix
index 11d78cd61328..d0d7bceef61f 100644
--- a/pkgs/desktops/gnome-3/3.20/core/gnome-shell/default.nix
+++ b/pkgs/desktops/gnome-3/3.20/core/gnome-shell/default.nix
@@ -1,5 +1,5 @@
 { fetchurl, stdenv, pkgconfig, gnome3, json_glib, libcroco, intltool, libsecret
-, python3, libsoup, polkit, clutter, networkmanager, docbook_xsl, docbook_xsl_ns, at_spi2_core
+, python3Packages, libsoup, polkit, clutter, networkmanager, docbook_xsl , docbook_xsl_ns, at_spi2_core
 , libstartup_notification, telepathy_glib, telepathy_logger, libXtst, p11_kit, unzip
 , sqlite, libgweather, libcanberra_gtk3
 , libpulseaudio, libical, libtool, nss, gobjectIntrospection, gstreamer, makeWrapper
@@ -15,16 +15,18 @@ stdenv.mkDerivation rec {
 
   buildInputs = with gnome3;
     [ gsettings_desktop_schemas gnome_keyring gnome-menus glib gcr json_glib accountsservice
-      libcroco intltool libsecret pkgconfig python3 libsoup polkit libcanberra gdk_pixbuf librsvg
+      libcroco intltool libsecret pkgconfig libsoup polkit libcanberra gdk_pixbuf librsvg
       clutter networkmanager libstartup_notification telepathy_glib docbook_xsl docbook_xsl_ns
       libXtst p11_kit networkmanagerapplet gjs mutter libpulseaudio caribou evolution_data_server
-      libical libtool nss gobjectIntrospection gtk gstreamer makeWrapper gdm
+      libical libtool nss gtk gstreamer makeWrapper gdm
       libcanberra_gtk3 gnome_control_center
       defaultIconTheme sqlite gnome3.gnome-bluetooth
       libgweather # not declared at build time, but typelib is needed at runtime
       gnome3.gnome-clocks # schemas needed
       at_spi2_core upower ibus gnome_session gnome_desktop telepathy_logger gnome3.gnome_settings_daemon ];
 
+  propagatedBuildInputs = [ python3Packages.pygobject3 python3Packages.python gobjectIntrospection ];
+
   installFlags = [ "keysdir=$(out)/share/gnome-control-center/keybindings" ];
 
   preBuild = ''
@@ -40,6 +42,9 @@ stdenv.mkDerivation rec {
       --prefix XDG_DATA_DIRS : "${gnome_themes_standard}/share:$out/share:$XDG_ICON_DIRS" \
       --suffix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH"
 
+    wrapProgram "$out/bin/gnome-shell-extension-tool" \
+      --prefix PYTHONPATH : "${python3Packages.pygobject3}/${python3Packages.python.sitePackages}:$PYTHONPATH"
+
     wrapProgram "$out/libexec/gnome-shell-calendar-server" \
       --prefix XDG_DATA_DIRS : "${evolution_data_server}/share:$out/share:$XDG_ICON_DIRS:$GSETTINGS_SCHEMAS_PATH"