summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorAmbroz Bizjak <ambrop7@gmail.com>2015-04-05 09:54:38 +0200
committerThomas Tuegel <ttuegel@gmail.com>2015-04-07 11:26:49 -0500
commit6e3642b89e0e233f0827df1882fb0730c0442f55 (patch)
tree2c7c0a388031da8c9acfc509c6312466d742e2d5 /pkgs/desktops
parente8932ddcefb15f1d9b20b9171b2753e1e32ace14 (diff)
downloadnixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar.gz
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar.bz2
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar.lz
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar.xz
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.tar.zst
nixlib-6e3642b89e0e233f0827df1882fb0730c0442f55.zip
Plasma 5.2.2: Fix startkde due to qdbus and qtpaths moving to qt5.base in Qt5.4.
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.2/startkde/default.nix2
-rw-r--r--pkgs/desktops/plasma-5.2/startkde/startkde.in14
2 files changed, 8 insertions, 8 deletions
diff --git a/pkgs/desktops/plasma-5.2/startkde/default.nix b/pkgs/desktops/plasma-5.2/startkde/default.nix
index 62f51ec8522e..624c5d239d5d 100644
--- a/pkgs/desktops/plasma-5.2/startkde/default.nix
+++ b/pkgs/desktops/plasma-5.2/startkde/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation {
 
   inherit bash gnused gnugrep kconfig kinit kservice socat;
   inherit (xorg) mkfontdir xmessage xprop xrdb xset xsetroot;
-  qt5 = qt5.base;
+  qt5tools = qt5.tools;
   dbus_tools = dbus.tools;
   plasmaWorkspace = plasma-workspace;
   plasmaDesktop = plasma-desktop;
diff --git a/pkgs/desktops/plasma-5.2/startkde/startkde.in b/pkgs/desktops/plasma-5.2/startkde/startkde.in
index 0693f1027817..0825a0733f43 100644
--- a/pkgs/desktops/plasma-5.2/startkde/startkde.in
+++ b/pkgs/desktops/plasma-5.2/startkde/startkde.in
@@ -63,7 +63,7 @@ fi
 # * Then ksmserver is started which takes control of the rest of the startup sequence
 
 # We need to create config folder so we can write startupconfigkeys
-configDir=$(@qt5@/bin/qtpaths --writable-path GenericConfigLocation)
+configDir=$(@qt5tools@/bin/qtpaths --writable-path GenericConfigLocation)
 mkdir -p "$configDir"
 
 # This is basically setting defaults so we can use them with kstartupconfig5
@@ -133,7 +133,7 @@ unset DESKTOP_LOCKED # Don't want it in the environment
 if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
     eval `@dbus_tools@/bin/dbus-launch --sh-syntax --exit-with-session`
 fi
-if @qt5@/bin/qdbus >/dev/null 2>/dev/null; then
+if @qt5tools@/bin/qdbus >/dev/null 2>/dev/null; then
     : # ok
 else
     echo 'startkde: Could not start D-Bus. Can you call qdbus?'  1>&2
@@ -170,7 +170,7 @@ fi
 # For anything else (that doesn't set env vars, or that needs a window manager),
 # better use the Autostart folder.
 
-scriptpath=$(@qt5@/bin/qtpaths --paths GenericConfigLocation | tr ':' '\n' | @gnused@/bin/sed 's,$,/plasma-workspace,g')
+scriptpath=$(@qt5tools@/bin/qtpaths --paths GenericConfigLocation | tr ':' '\n' | @gnused@/bin/sed 's,$,/plasma-workspace,g')
 
 # Add /env/ to the directory to locate the scripts to be sourced
 for prefix in `echo $scriptpath`; do
@@ -180,7 +180,7 @@ for prefix in `echo $scriptpath`; do
 done
 
 # Set the path for Qt plugins provided by KDE
-QT_PLUGIN_PATH=${QT_PLUGIN_PATH+$QT_PLUGIN_PATH:}`@qt5@/bin/qtpaths --plugin-dir`
+QT_PLUGIN_PATH=${QT_PLUGIN_PATH+$QT_PLUGIN_PATH:}`@qt5tools@/bin/qtpaths --plugin-dir`
 # TODO: Do we really need this?
 QT_PLUGIN_PATH=$QT_PLUGIN_PATH:$kdehome/lib/kde5/plugins/
 export QT_PLUGIN_PATH
@@ -336,13 +336,13 @@ if test x"$wait_drkonqi"x = x"true"x ; then
     # wait for remaining drkonqi instances with timeout (in seconds)
     wait_drkonqi_timeout=`@kconfig@/bin/kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
     wait_drkonqi_counter=0
-    while @qt5@/bin/qdbus | @gnugrep@/bin/grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
+    while @qt5tools@/bin/qdbus | @gnugrep@/bin/grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
         sleep 5
         wait_drkonqi_counter=$((wait_drkonqi_counter+5))
         if test "$wait_drkonqi_counter" -ge "$wait_drkonqi_timeout" ; then
             # ask remaining drkonqis to die in a graceful way
-            @qt5@/bin/qdbus | @gnugrep@/bin/grep 'org.kde.drkonqi-' | while read address ; do
-                @qt5@/bin/qdbus "$address" "/MainApplication" "quit"
+            @qt5tools@/bin/qdbus | @gnugrep@/bin/grep 'org.kde.drkonqi-' | while read address ; do
+                @qt5tools@/bin/qdbus "$address" "/MainApplication" "quit"
             done
             break
         fi