summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-11-18 11:29:47 -0600
committerGitHub <noreply@github.com>2016-11-18 11:29:47 -0600
commit6cd867dd4c72c27a02c8873494594259bc154943 (patch)
tree5d93e9204c9280e83d9175eec4e9002ea1593dda /pkgs/desktops
parente8bb0a5ef7e0f0d94bdb96ece9da8fffa25fe9cf (diff)
parent5ab9ad1ce274bf7c4db75eb049b567f39750338f (diff)
downloadnixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar.gz
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar.bz2
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar.lz
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar.xz
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.tar.zst
nixlib-6cd867dd4c72c27a02c8873494594259bc154943.zip
Merge pull request #20433 from ttuegel/install-cd-kde-5
Use KDE 5 for the graphical installation DVD
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/kde-5/plasma/default.nix8
-rw-r--r--pkgs/desktops/kde-5/plasma/oxygen.nix27
-rw-r--r--pkgs/desktops/kde-5/plasma/plasma-desktop/default.nix5
-rwxr-xr-xpkgs/desktops/kde-5/plasma/startkde/startkde.sh38
4 files changed, 57 insertions, 21 deletions
diff --git a/pkgs/desktops/kde-5/plasma/default.nix b/pkgs/desktops/kde-5/plasma/default.nix
index bb123fcdab44..36850824d63c 100644
--- a/pkgs/desktops/kde-5/plasma/default.nix
+++ b/pkgs/desktops/kde-5/plasma/default.nix
@@ -44,14 +44,6 @@ let
       inherit (srcs.breeze) src version;
     };
     breeze-qt5 = callPackage ./breeze-qt5.nix {};
-    breeze =
-      let
-        version = (builtins.parseDrvName breeze-qt5.name).version;
-      in
-        symlinkJoin {
-          name = "breeze-${version}";
-          paths = map (pkg: pkg.out or pkg) [ breeze-gtk breeze-qt4 breeze-qt5 ];
-        };
     breeze-grub = callPackage ./breeze-grub.nix {};
     breeze-plymouth = callPackage ./breeze-plymouth {};
     kactivitymanagerd = callPackage ./kactivitymanagerd.nix {};
diff --git a/pkgs/desktops/kde-5/plasma/oxygen.nix b/pkgs/desktops/kde-5/plasma/oxygen.nix
index 44a7575526f1..f880f2e3ab23 100644
--- a/pkgs/desktops/kde-5/plasma/oxygen.nix
+++ b/pkgs/desktops/kde-5/plasma/oxygen.nix
@@ -1,19 +1,20 @@
 {
-  plasmaPackage,
-  ecm, makeQtWrapper,
+  plasmaPackage, kdeWrapper,
+  ecm,
   frameworkintegration, kcmutils, kcompletion, kconfig, kdecoration, kguiaddons,
   ki18n, kwidgetsaddons, kservice, kwayland, kwindowsystem, qtx11extras
 }:
 
-plasmaPackage {
-  name = "oxygen";
-  nativeBuildInputs = [ ecm makeQtWrapper ];
-  propagatedBuildInputs = [
-    frameworkintegration kcmutils kcompletion kconfig kdecoration kguiaddons
-    ki18n kservice kwayland kwidgetsaddons kwindowsystem qtx11extras
-  ];
-  postInstall = ''
-    wrapQtProgram "$out/bin/oxygen-demo5"
-    wrapQtProgram "$out/bin/oxygen-settings5"
-  '';
+let
+  unwrapped = plasmaPackage {
+    name = "oxygen";
+    nativeBuildInputs = [ ecm ];
+    propagatedBuildInputs = [
+      frameworkintegration kcmutils kcompletion kconfig kdecoration kguiaddons
+      ki18n kservice kwayland kwidgetsaddons kwindowsystem qtx11extras
+    ];
+  };
+in
+kdeWrapper unwrapped {
+  targets = [ "bin/oxygen-demo5" "bin/oxygen-settings5" ];
 }
diff --git a/pkgs/desktops/kde-5/plasma/plasma-desktop/default.nix b/pkgs/desktops/kde-5/plasma/plasma-desktop/default.nix
index 7e8823e2db96..8d4098ca31f2 100644
--- a/pkgs/desktops/kde-5/plasma/plasma-desktop/default.nix
+++ b/pkgs/desktops/kde-5/plasma/plasma-desktop/default.nix
@@ -38,4 +38,9 @@ plasmaPackage rec {
     "-DEvdev_INCLUDE_DIRS=${xf86inputevdev.dev}/include/xorg"
     "-DSynaptics_INCLUDE_DIRS=${xf86inputsynaptics.dev}/include/xorg"
   ];
+  postInstall = ''
+    # Display ~/Desktop contents on the desktop by default.
+    sed -i "$out/share/plasma/shells/org.kde.plasma.desktop/contents/defaults" \
+        -e 's/Containment=org.kde.desktopcontainment/Containment=org.kde.plasma.folder/'
+  '';
 }
diff --git a/pkgs/desktops/kde-5/plasma/startkde/startkde.sh b/pkgs/desktops/kde-5/plasma/startkde/startkde.sh
index 256f9949e834..63c62f12321e 100755
--- a/pkgs/desktops/kde-5/plasma/startkde/startkde.sh
+++ b/pkgs/desktops/kde-5/plasma/startkde/startkde.sh
@@ -6,6 +6,36 @@ export QT_PLUGIN_PATH="$QT_PLUGIN_PATH${QT_PLUGIN_PATH:+:}@QT_PLUGIN_PATH@"
 export QML_IMPORT_PATH="$QML_IMPORT_PATH${QML_IMPORT_PATH:+:}@QML_IMPORT_PATH@"
 export QML2_IMPORT_PATH="$QML2_IMPORT_PATH${QML2_IMPORT_PATH:+:}@QML2_IMPORT_PATH@"
 
+# Set the default GTK 2 theme
+if ! [ -e $HOME/.gtkrc-2.0 ] \
+     && [ -e /run/current-system/sw/share/themes/Breeze/gtk-2.0/gtkrc ]; then
+    cat >$HOME/.gtkrc-2.0 <<EOF
+# Default GTK+ 2 config for NixOS KDE 5
+include "/run/current-system/sw/share/themes/Breeze/gtk-2.0/gtkrc"
+gtk-theme-name="Breeze"
+gtk-icon-theme-name="breeze"
+gtk-fallback-icon-theme="hicolor"
+gtk-cursor-theme-name="breeze_cursors"
+gtk-toolbar-style=GTK_TOOLBAR_ICONS
+gtk-menu-images=1
+gtk-button-images=1
+EOF
+fi
+
+if ! [ -e $HOME/.config/gtk-3.0/settings.ini ] \
+       && [ -e /run/current-system/sw/share/themes/Breeze/gtk-3.0 ]; then
+    cat >$HOME/.config/gtk-3.0/settings.ini <<EOF
+[Settings]
+gtk-theme-name=Breeze
+gtk-icon-theme-name=breeze
+gtk-fallback-icon-theme=hicolor
+gtk-cursor-theme-name=breeze_cursors
+gtk-toolbar-style=GTK_TOOLBAR_ICONS
+gtk-menu-images=1
+gtk-button-images=1
+EOF
+fi
+
 # The KDE icon cache is supposed to update itself
 # automatically, but it uses the timestamp on the icon
 # theme directory as a trigger.  Since in Nix the
@@ -71,6 +101,14 @@ fi
 configDir=$(qtpaths --writable-path GenericConfigLocation)
 mkdir -p "$configDir"
 
+if ! [ -e $configDir/kcminputrc ]; then
+    cat >$configDir/kcminputrc <<EOF
+[Mouse]
+cursorTheme=breeze_cursors
+cursorSize=0
+EOF
+fi
+
 THEME=org.kde.breeze
 #This is basically setting defaults so we can use them with kstartupconfig5
 #We cannot set the equivilant of THEME here as it will generate an