summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-10-17 16:52:46 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-10-30 16:10:37 -0500
commit5df5e1f1651066c4d9293f6cdeb83f9d18a07704 (patch)
tree3ed10730d09c6f86617d056a72fabd6ba2e82393 /pkgs/desktops
parent2386bd7c61e899667b8a388b588557c132eb64a3 (diff)
downloadnixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar.gz
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar.bz2
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar.lz
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar.xz
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.tar.zst
nixlib-5df5e1f1651066c4d9293f6cdeb83f9d18a07704.zip
plasma54: propagate packages to user profile
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-desktop/default.nix5
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-mediacenter.nix5
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-workspace/default.nix5
3 files changed, 12 insertions, 3 deletions
diff --git a/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix b/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
index 77dfe3d91820..eb013292805a 100644
--- a/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-desktop/default.nix
@@ -9,7 +9,7 @@
 , libcanberra_kde, libpulseaudio, makeKDEWrapper, utillinux
 }:
 
-plasmaPackage {
+plasmaPackage rec {
   name = "plasma-desktop";
   nativeBuildInputs = [
     extra-cmake-modules
@@ -28,6 +28,9 @@ plasmaPackage {
     kglobalaccel ki18n kpeople krunner kwin plasma-framework
     plasma-workspace qtdeclarative qtx11extras
   ];
+  # All propagatedBuildInputs should be present in the profile because
+  # wrappers cannot be used here.
+  propagatedUserEnvPkgs = propagatedBuildInputs;
   patches = [
     (substituteAll {
       src = ./0001-hwclock.patch;
diff --git a/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix b/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
index 40912087b8c8..afd8a18bbbd6 100644
--- a/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-mediacenter.nix
@@ -4,7 +4,7 @@
 , taglib
 }:
 
-plasmaPackage {
+plasmaPackage rec {
   name = "plasma-mediacenter";
   nativeBuildInputs = [
     extra-cmake-modules
@@ -17,4 +17,7 @@ plasmaPackage {
     baloo kactivities kdeclarative kfilemetadata ki18n kio
     plasma-framework
   ];
+  # All propagatedBuildInputs should be present in the profile because
+  # wrappers cannot be used here.
+  propagatedUserEnvPkgs = propagatedBuildInputs;
 }
diff --git a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
index a2843a192907..37f55204ec1c 100644
--- a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
@@ -10,7 +10,7 @@
 , xprop, xrdb, xset, xsetroot, solid, qtquickcontrols
 }:
 
-plasmaPackage {
+plasmaPackage rec {
   name = "plasma-workspace";
   nativeBuildInputs = [
     extra-cmake-modules
@@ -28,6 +28,9 @@ plasmaPackage {
     kidletime krunner ktexteditor kwin libkscreen libksysguard
     plasma-framework qtquick1 qtquickcontrols qtx11extras solid
   ];
+  # All propagatedBuildInputs should be present in the profile because
+  # impure wrappers are used below.
+  propagatedUserEnvPkgs = propagatedBuildInputs;
   patches = [ ./0001-startkde-NixOS-patches.patch ];
 
   inherit bash coreutils gnused gnugrep socat;