summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorAlexander Ried <ried@mytum.de>2016-10-22 19:54:20 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-10-22 19:54:20 +0200
commit459da7b86ecbbd0816c20e6c7cce0ab4e5b08915 (patch)
tree0644958e6fddd7fbe0b949e7021fcdd92b8aa2f0 /pkgs/desktops
parente56832d7301f2be7c18abf12d151db00be88f6fa (diff)
downloadnixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar.gz
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar.bz2
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar.lz
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar.xz
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.tar.zst
nixlib-459da7b86ecbbd0816c20e6c7cce0ab4e5b08915.zip
gnome3: default to 3.22 (#19743)
* gnome3: default to 3.22

* zuki-themes: add src for gnome 3.22, remove 3.18

* gnome3_22.vte_290: copy from gnome3.20

* termite: use vte-select-text from gnome3_20
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.22/core/vte/2.90.nix40
-rw-r--r--pkgs/desktops/gnome-3/3.22/default.nix2
2 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/3.22/core/vte/2.90.nix b/pkgs/desktops/gnome-3/3.22/core/vte/2.90.nix
new file mode 100644
index 000000000000..cbb52c9aaa12
--- /dev/null
+++ b/pkgs/desktops/gnome-3/3.22/core/vte/2.90.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, intltool, pkgconfig, gnome3, ncurses, gobjectIntrospection }:
+
+stdenv.mkDerivation rec {
+  versionMajor = "0.36";
+  versionMinor = "3";
+  moduleName   = "vte";
+
+  name = "${moduleName}-${versionMajor}.${versionMinor}";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${moduleName}/${versionMajor}/${name}.tar.xz";
+    sha256 = "54e5b07be3c0f7b158302f54ee79d4de1cb002f4259b6642b79b1e0e314a959c";
+  };
+
+  buildInputs = [ gobjectIntrospection intltool pkgconfig gnome3.glib gnome3.gtk3 ncurses ];
+
+  configureFlags = [ "--enable-introspection" ];
+
+  enableParallelBuilding = true;
+
+  postInstall = ''
+    substituteInPlace $out/lib/libvte2_90.la --replace "-lncurses" "-L${ncurses.out}/lib -lncurses"
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://www.gnome.org/;
+    description = "A library implementing a terminal emulator widget for GTK+";
+    longDescription = ''
+      VTE is a library (libvte) implementing a terminal emulator widget for
+      GTK+, and a minimal sample application (vte) using that.  Vte is
+      mainly used in gnome-terminal, but can also be used to embed a
+      console/terminal in games, editors, IDEs, etc. VTE supports Unicode and
+      character set conversion, as well as emulating any terminal known to
+      the system's terminfo database.
+    '';
+    license = licenses.lgpl2;
+    maintainers = with maintainers; [ astsmtl antono lethalman ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/desktops/gnome-3/3.22/default.nix b/pkgs/desktops/gnome-3/3.22/default.nix
index 926694f48d40..3ebd964ab0ec 100644
--- a/pkgs/desktops/gnome-3/3.22/default.nix
+++ b/pkgs/desktops/gnome-3/3.22/default.nix
@@ -232,6 +232,8 @@ let
 
   vte = callPackage ./core/vte { };
 
+  vte_290 = callPackage ./core/vte/2.90.nix { };
+
   vino = callPackage ./core/vino { };
 
   yelp = callPackage ./core/yelp { };