summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-04-01 11:33:00 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-04-01 11:33:00 +0000
commit3d6086c7a71e1677c53c708507b9114b41e2c786 (patch)
tree48ebf20c8388d3c862bb2739d86520a847cdf4c3 /pkgs/desktops
parent151bd1c17f551f26dc9ca860acb45585b74c866c (diff)
downloadnixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar.gz
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar.bz2
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar.lz
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar.xz
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.tar.zst
nixlib-3d6086c7a71e1677c53c708507b9114b41e2c786.zip
* Fix the kdelibs 3.5 build on the current Linux kernel headers (where
  linux/inotify.h shouldn't be used anymore).

svn path=/nixpkgs/branches/stdenv-updates/; revision=14822
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/kde-3/kdelibs/default.nix6
-rw-r--r--pkgs/desktops/kde-3/kdelibs/inotify.patch30
2 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/desktops/kde-3/kdelibs/default.nix b/pkgs/desktops/kde-3/kdelibs/default.nix
index 86a85ab042bb..984e72c8d7bd 100644
--- a/pkgs/desktops/kde-3/kdelibs/default.nix
+++ b/pkgs/desktops/kde-3/kdelibs/default.nix
@@ -13,6 +13,12 @@ stdenv.mkDerivation {
     sha256 = "0wjw51r96h6rngbsrzndw890xggzvrakydsbaldlrvbh3jq9qzk1";
   };
 
+  patches = [
+    # We're not supposed to use linux/inotify.h, use sys/inotify.h instead.
+    # Adapted from Gentoo.
+    ./inotify.patch
+  ];
+
   passthru = {inherit openssl libjpeg qt; inherit (xlibs) libX11;};
   
   buildInputs = [
diff --git a/pkgs/desktops/kde-3/kdelibs/inotify.patch b/pkgs/desktops/kde-3/kdelibs/inotify.patch
new file mode 100644
index 000000000000..3d0b470811af
--- /dev/null
+++ b/pkgs/desktops/kde-3/kdelibs/inotify.patch
@@ -0,0 +1,30 @@
+diff -rc kdelibs-3.5.10-orig/kio/kio/kdirwatch.cpp kdelibs-3.5.10/kio/kio/kdirwatch.cpp
+*** kdelibs-3.5.10-orig/kio/kio/kdirwatch.cpp	2006-07-22 10:16:37.000000000 +0200
+--- kdelibs-3.5.10/kio/kio/kdirwatch.cpp	2009-04-01 13:26:48.000000000 +0200
+***************
+*** 64,74 ****
+  // debug
+  #include <sys/ioctl.h>
+  
+! #ifdef HAVE_INOTIFY
+  #include <unistd.h>
+  #include <fcntl.h>
+  #include <sys/syscall.h>
+- #include <linux/types.h>
+  // Linux kernel headers are documented to not compile
+  #define _S390_BITOPS_H
+  #include <linux/inotify.h>
+--- 64,76 ----
+  // debug
+  #include <sys/ioctl.h>
+  
+! #if 1
+! #include <sys/inotify.h>
+! #include <fcntl.h>
+! #elif HAVE_INOTIFY
+  #include <unistd.h>
+  #include <fcntl.h>
+  #include <sys/syscall.h>
+  // Linux kernel headers are documented to not compile
+  #define _S390_BITOPS_H
+  #include <linux/inotify.h>