summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-12-11 07:21:50 -0600
committerThomas Tuegel <ttuegel@gmail.com>2015-12-11 07:21:50 -0600
commit3960ecb9337316fad483625a5e801e5527d4c693 (patch)
tree77080641df88be402b9f6f4597d350a3c9a2d48a /pkgs/desktops
parentc03b26ee0807e9654a308fe92347cb054abf87c6 (diff)
parent899c554f65ee60a39dbb93ed7d7eb9372dff6d14 (diff)
downloadnixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar.gz
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar.bz2
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar.lz
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar.xz
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.tar.zst
nixlib-3960ecb9337316fad483625a5e801e5527d4c693.zip
Merge branch 'plasma-5.5'
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.5/breeze-gtk.nix8
-rw-r--r--pkgs/desktops/plasma-5.5/default.nix3
2 files changed, 10 insertions, 1 deletions
diff --git a/pkgs/desktops/plasma-5.5/breeze-gtk.nix b/pkgs/desktops/plasma-5.5/breeze-gtk.nix
new file mode 100644
index 000000000000..179f15dc8763
--- /dev/null
+++ b/pkgs/desktops/plasma-5.5/breeze-gtk.nix
@@ -0,0 +1,8 @@
+{ plasmaPackage
+, extra-cmake-modules
+}:
+
+plasmaPackage {
+  name = "breeze-gtk";
+  nativeBuildInputs = [ extra-cmake-modules ];
+}
diff --git a/pkgs/desktops/plasma-5.5/default.nix b/pkgs/desktops/plasma-5.5/default.nix
index 33937aa32200..812c70c2b004 100644
--- a/pkgs/desktops/plasma-5.5/default.nix
+++ b/pkgs/desktops/plasma-5.5/default.nix
@@ -44,11 +44,12 @@ let
 
   addPackages = self: with self; {
     bluedevil = callPackage ./bluedevil.nix {};
+    breeze-gtk = callPackage ./breeze-gtk.nix {};
     breeze-qt4 = callPackage ./breeze-qt4.nix {};
     breeze-qt5 = callPackage ./breeze-qt5.nix {};
     breeze =
       let version = (builtins.parseDrvName breeze-qt5.name).version;
-      in symlinkJoin "breeze-${version}" [ breeze-qt4 breeze-qt5 ];
+      in symlinkJoin "breeze-${version}" [ breeze-gtk breeze-qt4 breeze-qt5 ];
     kde-cli-tools = callPackage ./kde-cli-tools.nix {};
     kde-gtk-config = callPackage ./kde-gtk-config {};
     kdecoration = callPackage ./kdecoration.nix {};