summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-07-31 18:08:44 +0200
committerGitHub <noreply@github.com>2018-07-31 18:08:44 +0200
commit315a47d249100045acdffe04e1dd32d2b8d63eaa (patch)
tree6729247dd3930c65691246459f428771c29aa577 /pkgs/desktops
parent0f3eaa0bd5b2b8e52beabe0615b5044b508b6999 (diff)
parente87a1a518268f76d159060ab27442f3db0c991b1 (diff)
downloadnixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar.gz
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar.bz2
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar.lz
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar.xz
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.tar.zst
nixlib-315a47d249100045acdffe04e1dd32d2b8d63eaa.zip
Merge pull request #43927 from volth/xfce4-battery-plugin-1.1.0
xfce4-13.xfce4-battery-plugin: init at 1.1.0
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce4-13/default.nix2
-rw-r--r--pkgs/desktops/xfce4-13/mkXfceDerivation.nix8
-rw-r--r--pkgs/desktops/xfce4-13/xfce4-battery-plugin/default.nix11
3 files changed, 17 insertions, 4 deletions
diff --git a/pkgs/desktops/xfce4-13/default.nix b/pkgs/desktops/xfce4-13/default.nix
index 6db207a79c56..9989ebed4bce 100644
--- a/pkgs/desktops/xfce4-13/default.nix
+++ b/pkgs/desktops/xfce4-13/default.nix
@@ -44,6 +44,8 @@ makeScope newScope (self: with self; {
 
   xfce4-appfinder = callPackage ./xfce4-appfinder { };
 
+  xfce4-battery-plugin = callPackage ./xfce4-battery-plugin { };
+
   xfce4-dev-tools = callPackage ./xfce4-dev-tools {
     mkXfceDerivation = mkXfceDerivation.override {
       xfce4-dev-tools = null;
diff --git a/pkgs/desktops/xfce4-13/mkXfceDerivation.nix b/pkgs/desktops/xfce4-13/mkXfceDerivation.nix
index f08272e9db07..da7179c46462 100644
--- a/pkgs/desktops/xfce4-13/mkXfceDerivation.nix
+++ b/pkgs/desktops/xfce4-13/mkXfceDerivation.nix
@@ -1,6 +1,6 @@
-{ stdenv, fetchgit, pkgconfig, xfce4-dev-tools ? null }:
+{ stdenv, fetchgit, pkgconfig, xfce4-dev-tools, hicolor-icon-theme }:
 
-{ category, pname, sha256 ? null, version, ... } @ args:
+{ category, pname, version, rev ? "${pname}-${version}", sha256, ... } @ args:
 
 let
   inherit (builtins) filter getAttr head isList;
@@ -16,12 +16,12 @@ let
     name = "${pname}-${version}";
 
     nativeBuildInputs = [ pkgconfig xfce4-dev-tools ];
+    buildInputs = [ hicolor-icon-theme ];
     configureFlags = [ "--enable-maintainer-mode" ];
 
     src = fetchgit {
       url = "git://git.xfce.org/${category}/${pname}";
-      rev = name;
-      inherit sha256;
+      inherit rev sha256;
     };
 
     enableParallelBuilding = true;
diff --git a/pkgs/desktops/xfce4-13/xfce4-battery-plugin/default.nix b/pkgs/desktops/xfce4-13/xfce4-battery-plugin/default.nix
new file mode 100644
index 000000000000..b4b5ff7b7148
--- /dev/null
+++ b/pkgs/desktops/xfce4-13/xfce4-battery-plugin/default.nix
@@ -0,0 +1,11 @@
+{ mkXfceDerivation, gtk3, libxfce4ui, libxfce4util, xfce4-panel, xfconf }:
+
+mkXfceDerivation rec {
+  category = "panel-plugins";
+  pname = "xfce4-battery-plugin";
+  version = "1.1.0";
+  rev = version;
+  sha256 = "0mz0lj3wjrsj9n4wcqrvv08430g38nkjbdimxdy8316n6bqgngfn";
+
+  buildInputs = [ gtk3 libxfce4ui libxfce4util xfce4-panel xfconf ];
+}