summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-05-03 17:09:50 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-05-03 17:09:50 -0500
commit2325791c2bea48b92fcfb8bbb1988928393cb1fd (patch)
treed2349559b24861ef9e40fbb27d53a7e1fdaf5f0c /pkgs/desktops
parente1cbfa5415810e92d6a5904d201a69a4a1f40bc0 (diff)
downloadnixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar.gz
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar.bz2
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar.lz
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar.xz
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.tar.zst
nixlib-2325791c2bea48b92fcfb8bbb1988928393cb1fd.zip
plasma53: patch upstream startkde
Rather than shipping our own startkde script, we will go back to
patching upstream's script. This will be less confusing to potential
contributors.
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.3/default.nix21
-rw-r--r--pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch397
-rw-r--r--pkgs/desktops/plasma-5.3/startkde/default.nix34
-rw-r--r--pkgs/desktops/plasma-5.3/startkde/kdeglobals11
-rw-r--r--pkgs/desktops/plasma-5.3/startkde/startkde.in374
-rw-r--r--pkgs/desktops/plasma-5.3/startkde/startupconfigkeys5
6 files changed, 410 insertions, 432 deletions
diff --git a/pkgs/desktops/plasma-5.3/default.nix b/pkgs/desktops/plasma-5.3/default.nix
index 20818a5c8464..bd840dff42d6 100644
--- a/pkgs/desktops/plasma-5.3/default.nix
+++ b/pkgs/desktops/plasma-5.3/default.nix
@@ -139,15 +139,25 @@ let
       };
 
       plasma-workspace = with pkgs; super.plasma-workspace // {
+        patches = [
+          (substituteAll {
+            src = ./plasma-workspace/0001-startkde-NixOS-patches.patch;
+            inherit (pkgs) bash gnused gnugrep socat;
+            inherit (kf5) kconfig kinit kservice;
+            inherit (pkgs.xorg) mkfontdir xmessage xprop xrdb xset xsetroot;
+            qt5tools = qt5.tools;
+            dbus_tools = pkgs.dbus.tools;
+          })
+        ];
         buildInputs = with xlibs;
           super.plasma-workspace.buildInputs ++ [ libSM libXcursor pam ];
         postPatch = ''
           substituteInPlace startkde/kstartupconfig/kstartupconfig.cpp \
             --replace kdostartupconfig5 $out/bin/kdostartupconfig5
         '';
-        postInstall = ''
-          # We use a custom startkde script
-          rm $out/bin/startkde
+        preConfigure = ''
+          substituteInPlace startkde/startkde.cmake \
+            --subst-var-by plasmaWorkspace "$out"
         '';
       };
 
@@ -175,9 +185,4 @@ let
 in
   plasma5 // {
     inherit kf5 scope;
-    startkde = pkgs.callPackage ./startkde {
-      inherit (kf5) kconfig kinit kservice;
-      inherit (plasma5) plasma-desktop plasma-workspace;
-      inherit qt5;
-    };
   }
diff --git a/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch b/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch
new file mode 100644
index 000000000000..68f32862b217
--- /dev/null
+++ b/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch
@@ -0,0 +1,397 @@
+From 9aa37de6cd887c6cdd7ea2356cbb6aecdb988b75 Mon Sep 17 00:00:00 2001
+From: Thomas Tuegel <ttuegel@gmail.com>
+Date: Sun, 3 May 2015 14:51:04 -0500
+Subject: [PATCH] startkde: NixOS patches
+
+---
+ startkde/startkde.cmake | 212 +++++++++++++++++++-----------------------------
+ 1 file changed, 85 insertions(+), 127 deletions(-)
+
+diff --git a/startkde/startkde.cmake b/startkde/startkde.cmake
+index 24e5c1b..d8642d3 100644
+--- a/startkde/startkde.cmake
++++ b/startkde/startkde.cmake
+@@ -1,8 +1,29 @@
+-#!/bin/sh
++#!@bash@/bin/bash
+ #
+ #  DEFAULT KDE STARTUP SCRIPT ( @PROJECT_VERSION@ )
+ #
+ 
++# The KDE icon cache is supposed to update itself
++# automatically, but it uses the timestamp on the icon
++# theme directory as a trigger.  Since in Nix the
++# timestamp is always the same, this doesn't work.  So as
++# a workaround, nuke the icon cache on login.  This isn't
++# perfect, since it may require logging out after
++# installing new applications to update the cache.
++# See http://lists-archives.org/kde-devel/26175-what-when-will-icon-cache-refresh.html
++rm -fv $HOME/.cache/icon-cache.kcache
++
++# Qt writes a weird ‘libraryPath’ line to
++# ~/.config/Trolltech.conf that causes the KDE plugin
++# paths of previous KDE invocations to be searched.
++# Obviously using mismatching KDE libraries is potentially
++# disastrous, so here we nuke references to the Nix store
++# in Trolltech.conf.  A better solution would be to stop
++# Qt from doing this wackiness in the first place.
++if [ -e $HOME/.config/Trolltech.conf ]; then
++    @gnused@/bin/sed -e '/nix\\store\|nix\/store/ d' -i $HOME/.config/Trolltech.conf
++fi
++
+ if test "x$1" = x--failsafe; then
+     KDE_FAILSAFE=1 # General failsafe flag
+     KWIN_COMPOSE=N # Disable KWin's compositing
+@@ -16,29 +37,16 @@ trap 'echo GOT SIGHUP' HUP
+ # we have to unset this for Darwin since it will screw up KDE's dynamic-loading
+ unset DYLD_FORCE_FLAT_NAMESPACE
+ 
+-# in case we have been started with full pathname spec without being in PATH
+-bindir=`echo "$0" | sed -n 's,^\(/.*\)/[^/][^/]*$,\1,p'`
+-if [ -n "$bindir" ]; then
+-  qbindir=`qtpaths --binaries-dir`
+-  qdbus=$qbindir/qdbus
+-  case $PATH in
+-    $bindir|$bindir:*|*:$bindir|*:$bindir:*) ;;
+-    *) PATH=$bindir:$PATH; export PATH;;
+-  esac
+-else
+-  qdbus=qdbus
+-fi
+-
+ # Check if a KDE session already is running and whether it's possible to connect to X
+ kcheckrunning
+ kcheckrunning_result=$?
+ if test $kcheckrunning_result -eq 0 ; then
+-	echo "KDE seems to be already running on this display."
+-	xmessage -geometry 500x100 "KDE seems to be already running on this display." > /dev/null 2>/dev/null
++  echo "KDE seems to be already running on this display."
++  @xmessage@/bin/xmessage -geometry 500x100 "KDE seems to be already running on this display."
+ 	exit 1
+ elif test $kcheckrunning_result -eq 2 ; then
+ 	echo "\$DISPLAY is not set or cannot connect to the X server."
+-        exit 1
++  exit 1
+ fi
+ 
+ # Boot sequence:
+@@ -56,13 +64,8 @@ fi
+ # * Then ksmserver is started which takes control of the rest of the startup sequence
+ 
+ # We need to create config folder so we can write startupconfigkeys
+-if [  ${XDG_CONFIG_HOME} ]; then
+-  configDir=$XDG_CONFIG_HOME;
+-else
+-  configDir=${HOME}/.config; #this is the default, http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
+-fi
+-
+-mkdir -p $configDir
++configDir=$(@qt5tools@/bin/qtpaths --writable-path GenericConfigLocation)
++mkdir -p "$configDir"
+ 
+ #This is basically setting defaults so we can use them with kstartupconfig5
+ cat >$configDir/startupconfigkeys <<EOF
+@@ -106,53 +109,19 @@ toolBarFont=Oxygen-Sans,9,-1,5,50,0,0,0,0,0
+ EOF
+ }
+ 
+-# Make sure the Oxygen font is installed
+-# This is necessary for setups where CMAKE_INSTALL_PREFIX
+-# is not in /usr. fontconfig looks in /usr, ~/.fonts and
+-# $XDG_DATA_HOME for fonts. In this case, we symlink the
+-# Oxygen font under ${XDG_DATA_HOME} and make it known to
+-# fontconfig
+-
+-usr_share="/usr/share"
+-install_share="@CMAKE_INSTALL_PREFIX@/@SHARE_INSTALL_PREFIX@"
+-
+-if [ ! $install_share = $usr_share ]; then
+-
+-    if [ ${XDG_DATA_HOME} ]; then
+-        fontsDir="${XDG_DATA_HOME}/fonts"
+-    else
+-        fontsDir="${HOME}/.fonts"
+-    fi
+-
+-    test -d $fontsDir || {
+-        mkdir -p $fontsDir
+-    }
+-
+-    oxygenDir=$fontsDir/oxygen
+-    prefixDir="@CMAKE_INSTALL_PREFIX@/@SHARE_INSTALL_PREFIX@/fonts/oxygen"
+-
+-    # if the oxygen dir doesn't exist, create a symlink to be sure that the
+-    # Oxygen font is available to the user
+-    test -d $oxygenDir || test -d $prefixDir && {
+-        test -h $oxygenDir || ln -s $prefixDir $oxygenDir && fc-cache $oxygenDir
+-    }
+-fi
+-
+ kstartupconfig5
+ returncode=$?
+ if test $returncode -ne 0; then
+-    xmessage -geometry 500x100 "kstartupconfig5 does not exist or fails. The error code is $returncode. Check your installation."
++    @xmessage@/bin/xmessage -geometry 500x100 "kstartupconfig5 does not exist or fails. The error code is $returncode. Check your installation."
+     exit 1
+ fi
+ [ -r $configDir/startupconfig ] && . $configDir/startupconfig
+ 
+-if test "$kdeglobals_kscreen_scalefactor" -ne 1; then
+-    export QT_DEVICE_PIXEL_RATIO=$kdeglobals_kscreen_scalefactor
+-fi
++XCURSOR_PATH=~/.icons:$(echo "$XDG_DATA_DIRS" | tr ":" "\n" | @gnused@/bin/sed 's,$,/icons,g' | tr "\n" ":")
++export XCURSOR_PATH
+ 
+ # XCursor mouse theme needs to be applied here to work even for kded or ksmserver
+ if test -n "$kcminputrc_mouse_cursortheme" -o -n "$kcminputrc_mouse_cursorsize" ; then
+-    @EXPORT_XCURSOR_PATH@
+ 
+     kapplymousetheme "$kcminputrc_mouse_cursortheme" "$kcminputrc_mouse_cursorsize"
+     if test $? -eq 10; then
+@@ -168,15 +137,33 @@ if test -n "$kcminputrc_mouse_cursortheme" -o -n "$kcminputrc_mouse_cursorsize"
+     fi
+ fi
+ 
+-if test "$kcmfonts_general_forcefontdpi" -ne 0; then
+-    xrdb -quiet -merge -nocpp <<EOF
+-Xft.dpi: $kcmfonts_general_forcefontdpi
+-EOF
+-fi
++# Set a left cursor instead of the standard X11 "X" cursor, since I've heard
++# from some users that they're confused and don't know what to do. This is
++# especially necessary on slow machines, where starting KDE takes one or two
++# minutes until anything appears on the screen.
++#
++# If the user has overwritten fonts, the cursor font may be different now
++# so don't move this up.
++#
++@xsetroot@/bin/xsetroot -cursor_name left_ptr
+ 
+ dl=$DESKTOP_LOCKED
+ unset DESKTOP_LOCKED # Don't want it in the environment
+ 
++# Make sure that D-Bus is running
++# D-Bus autolaunch is broken
++if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
++    eval `@dbus_tools@/dbus-launch --sh-syntax --exit-with-session`
++fi
++if @qt5tools@/bin/qdbus >/dev/null 2>/dev/null; then
++    : # ok
++else
++    echo 'startkde: Could not start D-Bus. Can you call qdbus?'  1>&2
++    test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
++    @xmessage@/bin/xmessage -geometry 500x100 "Could not start D-Bus. Can you call qdbus?"
++    exit 1
++fi
++
+ ksplash_pid=
+ if test -z "$dl"; then
+   # the splashscreen and progress indicator
+@@ -205,8 +192,7 @@ fi
+ # For anything else (that doesn't set env vars, or that needs a window manager),
+ # better use the Autostart folder.
+ 
+-# TODO: Use GenericConfigLocation once we depend on Qt 5.4
+-scriptpath=`qtpaths --paths ConfigLocation | tr ':' '\n' | sed 's,$,/plasma-workspace,g'`
++scriptpath=$(@qt5tools@/bin/qtpaths --paths GenericConfigLocation | tr ':' '\n' | @gnused@/bin/sed 's,$,/plasma-workspace,g')
+ 
+ # Add /env/ to the directory to locate the scripts to be sourced
+ for prefix in `echo $scriptpath`; do
+@@ -216,7 +202,7 @@ for prefix in `echo $scriptpath`; do
+ done
+ 
+ # Set the path for Qt plugins provided by KDE
+-QT_PLUGIN_PATH=${QT_PLUGIN_PATH+$QT_PLUGIN_PATH:}`qtpaths --plugin-dir`
++QT_PLUGIN_PATH=${QT_PLUGIN_PATH+$QT_PLUGIN_PATH:}`@qt5tools@/bin/qtpaths --plugin-dir`
+ # TODO: Do we really need this?
+ QT_PLUGIN_PATH=$QT_PLUGIN_PATH:$kdehome/lib/kde5/plugins/
+ export QT_PLUGIN_PATH
+@@ -242,7 +228,7 @@ usr_odir=$HOME/.fonts/kde-override
+ usr_fdir=$HOME/.fonts
+ 
+ if test -n "$KDEDIRS"; then
+-  kdedirs_first=`echo "$KDEDIRS"|sed -e 's/:.*//'`
++  kdedirs_first=`echo "$KDEDIRS" | @gnused@/bin/sed -e 's/:.*//'`
+   sys_odir=$kdedirs_first/share/fonts/override
+   sys_fdir=$kdedirs_first/share/fonts
+ else
+@@ -255,23 +241,13 @@ fi
+ # add the user's dirs to the font path, as they might simply have been made
+ # read-only by the administrator, for whatever reason.
+ 
+-test -d "$sys_odir" && xset +fp "$sys_odir"
+-test -d "$usr_odir" && (mkfontdir "$usr_odir" ; xset +fp "$usr_odir")
+-test -d "$usr_fdir" && (mkfontdir "$usr_fdir" ; xset fp+ "$usr_fdir")
+-test -d "$sys_fdir" && xset fp+ "$sys_fdir"
++test -d "$sys_odir" && @xset@/bin/xset +fp "$sys_odir"
++test -d "$usr_odir" && ( @mkfontdir@/bin/mkfontdir "$usr_odir" ; @xset@/bin/xset +fp "$usr_odir" )
++test -d "$usr_fdir" && ( @mkfontdir@/bin/mkfontdir "$usr_fdir" ; @xset@/bin/xset fp+ "$usr_fdir" )
++test -d "$sys_fdir" && @xset@/bin/xset fp+ "$sys_fdir"
+ 
+ # Ask X11 to rebuild its font list.
+-xset fp rehash
+-
+-# Set a left cursor instead of the standard X11 "X" cursor, since I've heard
+-# from some users that they're confused and don't know what to do. This is
+-# especially necessary on slow machines, where starting KDE takes one or two
+-# minutes until anything appears on the screen.
+-#
+-# If the user has overwritten fonts, the cursor font may be different now
+-# so don't move this up.
+-#
+-xsetroot -cursor_name left_ptr
++@xset@/bin/xset fp rehash
+ 
+ # Get Ghostscript to look into user's KDE fonts dir for additional Fontmap
+ if test -n "$GS_LIB" ; then
+@@ -284,30 +260,6 @@ fi
+ 
+ echo 'startkde: Starting up...'  1>&2
+ 
+-# Make sure that the KDE prefix is first in XDG_DATA_DIRS and that it's set at all.
+-# The spec allows XDG_DATA_DIRS to be not set, but X session startup scripts tend
+-# to set it to a list of paths *not* including the KDE prefix if it's not /usr or
+-# /usr/local.
+-if test -z "$XDG_DATA_DIRS"; then
+-    XDG_DATA_DIRS="@CMAKE_INSTALL_PREFIX@/@SHARE_INSTALL_PREFIX@:/usr/share:/usr/local/share"
+-fi
+-export XDG_DATA_DIRS
+-
+-# Make sure that D-Bus is running
+-# D-Bus autolaunch is broken
+-if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
+-    eval `dbus-launch --sh-syntax --exit-with-session`
+-fi
+-if $qdbus >/dev/null 2>/dev/null; then
+-    : # ok
+-else
+-    echo 'startkde: Could not start D-Bus. Can you call qdbus?'  1>&2
+-    test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
+-    xmessage -geometry 500x100 "Could not start D-Bus. Can you call qdbus?"
+-    exit 1
+-fi
+-
+-
+ # Mark that full KDE session is running (e.g. Konqueror preloading works only
+ # with full KDE running). The KDE_FULL_SESSION property can be detected by
+ # any X client connected to the same X session, even if not launched
+@@ -332,11 +284,11 @@ fi
+ #
+ KDE_FULL_SESSION=true
+ export KDE_FULL_SESSION
+-xprop -root -f KDE_FULL_SESSION 8t -set KDE_FULL_SESSION true
++@xprop@/bin/xprop -root -f KDE_FULL_SESSION 8t -set KDE_FULL_SESSION true
+ 
+ KDE_SESSION_VERSION=5
+ export KDE_SESSION_VERSION
+-xprop -root -f KDE_SESSION_VERSION 32c -set KDE_SESSION_VERSION 5
++@xprop@/bin/xprop -root -f KDE_SESSION_VERSION 32c -set KDE_SESSION_VERSION 5
+ 
+ KDE_SESSION_UID=`id -ru`
+ export KDE_SESSION_UID
+@@ -346,30 +298,36 @@ export XDG_CURRENT_DESKTOP
+ 
+ # At this point all the environment is ready, let's send it to kwalletd if running
+ if test -n "$PAM_KWALLET_LOGIN" ; then
+-    env | socat STDIN UNIX-CONNECT:$PAM_KWALLET_LOGIN
++    env | @socat@/bin/socat STDIN UNIX-CONNECT:$PAM_KWALLET_LOGIN
+ fi
+ 
+-# At this point all environment variables are set, let's send it to the DBus session server to update the activation environment
++# At this point all environment variables are set, let's send it to the DBus
++# session server to update the activation environment
+ @CMAKE_INSTALL_FULL_LIBEXECDIR@/ksyncdbusenv
+ if test $? -ne 0; then
+   # Startup error
+   echo 'startkde: Could not sync environment to dbus.'  1>&2
+   test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
+-  xmessage -geometry 500x100 "Could not sync environment to dbus."
++  @xmessage@/bin/xmessage -geometry 500x100 "Could not sync environment to dbus."
+   exit 1
+ fi
+ 
+ # We set LD_BIND_NOW to increase the efficiency of kdeinit.
+ # kdeinit unsets this variable before loading applications.
+-LD_BIND_NOW=true @CMAKE_INSTALL_FULL_LIBEXECDIR_KF5@/start_kdeinit_wrapper --kded +kcminit_startup
++LD_BIND_NOW=true @kinit@/lib/libexec/kf5/start_kdeinit_wrapper --kded +kcminit_startup
+ if test $? -ne 0; then
+   # Startup error
+   echo 'startkde: Could not start kdeinit5. Check your installation.'  1>&2
+   test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
+-  xmessage -geometry 500x100 "Could not start kdeinit5. Check your installation."
++  @xmessage@/bin/xmessage -geometry 500x100 "Could not start kdeinit5. Check your installation"
+   exit 1
+ fi
+ 
++# (NixOS) We run kbuildsycoca5 before starting the user session because things
++# may be missing or moved if they have run nixos-rebuild and it may not be
++# possible for them to start Konsole to run it manually!
++@kservice@/bin/kbuildsycoca5
++
+ # finally, give the session control to the session manager
+ # see kdebase/ksmserver for the description of the rest of the startup sequence
+ # if the KDEWM environment variable has been set, then it will be used as KDE's
+@@ -385,27 +343,27 @@ test -n "$KDEWM" && KDEWM="--windowmanager $KDEWM"
+ # lock now and do the rest of the KDE startup underneath the locker.
+ KSMSERVEROPTIONS=""
+ test -n "$dl" && KSMSERVEROPTIONS=" --lockscreen"
+-kwrapper5 ksmserver $KDEWM $KSMSERVEROPTIONS
++@kinit@/bin/kwrapper5 ksmserver $KDEWM $KSMSERVEROPTIONS
+ if test $? -eq 255; then
+   # Startup error
+   echo 'startkde: Could not start ksmserver. Check your installation.'  1>&2
+   test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
+-  xmessage -geometry 500x100 "Could not start ksmserver. Check your installation."
++  @xmessage@/bin/xmessage -geometry 500x100 "Could not start ksmserver. Check your installation."
+ fi
+ 
+-wait_drkonqi=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Enabled --default true`
++wait_drkonqi=`@kconfig@/bin/kreadconfig5 --file startkderc --group WaitForDrKonqi --key Enabled --default true`
+ 
+ if test x"$wait_drkonqi"x = x"true"x ; then
+     # wait for remaining drkonqi instances with timeout (in seconds)
+-    wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
++    wait_drkonqi_timeout=`@kconfig@/bin/kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
+     wait_drkonqi_counter=0
+-    while $qdbus | grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
++    while @qt5tools@/bin/qdbus | @gnugrep@/bin/grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
+         sleep 5
+         wait_drkonqi_counter=$((wait_drkonqi_counter+5))
+         if test "$wait_drkonqi_counter" -ge "$wait_drkonqi_timeout" ; then
+             # ask remaining drkonqis to die in a graceful way
+-            $qdbus | grep 'org.kde.drkonqi-' | while read address ; do
+-                $qdbus "$address" "/MainApplication" "quit"
++            @qt5tools@/bin/qdbus | @gnugrep@/bin/grep 'org.kde.drkonqi-' | while read address ; do
++                @qt5tools@/bin/qdbus "$address" "/MainApplication" "quit"
+             done
+             break
+         fi
+@@ -417,21 +375,21 @@ echo 'startkde: Shutting down...'  1>&2
+ test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
+ 
+ # Clean up
+-kdeinit5_shutdown
++@kinit@/bin/kdeinit5_shutdown
+ 
+ echo 'startkde: Running shutdown scripts...'  1>&2
+ 
+ # Run scripts found in <config locations>/plasma-workspace/shutdown
+ for prefix in `echo "$scriptpath"`; do
+-  for file in `ls "$prefix"/shutdown 2> /dev/null | egrep -v '(~|\.bak)$'`; do
++  for file in `ls "$prefix"/shutdown 2> /dev/null | @gnugrep@/bin/egrep -v '(~|\.bak)$'`; do
+     test -x "$prefix$file" && "$prefix$file"
+   done
+ done
+ 
+ unset KDE_FULL_SESSION
+-xprop -root -remove KDE_FULL_SESSION
++@xprop@/bin/xprop -root -remove KDE_FULL_SESSION
+ unset KDE_SESSION_VERSION
+-xprop -root -remove KDE_SESSION_VERSION
++@xprop@/bin/xprop -root -remove KDE_SESSION_VERSION
+ unset KDE_SESSION_UID
+ 
+ echo 'startkde: Done.'  1>&2
+-- 
+2.3.6
+
diff --git a/pkgs/desktops/plasma-5.3/startkde/default.nix b/pkgs/desktops/plasma-5.3/startkde/default.nix
deleted file mode 100644
index 624c5d239d5d..000000000000
--- a/pkgs/desktops/plasma-5.3/startkde/default.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-# We provide our own version of the startkde script in its entirety, rather than
-# patching the version provided by kde-workspace, because it requires such
-# extensive patching.
-
-{ stdenv, bash, dbus, gnused, gnugrep, kconfig, kinit, kservice, plasma-desktop
-, plasma-workspace, qt5, socat, xorg }:
-
-let startkde = ./startkde.in; in
-
-stdenv.mkDerivation {
-  name = "startkde-0.1";
-  phases = "installPhase";
-
-  inherit bash gnused gnugrep kconfig kinit kservice socat;
-  inherit (xorg) mkfontdir xmessage xprop xrdb xset xsetroot;
-  qt5tools = qt5.tools;
-  dbus_tools = dbus.tools;
-  plasmaWorkspace = plasma-workspace;
-  plasmaDesktop = plasma-desktop;
-  startupconfigkeys = ./startupconfigkeys;
-  kdeglobals = ./kdeglobals;
-
-  installPhase = ''
-    mkdir -p $out/bin
-    substituteAll ${startkde} $out/bin/startkde
-    chmod +x $out/bin/startkde
-  '';
-
-  meta = {
-    description = "Custom startkde script for Nixpkgs";
-    maintainers = with stdenv.lib.maintainers; [ ttuegel ];
-    license = with stdenv.lib.licenses; [ gpl2Plus ];
-  };
-}
diff --git a/pkgs/desktops/plasma-5.3/startkde/kdeglobals b/pkgs/desktops/plasma-5.3/startkde/kdeglobals
deleted file mode 100644
index bfa610712ede..000000000000
--- a/pkgs/desktops/plasma-5.3/startkde/kdeglobals
+++ /dev/null
@@ -1,11 +0,0 @@
-[General]
-XftAntialias=true
-XftHintStyle=hintmedium
-XftSubPixel=none
-desktopFont=Oxygen-Sans,10,-1,5,50,0,0,0,0,0
-fixed=Oxygen Mono,9,-1,5,50,0,0,0,0,0
-font=Oxygen-Sans,10,-1,5,50,0,0,0,0,0
-menuFont=Oxygen-Sans,10,-1,5,50,0,0,0,0,0
-smallestReadableFont=Oxygen-Sans,8,-1,5,50,0,0,0,0,0
-taskbarFont=Oxygen-Sans,10,-1,5,50,0,0,0,0,0
-toolBarFont=Oxygen-Sans,9,-1,5,50,0,0,0,0,0
\ No newline at end of file
diff --git a/pkgs/desktops/plasma-5.3/startkde/startkde.in b/pkgs/desktops/plasma-5.3/startkde/startkde.in
deleted file mode 100644
index 0825a0733f43..000000000000
--- a/pkgs/desktops/plasma-5.3/startkde/startkde.in
+++ /dev/null
@@ -1,374 +0,0 @@
-#!@bash@/bin/bash -x
-#
-#  NIXOS KDE STARTUP SCRIPT
-#
-
-# The KDE icon cache is supposed to update itself
-# automatically, but it uses the timestamp on the icon
-# theme directory as a trigger.  Since in Nix the
-# timestamp is always the same, this doesn't work.  So as
-# a workaround, nuke the icon cache on login.  This isn't
-# perfect, since it may require logging out after
-# installing new applications to update the cache.
-# See http://lists-archives.org/kde-devel/26175-what-when-will-icon-cache-refresh.html
-rm -fv $HOME/.cache/icon-cache.kcache
-
-# Qt writes a weird ‘libraryPath’ line to
-# ~/.config/Trolltech.conf that causes the KDE plugin
-# paths of previous KDE invocations to be searched.
-# Obviously using mismatching KDE libraries is potentially
-# disastrous, so here we nuke references to the Nix store
-# in Trolltech.conf.  A better solution would be to stop
-# Qt from doing this wackiness in the first place.
-if [ -e $HOME/.config/Trolltech.conf ]; then
-    @gnused@/bin/sed -e '/nix\\store\|nix\/store/ d' -i $HOME/.config/Trolltech.conf
-fi
-
-if test "x$1" = x--failsafe; then
-    KDE_FAILSAFE=1 # General failsafe flag
-    KWIN_COMPOSE=N # Disable KWin's compositing
-    export KWIN_COMPOSE KDE_FAILSAFE
-fi
-
-# When the X server dies we get a HUP signal from xinit. We must ignore it
-# because we still need to do some cleanup.
-trap 'echo GOT SIGHUP' HUP
-
-# we have to unset this for Darwin since it will screw up KDE's dynamic-loading
-unset DYLD_FORCE_FLAT_NAMESPACE
-
-# Check if a KDE session already is running and whether it's possible to connect to X
-@plasmaWorkspace@/bin/kcheckrunning
-kcheckrunning_result=$?
-if test $kcheckrunning_result -eq 0 ; then
-  @xmessage@/bin/xmessage -geometry 500x100 "KDE seems to be already running on this display."
-	exit 1
-elif test $kcheckrunning_result -eq 2 ; then
-	echo "\$DISPLAY is not set or cannot connect to the X server."
-  exit 1
-fi
-
-# Boot sequence:
-#
-# kdeinit is used to fork off processes which improves memory usage
-# and startup time.
-#
-# * kdeinit starts klauncher first.
-# * Then kded is started. kded is responsible for keeping the sycoca
-#   database up to date. When an up to date database is present it goes
-#   into the background and the startup continues.
-# * Then kdeinit starts kcminit. kcminit performs initialisation of
-#   certain devices according to the user's settings
-#
-# * Then ksmserver is started which takes control of the rest of the startup sequence
-
-# We need to create config folder so we can write startupconfigkeys
-configDir=$(@qt5tools@/bin/qtpaths --writable-path GenericConfigLocation)
-mkdir -p "$configDir"
-
-# This is basically setting defaults so we can use them with kstartupconfig5
-cat @startupconfigkeys@ >$configDir/startupconfigkeys
-
-# preload the user's locale on first start
-plasmalocalerc=$configDir/plasma-localerc
-test -f $plasmalocalerc || {
-cat >$plasmalocalerc <<EOF
-[Formats]
-LANG=$LANG
-EOF
-}
-
-# export LC_* variables set by kcmshell5 formats into environment
-# so it can be picked up by QLocale and friends.
-exportformatssettings=$configDir/plasma-locale-settings.sh
-[ -f $exportformatssettings ] && . $exportformatssettings
-
-# Write a default kdeglobals file to set up the font
-kdeglobalsfile=$configDir/kdeglobals
-[ -f $kdeglobalsfile ] || cat @kdeglobals@ >$kdeglobalsfile
-
-@plasmaWorkspace@/bin/kstartupconfig5
-returncode=$?
-if test $returncode -ne 0; then
-    @xmessage@/bin/xmessage -geometry 500x100 "kstartupconfig5 exited with $returncode"
-    exit 1
-fi
-[ -r $configDir/startupconfig ] && . $configDir/startupconfig
-
-XCURSOR_PATH=~/.icons:$(echo "$XDG_DATA_DIRS" | tr ":" "\n" | @gnused@/bin/sed 's,$,/icons,g' | tr "\n" ":")
-export XCURSOR_PATH
-
-# XCursor mouse theme needs to be applied here to work even for kded or ksmserver
-if test -n "$kcminputrc_mouse_cursortheme" -o -n "$kcminputrc_mouse_cursorsize" ; then
-
-    @plasmaDesktop@/bin/kapplymousetheme "$kcminputrc_mouse_cursortheme" "$kcminputrc_mouse_cursorsize"
-    if test $? -eq 10; then
-        XCURSOR_THEME=default
-        export XCURSOR_THEME
-    elif test -n "$kcminputrc_mouse_cursortheme"; then
-        XCURSOR_THEME="$kcminputrc_mouse_cursortheme"
-        export XCURSOR_THEME
-    fi
-    if test -n "$kcminputrc_mouse_cursorsize"; then
-        XCURSOR_SIZE="$kcminputrc_mouse_cursorsize"
-        export XCURSOR_SIZE
-    fi
-fi
-
-# Set a left cursor instead of the standard X11 "X" cursor, since I've heard
-# from some users that they're confused and don't know what to do. This is
-# especially necessary on slow machines, where starting KDE takes one or two
-# minutes until anything appears on the screen.
-#
-# If the user has overwritten fonts, the cursor font may be different now
-# so don't move this up.
-#
-@xsetroot@/bin/xsetroot -cursor_name left_ptr
-
-dl=$DESKTOP_LOCKED
-unset DESKTOP_LOCKED # Don't want it in the environment
-
-# Make sure that D-Bus is running
-# D-Bus autolaunch is broken
-if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
-    eval `@dbus_tools@/bin/dbus-launch --sh-syntax --exit-with-session`
-fi
-if @qt5tools@/bin/qdbus >/dev/null 2>/dev/null; then
-    : # ok
-else
-    echo 'startkde: Could not start D-Bus. Can you call qdbus?'  1>&2
-    test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
-    @xmessage@/bin/xmessage -geometry 500x100 "Could not start D-Bus. Can you call qdbus?"
-    exit 1
-fi
-
-ksplash_pid=
-if test -z "$dl"; then
-  # the splashscreen and progress indicator
-  case "$ksplashrc_ksplash_engine" in
-    KSplashQML)
-      ksplash_pid=`@plasmaWorkspace@/bin/ksplashqml "${ksplashrc_ksplash_theme}" --pid`
-      ;;
-    None)
-      ;;
-    *)
-      ;;
-  esac
-fi
-
-# Source scripts found in <config locations>/plasma-workspace/env/*.sh
-# (where <config locations> correspond to the system and user's configuration
-# directories, as identified by Qt's qtpaths,  e.g.  $HOME/.config
-# and /etc/xdg/ on Linux)
-#
-# This is where you can define environment variables that will be available to
-# all KDE programs, so this is where you can run agents using e.g. eval `ssh-agent`
-# or eval `gpg-agent --daemon`.
-# Note: if you do that, you should also put "ssh-agent -k" as a shutdown script
-#
-# (see end of this file).
-# For anything else (that doesn't set env vars, or that needs a window manager),
-# better use the Autostart folder.
-
-scriptpath=$(@qt5tools@/bin/qtpaths --paths GenericConfigLocation | tr ':' '\n' | @gnused@/bin/sed 's,$,/plasma-workspace,g')
-
-# Add /env/ to the directory to locate the scripts to be sourced
-for prefix in `echo $scriptpath`; do
-  for file in "$prefix"/env/*.sh; do
-    test -r "$file" && . "$file"
-  done
-done
-
-# Set the path for Qt plugins provided by KDE
-QT_PLUGIN_PATH=${QT_PLUGIN_PATH+$QT_PLUGIN_PATH:}`@qt5tools@/bin/qtpaths --plugin-dir`
-# TODO: Do we really need this?
-QT_PLUGIN_PATH=$QT_PLUGIN_PATH:$kdehome/lib/kde5/plugins/
-export QT_PLUGIN_PATH
-
-# Activate the kde font directories.
-#
-# There are 4 directories that may be used for supplying fonts for KDE.
-#
-# There are two system directories. These belong to the administrator.
-# There are two user directories, where the user may add her own fonts.
-#
-# The 'override' versions are for fonts that should come first in the list,
-# i.e. if you have a font in your 'override' directory, it will be used in
-# preference to any other.
-#
-# The preference order looks like this:
-# user override, system override, X, user, system
-#
-# Where X is the original font database that was set up before this script
-# runs.
-
-usr_odir=$HOME/.fonts/kde-override
-usr_fdir=$HOME/.fonts
-
-if test -n "$KDEDIRS"; then
-  kdedirs_first=`echo "$KDEDIRS" | @gnused@/bin/sed -e 's/:.*//'`
-  sys_odir=$kdedirs_first/share/fonts/override
-  sys_fdir=$kdedirs_first/share/fonts
-else
-  sys_odir=$KDEDIR/share/fonts/override
-  sys_fdir=$KDEDIR/share/fonts
-fi
-
-# We run mkfontdir on the user's font dirs (if we have permission) to pick
-# up any new fonts they may have installed. If mkfontdir fails, we still
-# add the user's dirs to the font path, as they might simply have been made
-# read-only by the administrator, for whatever reason.
-
-test -d "$sys_odir" && @xset@/bin/xset +fp "$sys_odir"
-test -d "$usr_odir" && ( @mkfontdir@/bin/mkfontdir "$usr_odir" ; @xset@/bin/xset +fp "$usr_odir" )
-test -d "$usr_fdir" && ( @mkfontdir@/bin/mkfontdir "$usr_fdir" ; @xset@/bin/xset fp+ "$usr_fdir" )
-test -d "$sys_fdir" && @xset@/bin/xset fp+ "$sys_fdir"
-
-# Ask X11 to rebuild its font list.
-@xset@/bin/xset fp rehash
-
-# Get Ghostscript to look into user's KDE fonts dir for additional Fontmap
-if test -n "$GS_LIB" ; then
-    GS_LIB=$usr_fdir:$GS_LIB
-    export GS_LIB
-else
-    GS_LIB=$usr_fdir
-    export GS_LIB
-fi
-
-echo 'startkde: Starting up...'  1>&2
-
-
-# Mark that full KDE session is running (e.g. Konqueror preloading works only
-# with full KDE running). The KDE_FULL_SESSION property can be detected by
-# any X client connected to the same X session, even if not launched
-# directly from the KDE session but e.g. using "ssh -X", kdesu. $KDE_FULL_SESSION
-# however guarantees that the application is launched in the same environment
-# like the KDE session and that e.g. KDE utilities/libraries are available.
-# KDE_FULL_SESSION property is also only available since KDE 3.5.5.
-# The matching tests are:
-#   For $KDE_FULL_SESSION:
-#     if test -n "$KDE_FULL_SESSION"; then ... whatever
-#   For KDE_FULL_SESSION property:
-#     xprop -root | grep "^KDE_FULL_SESSION" >/dev/null 2>/dev/null
-#     if test $? -eq 0; then ... whatever
-#
-# Additionally there is (since KDE 3.5.7) $KDE_SESSION_UID with the uid
-# of the user running the KDE session. It should be rarely needed (e.g.
-# after sudo to prevent desktop-wide functionality in the new user's kded).
-#
-# Since KDE4 there is also KDE_SESSION_VERSION, containing the major version number.
-# Note that this didn't exist in KDE3, which can be detected by its absense and
-# the presence of KDE_FULL_SESSION.
-#
-KDE_FULL_SESSION=true
-export KDE_FULL_SESSION
-@xprop@/bin/xprop -root -f KDE_FULL_SESSION 8t -set KDE_FULL_SESSION true
-
-KDE_SESSION_VERSION=5
-export KDE_SESSION_VERSION
-@xprop@/bin/xprop -root -f KDE_SESSION_VERSION 32c -set KDE_SESSION_VERSION 5
-
-KDE_SESSION_UID=`id -ru`
-export KDE_SESSION_UID
-
-XDG_CURRENT_DESKTOP=KDE
-export XDG_CURRENT_DESKTOP
-
-# At this point all the environment is ready, let's send it to kwalletd if running
-if test -n "$PAM_KWALLET_LOGIN" ; then
-    env | @socat@/bin/socat STDIN UNIX-CONNECT:$PAM_KWALLET_LOGIN
-fi
-
-# At this point all environment variables are set, let's send it to the DBus
-# session server to update the activation environment
-@plasmaWorkspace@/lib/libexec/ksyncdbusenv
-if test $? -ne 0; then
-  # Startup error
-  echo 'startkde: Could not sync environment to dbus.'  1>&2
-  test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
-  @xmessage@/bin/xmessage -geometry 500x100 "Could not sync environment to dbus."
-  exit 1
-fi
-
-# We set LD_BIND_NOW to increase the efficiency of kdeinit.
-# kdeinit unsets this variable before loading applications.
-LD_BIND_NOW=true @kinit@/lib/libexec/kf5/start_kdeinit_wrapper --kded +kcminit_startup
-if test $? -ne 0; then
-  # Startup error
-  echo 'startkde: Could not start kdeinit5.'  1>&2
-  test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
-  @xmessage@/bin/xmessage -geometry 500x100 "Could not start kdeinit5."
-  exit 1
-fi
-
-# (NixOS) We run kbuildsycoca5 before starting the user session because things
-# may be missing or moved if they have run nixos-rebuild and it may not be
-# possible for them to start Konsole to run it manually!
-@kservice@/bin/kbuildsycoca5
-
-# finally, give the session control to the session manager
-# see kdebase/ksmserver for the description of the rest of the startup sequence
-# if the KDEWM environment variable has been set, then it will be used as KDE's
-# window manager instead of kwin.
-# if KDEWM is not set, ksmserver will ensure kwin is started.
-# kwrapper5 is used to reduce startup time and memory usage
-# kwrapper5 does not return useful error codes such as the exit code of ksmserver.
-# We only check for 255 which means that the ksmserver process could not be
-# started, any problems thereafter, e.g. ksmserver failing to initialize,
-# will remain undetected.
-test -n "$KDEWM" && KDEWM="--windowmanager $KDEWM"
-# If the session should be locked from the start (locked autologin),
-# lock now and do the rest of the KDE startup underneath the locker.
-KSMSERVEROPTIONS=""
-test -n "$dl" && KSMSERVEROPTIONS=" --lockscreen"
-@kinit@/bin/kwrapper5 @plasmaWorkspace@/bin/ksmserver $KDEWM $KSMSERVEROPTIONS
-if test $? -eq 255; then
-  # Startup error
-  echo 'startkde: Could not start ksmserver.'  1>&2
-  test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
-  @xmessage@/bin/xmessage -geometry 500x100 "Could not start ksmserver."
-fi
-
-wait_drkonqi=`@kconfig@/bin/kreadconfig5 --file startkderc --group WaitForDrKonqi --key Enabled --default true`
-
-if test x"$wait_drkonqi"x = x"true"x ; then
-    # wait for remaining drkonqi instances with timeout (in seconds)
-    wait_drkonqi_timeout=`@kconfig@/bin/kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
-    wait_drkonqi_counter=0
-    while @qt5tools@/bin/qdbus | @gnugrep@/bin/grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
-        sleep 5
-        wait_drkonqi_counter=$((wait_drkonqi_counter+5))
-        if test "$wait_drkonqi_counter" -ge "$wait_drkonqi_timeout" ; then
-            # ask remaining drkonqis to die in a graceful way
-            @qt5tools@/bin/qdbus | @gnugrep@/bin/grep 'org.kde.drkonqi-' | while read address ; do
-                @qt5tools@/bin/qdbus "$address" "/MainApplication" "quit"
-            done
-            break
-        fi
-    done
-fi
-
-echo 'startkde: Shutting down...'  1>&2
-# just in case
-test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
-
-# Clean up
-@kinit@/bin/kdeinit5_shutdown
-
-echo 'startkde: Running shutdown scripts...'  1>&2
-
-# Run scripts found in <config locations>/plasma-workspace/shutdown
-for prefix in `echo "$scriptpath"`; do
-  for file in `ls "$prefix"/shutdown 2> /dev/null | @gnugrep@/bin/egrep -v '(~|\.bak)$'`; do
-    test -x "$prefix$file" && "$prefix$file"
-  done
-done
-
-unset KDE_FULL_SESSION
-@xprop@/bin/xprop -root -remove KDE_FULL_SESSION
-unset KDE_SESSION_VERSION
-@xprop@/bin/xprop -root -remove KDE_SESSION_VERSION
-unset KDE_SESSION_UID
-
-echo 'startkde: Done.'  1>&2
diff --git a/pkgs/desktops/plasma-5.3/startkde/startupconfigkeys b/pkgs/desktops/plasma-5.3/startkde/startupconfigkeys
deleted file mode 100644
index 0fc92cff8a53..000000000000
--- a/pkgs/desktops/plasma-5.3/startkde/startupconfigkeys
+++ /dev/null
@@ -1,5 +0,0 @@
-kcminputrc Mouse cursorTheme 'breeze_cursors'
-kcminputrc Mouse cursorSize ''
-ksplashrc KSplash Theme Breeze
-ksplashrc KSplash Engine KSplashQML
-kcmfonts General forceFontDPI 0