summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2017-11-01 23:58:19 -0200
committerJosé Romildo Malaquias <malaquias@gmail.com>2017-11-01 23:58:19 -0200
commit2312b0ef475fddb91e09defc8a51b2c871513ece (patch)
tree030a613fc5ace2f333c7e5875568fa641ce4e554 /pkgs/desktops
parentf50e270076fd2cdd9f07d343408e499b223fe5c4 (diff)
downloadnixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar.gz
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar.bz2
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar.lz
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar.xz
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.tar.zst
nixlib-2312b0ef475fddb91e09defc8a51b2c871513ece.zip
lxqt-qtplugin: 0.11.1 -> 0.12.0
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/lxqt/core/lxqt-qtplugin/default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/pkgs/desktops/lxqt/core/lxqt-qtplugin/default.nix b/pkgs/desktops/lxqt/core/lxqt-qtplugin/default.nix
index d5b8987bbb82..c5fae1e9ecb3 100644
--- a/pkgs/desktops/lxqt/core/lxqt-qtplugin/default.nix
+++ b/pkgs/desktops/lxqt/core/lxqt-qtplugin/default.nix
@@ -1,19 +1,19 @@
 {
-  stdenv, fetchFromGitHub, standardPatch,
+  stdenv, fetchFromGitHub,
   cmake, lxqt-build-tools,
-  qtbase, qtx11extras, qttools, qtsvg, libdbusmenu, libqtxdg,
+  qtbase, qtx11extras, qttools, qtsvg, libdbusmenu, libqtxdg, libfm-qt
 }:
 
 stdenv.mkDerivation rec {
   name = "${pname}-${version}";
   pname = "lxqt-qtplugin";
-  version = "0.11.1";
+  version = "0.12.0";
 
-  srcs = fetchFromGitHub {
+  src = fetchFromGitHub {
     owner = "lxde";
     repo = pname;
     rev = version;
-    sha256 = "12hyw7rk3zx51n6g2bazlqv70xap0lygm9v21ibxgy1aw0j6iy02";
+    sha256 = "1i1rga0pg764ccwhq7acdsckxpl1apxwj4lv4gygxxmpkrg62zkv";
   };
 
   nativeBuildInputs = [
@@ -28,11 +28,13 @@ stdenv.mkDerivation rec {
     qtsvg
     libdbusmenu
     libqtxdg
+    libfm-qt
   ];
 
-  cmakeFlags = [ "-DPULL_TRANSLATIONS=NO" ];
-
-  postPatch = standardPatch;
+  postPatch = ''
+    substituteInPlace src/CMakeLists.txt \
+      --replace "DESTINATION \"\''${QT_PLUGINS_DIR}" "DESTINATION \"$qtPluginPrefix"
+  '';
 
   meta = with stdenv.lib; {
     description = "LXQt Qt platform integration plugin";