summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorLuca Bruno <lethalman88@gmail.com>2016-06-07 21:21:37 +0200
committerLuca Bruno <lethalman88@gmail.com>2016-06-07 21:22:27 +0200
commit217feced47bd5cc91eab2928d299dcae9536264d (patch)
treea5efa18a74b4d7097fc26747c34460e5c46cde92 /pkgs/desktops
parentb51ed9863b650ddd8f784b5c91fb4dc02527adea (diff)
downloadnixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar.gz
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar.bz2
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar.lz
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar.xz
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.tar.zst
nixlib-217feced47bd5cc91eab2928d299dcae9536264d.zip
gnome3_20.totem: fix build on i686
See https://bugzilla.gnome.org/show_bug.cgi?id=767374
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.20/core/totem/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.20/core/totem/x86.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/3.20/core/totem/default.nix b/pkgs/desktops/gnome-3/3.20/core/totem/default.nix
index 13665c72274e..bce3bd0ceba3 100644
--- a/pkgs/desktops/gnome-3/3.20/core/totem/default.nix
+++ b/pkgs/desktops/gnome-3/3.20/core/totem/default.nix
@@ -32,6 +32,8 @@ stdenv.mkDerivation rec {
 
   '';
 
+  patches = [ ./x86.patch ];
+
   meta = with stdenv.lib; {
     homepage = https://wiki.gnome.org/Apps/Videos;
     description = "Movie player for the GNOME desktop based on GStreamer";
diff --git a/pkgs/desktops/gnome-3/3.20/core/totem/x86.patch b/pkgs/desktops/gnome-3/3.20/core/totem/x86.patch
new file mode 100644
index 000000000000..ada6d59e8e04
--- /dev/null
+++ b/pkgs/desktops/gnome-3/3.20/core/totem/x86.patch
@@ -0,0 +1,11 @@
+--- a/src/backend/bacon-video-widget.c	2016-06-07 20:47:22.981213063 +0200
++++ b/src/backend/bacon-video-widget.c	2016-06-07 20:47:44.065781036 +0200
+@@ -2334,7 +2334,7 @@
+     if (!gst_toc_entry_get_start_stop_times (entry, &start, &stop)) {
+       GST_DEBUG ("Chapter #%d (couldn't get times)", i);
+     } else {
+-      GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, start, stop);
++      GST_DEBUG ("Chapter #%d (start: %" G_GINT64_FORMAT " stop: %" G_GINT64_FORMAT ")", i, start, stop);
+     }
+   }
+