summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-31 09:51:58 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-31 09:53:49 +0100
commit1fcd92ce923d33ab3d8c0b6c6d42473b135f114b (patch)
treec0f696c1c2d3ff82067d891ee25bb4f44af54880 /pkgs/desktops
parent4d2b7638173afb4c0f0c12a43654bcff5c9500ab (diff)
parentab3a12ed7ee0de4d247a8017151a1bf01829f6f7 (diff)
downloadnixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar.gz
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar.bz2
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar.lz
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar.xz
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.tar.zst
nixlib-1fcd92ce923d33ab3d8c0b6c6d42473b135f114b.zip
Merge branch 'master' into staging
A few thousand rebuilds from master, again.
Hydra: ?compare=1422362
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/extensions/mediaplayer/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/extensions/mediaplayer/default.nix b/pkgs/desktops/gnome-3/extensions/mediaplayer/default.nix
new file mode 100644
index 000000000000..f64a0ef3f27e
--- /dev/null
+++ b/pkgs/desktops/gnome-3/extensions/mediaplayer/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchFromGitHub, glib, meson, gettext, ninja }:
+
+stdenv.mkDerivation rec {
+  name = "gnome-shell-extensions-mediaplayer-${version}";
+  version = "3.5";
+
+  src = fetchFromGitHub {
+    owner = "JasonLG1979";
+    repo = "gnome-shell-extensions-mediaplayer";
+    rev = version;
+    sha256 = "0b8smid9vdybgs0601q9chlbgfm1rzrj3vmd3i6p2a5d1n4fyvsc";
+  };
+
+  nativeBuildInputs = [
+    meson
+    ninja
+  ];
+  buildInputs = [
+    glib
+    gettext
+  ];
+
+  postPatch = ''
+    rm build
+    chmod +x meson_post_install.py
+    patchShebangs meson_post_install.py
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Control MPRIS Version 2 Capable Media Players";
+    license = licenses.gpl2Plus;
+    homepage = https://github.com/JasonLG1979/gnome-shell-extensions-mediaplayer/;
+    maintainers = with maintainers; [ tiramiseb ];
+  };
+}
+