summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2018-01-01 11:23:20 -0200
committerTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2018-01-09 02:40:04 +0200
commit07b362419f5084c6bc86186a2cea04d7d2645e0c (patch)
treedf626fea9ad93ed169d744cf4fafc824dbbb397f /pkgs/desktops
parentdd6856a8665a3d6e1374c8797f728c0c5dbf96c4 (diff)
downloadnixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar.gz
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar.bz2
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar.lz
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar.xz
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.tar.zst
nixlib-07b362419f5084c6bc86186a2cea04d7d2645e0c.zip
mate-netbook: init at 1.18.2
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/mate/default.nix2
-rw-r--r--pkgs/desktops/mate/mate-netbook/default.nix42
2 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/desktops/mate/default.nix b/pkgs/desktops/mate/default.nix
index 5f2396c3527b..79a4ed8907c4 100644
--- a/pkgs/desktops/mate/default.nix
+++ b/pkgs/desktops/mate/default.nix
@@ -26,6 +26,7 @@ let
     mate-icon-theme-faenza = callPackage ./mate-icon-theme-faenza { };
     mate-media = callPackage ./mate-media { };
     mate-menus = callPackage ./mate-menus { };
+    mate-netbook = callPackage ./mate-netbook { };
     mate-notification-daemon = callPackage ./mate-notification-daemon { };
     mate-panel = callPackage ./mate-panel { };
     mate-polkit = callPackage ./mate-polkit { };
@@ -67,6 +68,7 @@ let
       mate-calc
       mate-icon-theme-faenza
       mate-media
+      mate-netbook
       mate-power-manager
       mate-screensaver
       mate-system-monitor
diff --git a/pkgs/desktops/mate/mate-netbook/default.nix b/pkgs/desktops/mate/mate-netbook/default.nix
new file mode 100644
index 000000000000..0a2a0e472020
--- /dev/null
+++ b/pkgs/desktops/mate/mate-netbook/default.nix
@@ -0,0 +1,42 @@
+{ stdenv, fetchurl, pkgconfig, intltool, gtk3, libwnck3, libfakekey, libXtst, mate-panel, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  name = "mate-netbook-${version}";
+  version = "${major-ver}.${minor-ver}";
+  major-ver = "1.18";
+  minor-ver = "2";
+
+  src = fetchurl {
+    url = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
+    sha256 = "0xy5mhkg0xfgyr7gnnjrfzqhmdnhyqscrl2h496p06cflknm17vb";
+  };
+
+  nativeBuildInputs = [
+    pkgconfig
+    intltool
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    gtk3
+    libwnck3
+    libfakekey
+    libXtst
+    mate-panel
+  ];
+
+  meta = with stdenv.lib; {
+    description = "MATE utilities for netbooks";
+    longDescription = ''
+      MATE utilities for netbooks are an applet and a daemon to maximize
+      windows and move their titles on the panel.
+
+      Installing these utilities is recommended for netbooks and similar
+      devices with low resolution displays.
+    '';
+    homepage = http://mate-desktop.org;
+    license = with licenses; [ gpl3 lgpl2Plus ];
+    platforms = platforms.unix;
+    maintainers = [ maintainers.romildo ];
+  };
+}