summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-10-02 00:22:12 +0000
committerOrivej Desh <orivej@gmx.fr>2017-10-02 00:22:12 +0000
commitfda26c8476c1684f77bacacf2b5c46b1fbf65b41 (patch)
tree84752640ad3cf64ba372bdd4aab713c097023281 /pkgs/data
parent21976d1fbd612f67825473a7a2b05bb1387e5840 (diff)
parent6b8806dff7a2cd11e37944af1bbb276ceb870199 (diff)
downloadnixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar.gz
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar.bz2
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar.lz
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar.xz
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.tar.zst
nixlib-fda26c8476c1684f77bacacf2b5c46b1fbf65b41.zip
Merge branch 'master' into staging
* master: (271 commits)
  pysmbc: clarify license
  pysmbc: fix license
  bazel: 0.5.4 -> 0.6.0 (#29990)
  googler: init at 3.3
  go: declare support for aarch64
  firefox-beta-bin: 56.0b5 -> 57.0b4
  spotify: 1.0.64.401.g9d720389-21 -> 1.0.64.407.g9bd02c2d-26
  gogs: 0.11.19 -> 0.11.29
  grafana: 4.5.1 -> 4.5.2
  mopidy-iris: 3.4.1 -> 3.4.9
  nextcloud: 12.0.2 -> 12.0.3
  haskell-json-autotype: jailbreak to fix build within LTS 9.x
  kore: fix up
  kore: init at 2.0.0
  glusterfs service: fix issues with useRpcbind
  tig: 2.2.2 -> 2.3.0
  haskell-hspec-core: enable test suite again
  hackage-packages.nix: automatic Haskell package set update
  librsvg: fix thumbnailer path
  awscli: 1.11.108 -> 1.11.162
  ...
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/nerdfonts/default.nix4
-rw-r--r--pkgs/data/fonts/tex-gyre-math/default.nix66
-rw-r--r--pkgs/data/fonts/tex-gyre-termes-math/default.nix37
3 files changed, 66 insertions, 41 deletions
diff --git a/pkgs/data/fonts/nerdfonts/default.nix b/pkgs/data/fonts/nerdfonts/default.nix
index 6b1ebfd68d0d..8815bf688389 100644
--- a/pkgs/data/fonts/nerdfonts/default.nix
+++ b/pkgs/data/fonts/nerdfonts/default.nix
@@ -20,10 +20,6 @@ stdenv.mkDerivation rec {
     ./install.sh ${withFont}
   '';
 
-  outputHashAlgo = "sha256";
-  outputHashMode = "recursive";
-  outputHash = "1f3qvzl7blqddx3cm2sdml7hi8s56yjc0vqhfajndxr5ybz6g1rw";
-
   meta = with stdenv.lib; {
     description = ''
       Nerd Fonts is a project that attempts to patch as many developer targeted
diff --git a/pkgs/data/fonts/tex-gyre-math/default.nix b/pkgs/data/fonts/tex-gyre-math/default.nix
new file mode 100644
index 000000000000..e99e0bfb342f
--- /dev/null
+++ b/pkgs/data/fonts/tex-gyre-math/default.nix
@@ -0,0 +1,66 @@
+{ variant, stdenv, fetchzip }:
+
+let
+  variants = {
+    bonum = {
+      displayName = "Bonum";
+      version = "1.005";
+      sha256 = "1b6x7siypyxp1lhq7xxdqafwbn6p2p3xm3jb38q999sv8cgslxz8";
+      outputHash = "1zjaxkzidqmxakh9d61n0by9mi8hrmir45jppjj6hzwhm3rvknff";
+    };
+    pagella = {
+      displayName = "Pagella";
+      version = "1.632";
+      sha256 = "0f4cgq9w0lc1fbcbfqiv19mdhivbsscl13jmb0ln685641ci2sjr";
+      outputHash = "0wz2n1dpx9b8a0qgqy8vl712fxhi87mhcda281xaad62chndwf6k";
+    };
+    schola = {
+      displayName = "Schola";
+      version = "1.533";
+      sha256 = "0caqgkz7gz700h5a1mai0gq8hv7skrgs5nnrs1f7zw1mb9g53ya9";
+      outputHash = "0jk4bpxki95a9lmfj4cgpnv1jwlkh8qixbkf498n1x7hkaz03f5n";
+    };
+    termes = {
+      displayName = "Termes";
+      version = "1.543";
+      sha256 = "10ayqfpryfn1l35hy0vwyjzw3a6mfsnzgf78vsnccgk2gz1g9vhz";
+      outputHash = "0pa433cgshlypbyrrlp3qq0wg972rngcp37pr8pxdfshgz13q1mm";
+    };
+  };
+  current = variants."${variant}";
+  dotless_version = builtins.replaceStrings ["."] [""] current.version;
+in stdenv.mkDerivation rec {
+  name = "tex-gyre-${variant}-math-${current.version}";
+  version = "${current.version}";
+
+  src = fetchzip {
+    url = "www.gust.org.pl/projects/e-foundry/tg-math/download/texgyre${variant}-math-${dotless_version}.zip";
+    sha256 = current.sha256;
+  };
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype/
+    mkdir -p $out/share/doc/${name}/
+    cp -v opentype/*.otf $out/share/fonts/opentype/
+    cp -v doc/*.txt $out/share/doc/${name}/
+  '';
+
+  outputHashAlgo = "sha256";
+  outputHashMode = "recursive";
+  outputHash = current.outputHash;
+
+  meta = with stdenv.lib; {
+    longDescription = ''
+      TeX Gyre ${current.displayName} Math is a math companion for the TeX Gyre
+      ${current.displayName} family of fonts (see
+      http://www.gust.org.pl/projects/e-foundry/tex-gyre/) in the OpenType format.
+    '';
+    homepage = http://www.gust.org.pl/projects/e-foundry/tg-math;
+    # "The TeX Gyre Math fonts are licensed under the GUST Font License (GFL),
+    # which is a free license, legally equivalent to the LaTeX Project Public
+    # License (LPPL), version 1.3c or later." - GUST website
+    license = licenses.lppl13c;
+    maintainers = with maintainers; [ siddharthist ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/data/fonts/tex-gyre-termes-math/default.nix b/pkgs/data/fonts/tex-gyre-termes-math/default.nix
deleted file mode 100644
index 83b157b085bc..000000000000
--- a/pkgs/data/fonts/tex-gyre-termes-math/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ stdenv, fetchzip }:
-
-stdenv.mkDerivation rec {
-  name = "tex-gyre-termes-math-${version}";
-  version = "1.543";
-
-  src = fetchzip {
-    url = "www.gust.org.pl/projects/e-foundry/tg-math/download/texgyretermes-math-1543.zip";
-    sha256 = "10ayqfpryfn1l35hy0vwyjzw3a6mfsnzgf78vsnccgk2gz1g9vhz";
-  };
-
-  installPhase = ''
-    mkdir -p $out/share/fonts/opentype/
-    mkdir -p $out/share/doc/${name}/
-    cp -v opentype/*.otf $out/share/fonts/opentype/
-    cp -v doc/*.txt $out/share/doc/${name}/
-  '';
-
-  outputHashAlgo = "sha256";
-  outputHashMode = "recursive";
-  outputHash = "0pa433cgshlypbyrrlp3qq0wg972rngcp37pr8pxdfshgz13q1mm";
-
-  meta = with stdenv.lib; {
-    longDescription = ''
-      TeX Gyre Termes Math is a math companion for the TeX Gyre Termes family
-      of fonts (see http://www.gust.org.pl/projects/e-foundry/tex-gyre/) in
-      the OpenType format.
-    '';
-    homepage = http://www.gust.org.pl/projects/e-foundry/tg-math;
-    # "The TeX Gyre Math fonts are licensed under the GUST Font License (GFL),
-    # which is a free license, legally equivalent to the LaTeX Project Public
-    # License (LPPL), version 1.3c or later." - GUST website
-    license = licenses.lppl13c;
-    maintainers = with maintainers; [ siddharthist ];
-    platforms = platforms.all;
-  };
-}