summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMichiel Leenaars <ml.software@leenaa.rs>2018-08-20 01:21:36 +0200
committerMichiel Leenaars <ml.software@leenaa.rs>2018-08-20 01:29:17 +0200
commitea51558cfad3c74cdf49afe9ca62033438877abe (patch)
treee664ede6232d7a260f98233da2bd664c4fed4bfb /pkgs/data
parentab328de0985e5ae4fc9d4b3639ab82acb57b1daf (diff)
downloadnixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar.gz
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar.bz2
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar.lz
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar.xz
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.tar.zst
nixlib-ea51558cfad3c74cdf49afe9ca62033438877abe.zip
eunomia-font: init at 0.200
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/eunomia/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/data/fonts/eunomia/default.nix b/pkgs/data/fonts/eunomia/default.nix
new file mode 100644
index 000000000000..56fa718f8670
--- /dev/null
+++ b/pkgs/data/fonts/eunomia/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "200";
+  pname = "eunomia";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "0lpmczs1d4p9dy4s0dnvv7bl5cd0f6yzyasfrkxij5s86glps38b";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://dotcolon.net/font/eunomia/;
+    description = "A futuristic decorative font.";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}