summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2016-04-16 06:15:21 -0300
committerRobert Helgesson <robert@rycee.net>2016-04-16 21:42:01 +0200
commitd94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1 (patch)
tree281e27b98492b250f7c8a2a32b27c199ec980855 /pkgs/data
parent9de93be6cd448bdce64e7ef5cf80ff8d81592140 (diff)
downloadnixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar.gz
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar.bz2
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar.lz
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar.xz
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.tar.zst
nixlib-d94a8d67bd50ff48aa1876ea2d3a081ed7bdf3e1.zip
helvetica-neue-lt-std: init at 2013.06.07
fix
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/helvetica-neue-lt-std/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/data/fonts/helvetica-neue-lt-std/default.nix b/pkgs/data/fonts/helvetica-neue-lt-std/default.nix
new file mode 100644
index 000000000000..13e98462b215
--- /dev/null
+++ b/pkgs/data/fonts/helvetica-neue-lt-std/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation rec {
+  name = "helvetica-neue-lt-std-${version}";
+  version = "2013.06.07"; # date of most recent file in distribution
+
+  src = fetchurl {
+    url = "http://www.ephifonts.com/downloads/helvetica-neue-lt-std.zip";
+    sha256 = "0nrjdj2a11dr6d3aihvjxzrkdi0wq6f2bvaiimi5iwmpyz80n0h6";
+  };
+
+  nativeBuildInputs = [ unzip ];
+
+  phases = [ "unpackPhase" "installPhase" ];
+
+  sourceRoot = "Helvetica Neue LT Std";
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype
+    cp -v *.otf $out/share/fonts/opentype
+  '';
+
+  meta = {
+    homepage = http://www.ephifonts.com/free-helvetica-font-helvetica-neue-lt-std.html;
+    description = "Helvetica Neue LT Std font";
+    longDescription = ''
+      Helvetica Neue Lt Std is one of the most highly rated and complete
+      fonts of all time. Developed in early 1983, this font has well
+      camouflaged heights and weights. The structure of the word is uniform
+      throughout all the characters.
+
+      The legibility with Helvetica Neue LT Std is said to have improved as
+      opposed to other fonts. The tail of it is much longer in this
+      font. The numbers are well spaced and defined with high accuracy. The
+      punctuation marks are heavily detailed as well.
+    '';
+    license = stdenv.lib.licenses.unfree;
+    maintainers = [ stdenv.lib.maintainers.romildo ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}