summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-02-14 08:33:51 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-02-14 08:33:51 +0100
commitd039c879845ddcde6108203781e4b001c409e2c2 (patch)
tree1f9e2a99d95c8866ddbef81b4bfa6a49ce979451 /pkgs/data
parent34922a3951a0ada7af4fe808250abaf5feb4e28e (diff)
parent6a036d9fca013265b4109ffcaf6df62efa010fa3 (diff)
downloadnixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar.gz
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar.bz2
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar.lz
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar.xz
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.tar.zst
nixlib-d039c879845ddcde6108203781e4b001c409e2c2.zip
Merge branch 'master' into closure-size
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/arkpandora/default.nix18
-rw-r--r--pkgs/data/fonts/google-fonts/default.nix2
-rw-r--r--pkgs/data/fonts/libertine/default.nix39
-rw-r--r--pkgs/data/fonts/powerline-fonts/default.nix8
-rw-r--r--pkgs/data/fonts/redhat-liberation-fonts/binary.nix29
-rw-r--r--pkgs/data/fonts/redhat-liberation-fonts/default.nix14
-rw-r--r--pkgs/data/misc/geolite-legacy/default.nix14
-rw-r--r--pkgs/data/misc/media-player-info/default.nix2
-rw-r--r--pkgs/data/misc/wireless-regdb/default.nix4
9 files changed, 60 insertions, 70 deletions
diff --git a/pkgs/data/fonts/arkpandora/default.nix b/pkgs/data/fonts/arkpandora/default.nix
index 189c066b13eb..55420e2d344e 100644
--- a/pkgs/data/fonts/arkpandora/default.nix
+++ b/pkgs/data/fonts/arkpandora/default.nix
@@ -1,6 +1,8 @@
-args : with args; 
-let version = lib.attrByPath ["version"] "2.04" args; in
-rec {
+{ stdenv, fetchurl }:
+stdenv.mkDerivation rec {
+  name = "arkpandora-${version}";
+  version = "2.04";
+
   src = fetchurl {
     urls = [
       "ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ttf-arkpandora-${version}.tgz"
@@ -10,13 +12,11 @@ rec {
     sha256 = "16mfxwlgn6vs3xn00hha5dnmz6bhjiflq138y4zcq3yhk0y9bz51";
   };
 
-  buildInputs = [];
-  configureFlags = [];
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp *.ttf $out/share/fonts/truetype
+  '';
 
-  /* doConfigure should be specified separately */
-  phaseNames = ["doUnpack" "installFonts"];
-      
-  name = "arkpandora-" + version;
   meta = {
     description = "Font, metrically identical to Arial and Times New Roman";
   };
diff --git a/pkgs/data/fonts/google-fonts/default.nix b/pkgs/data/fonts/google-fonts/default.nix
index 9f14f945e353..e4c655877c8b 100644
--- a/pkgs/data/fonts/google-fonts/default.nix
+++ b/pkgs/data/fonts/google-fonts/default.nix
@@ -21,6 +21,6 @@ stdenv.mkDerivation rec {
     description = "Font files available from Google Font";
     license = with licenses; [ asl20 ofl ufl ];
     platforms = platforms.all;
-    maintainer = with maintainers; [ manveru ];
+    maintainers = with maintainers; [ manveru ];
   };
 }
diff --git a/pkgs/data/fonts/libertine/default.nix b/pkgs/data/fonts/libertine/default.nix
index eb28521a2b8a..b95b0f0beddf 100644
--- a/pkgs/data/fonts/libertine/default.nix
+++ b/pkgs/data/fonts/libertine/default.nix
@@ -1,4 +1,6 @@
-args @ { fetchurl, fontforge, lib, ... }: with args; rec {
+{ stdenv, fetchurl, fontforge }:
+
+stdenv.mkDerivation rec {
   name = "linux-libertine-5.3.0";
 
   src = fetchurl {
@@ -6,18 +8,37 @@ args @ { fetchurl, fontforge, lib, ... }: with args; rec {
     sha256 = "0x7cz6hvhpil1rh03rax9zsfzm54bh7r4bbrq8rz673gl9h47v0v";
   };
 
-  buildInputs = [ fontforge ];
+  setSourceRoot = "sourceRoot=`pwd`";
 
-  /* doConfigure should be specified separately */
-  phaseNames = ["doUnpack" "generateFontsFromSFD" "installFonts"];
+  buildInputs = [ fontforge ];
 
-  extraFontForgeCommands = ''
-    ScaleToEm(1000);
+  buildPhase = ''
+    for i in *.sfd; do
+      fontforge -c \
+        'Open($1);
+        ScaleToEm(1000);
+        Reencode("unicode");
+        Generate($1:r + ".ttf");
+        Generate($1:r + ".otf");
+        Reencode("TeX-Base-Encoding");
+        Generate($1:r + ".afm");
+        Generate($1:r + ".pfm");
+        Generate($1:r + ".pfb");
+        Generate($1:r + ".map");
+        Generate($1:r + ".enc");
+        ' $i;
+    done
   '';
 
-  doUnpack = lib.fullDepEntry ''
-      tar xf ${src}
-    '' ["minInit"];
+  installPhase = ''
+    mkdir -p $out/share/fonts/{opentype,truetype,type1}/public
+    mkdir -p $out/share/texmf/fonts/{enc,map}
+    cp *.otf $out/share/fonts/opentype/public
+    cp *.ttf $out/share/fonts/truetype/public
+    cp *.pfb $out/share/fonts/type1/public
+    cp *.enc $out/share/texmf/fonts/enc
+    cp *.map $out/share/texmf/fonts/map
+  '';
 
   meta = {
     description = "Linux Libertine Fonts";
diff --git a/pkgs/data/fonts/powerline-fonts/default.nix b/pkgs/data/fonts/powerline-fonts/default.nix
index 63b4ad1ea04a..2e576cf6dc8b 100644
--- a/pkgs/data/fonts/powerline-fonts/default.nix
+++ b/pkgs/data/fonts/powerline-fonts/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchFromGitHub }:
 
 stdenv.mkDerivation {
-  name = "powerline-fonts-2015-06-29";
+  name = "powerline-fonts-2015-12-11";
 
   src = fetchFromGitHub {
     owner = "powerline";
     repo = "fonts";
-    rev = "97dc451724fb24e1dd9892c988642b239b5dc67c";
-    sha256 = "1m0a8k916s74iv2k0kk36dz7d2hfb2zgf8m0b9hg71w4yd3bmj4w";
+    rev = "a44abd0e742ad6e7fd8d8bc4c3cad5155c9f3a92";
+    sha256 = "1pwz83yh28yd8aj6fbyfz8z3q3v67psszpd9mp4vv0ms9w8b5ajn";
   };
 
   buildPhase = "true";
@@ -38,6 +38,6 @@ stdenv.mkDerivation {
     '';
     license = with licenses; [ asl20 free ofl ];
     platforms = platforms.all;
-    maintainer = with maintainers; [ malyn ];
+    maintainers = with maintainers; [ malyn ];
   };
 }
diff --git a/pkgs/data/fonts/redhat-liberation-fonts/binary.nix b/pkgs/data/fonts/redhat-liberation-fonts/binary.nix
index df206fe13b5a..9cbe951cf4ae 100644
--- a/pkgs/data/fonts/redhat-liberation-fonts/binary.nix
+++ b/pkgs/data/fonts/redhat-liberation-fonts/binary.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl}:
+{ stdenv, fetchurl, liberation_ttf_from_source }:
 
 stdenv.mkDerivation rec {
   version = "2.00.1";
@@ -16,30 +16,5 @@ stdenv.mkDerivation rec {
     cp -v AUTHORS ChangeLog COPYING License.txt README "$out/doc/${name}" || true
   '';
 
-  meta = {
-    description = "Liberation Fonts, replacements for Times New Roman, Arial, and Courier New";
-    longDescription = ''
-      The Liberation Fonts are intended to be replacements for the three most
-      commonly used fonts on Microsoft systems: Times New Roman, Arial, and
-      Courier New.
-
-      There are three sets: Sans (a substitute for Arial, Albany, Helvetica,
-      Nimbus Sans L, and Bitstream Vera Sans), Serif (a substitute for Times
-      New Roman, Thorndale, Nimbus Roman, and Bitstream Vera Serif) and Mono
-      (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L, and
-      Bitstream Vera Sans Mono).
-
-      You are free to use these fonts on any system you would like.  You are
-      free to redistribute them under the GPL+exception license found in the
-      download.  Using these fonts does not subject your documents to the
-      GPL---it liberates them from any proprietary claim.
-    '';
-
-    # See `License.txt' for details.
-    license = stdenv.lib.licenses.gpl2Oss;
-    homepage = https://fedorahosted.org/liberation-fonts/;
-    maintainers = [
-      stdenv.lib.maintainers.raskin
-    ];
-  };
+  inherit (liberation_ttf_from_source) meta;
 }
diff --git a/pkgs/data/fonts/redhat-liberation-fonts/default.nix b/pkgs/data/fonts/redhat-liberation-fonts/default.nix
index cd5c50309412..80af5ab52d90 100644
--- a/pkgs/data/fonts/redhat-liberation-fonts/default.nix
+++ b/pkgs/data/fonts/redhat-liberation-fonts/default.nix
@@ -18,30 +18,24 @@ stdenv.mkDerivation rec {
     cp -v AUTHORS ChangeLog COPYING License.txt README "$out/doc/${name}" || true
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Liberation Fonts, replacements for Times New Roman, Arial, and Courier New";
     longDescription = ''
       The Liberation Fonts are intended to be replacements for the three most
       commonly used fonts on Microsoft systems: Times New Roman, Arial, and
-      Courier New.
+      Courier New. Since 2012 they are based on croscore fonts.
 
       There are three sets: Sans (a substitute for Arial, Albany, Helvetica,
       Nimbus Sans L, and Bitstream Vera Sans), Serif (a substitute for Times
       New Roman, Thorndale, Nimbus Roman, and Bitstream Vera Serif) and Mono
       (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L, and
       Bitstream Vera Sans Mono).
-
-      You are free to use these fonts on any system you would like.  You are
-      free to redistribute them under the GPL+exception license found in the
-      download.  Using these fonts does not subject your documents to the
-      GPL---it liberates them from any proprietary claim.
     '';
 
-    # See `License.txt' for details.
-    license = stdenv.lib.licenses.gpl2Oss;
+    license = licenses.ofl;
     homepage = https://fedorahosted.org/liberation-fonts/;
     maintainers = [
-      stdenv.lib.maintainers.raskin
+      maintainers.raskin
     ];
   };
 }
diff --git a/pkgs/data/misc/geolite-legacy/default.nix b/pkgs/data/misc/geolite-legacy/default.nix
index eab577888d11..2be23b0f35c7 100644
--- a/pkgs/data/misc/geolite-legacy/default.nix
+++ b/pkgs/data/misc/geolite-legacy/default.nix
@@ -8,26 +8,26 @@ let
 in
 stdenv.mkDerivation rec {
   name = "geolite-legacy-${version}";
-  version = "2016-01-25";
+  version = "2016-02-08";
 
   srcGeoIP = fetchDB
     "GeoLiteCountry/GeoIP.dat.gz" "GeoIP.dat.gz"
-    "07h1ha7z9i877ph41fw4blcfb11ynv8k9snrrsgsjrvv2yqvsc37";
+    "00y8j0jxk60wscm6wiz3mmmj5xfvwqnmxjm2ar8ngkl8mxzl12gm";
   srcGeoIPv6 = fetchDB
     "GeoIPv6.dat.gz" "GeoIPv6.dat.gz"
-    "14wsc0w8ir5q1lq6d9bpr03qvrbi2i0g04gkfcwbnh63yqxc31m9";
+    "0l6wv246kzm63qqmqr9lzpbvbanfwfkvn9bj34jn2djp4rfrkjrf";
   srcGeoLiteCity = fetchDB
     "GeoLiteCity.dat.xz" "GeoIPCity.dat.xz"
-    "1nra64shc3bp1d6vk9rdv7wyd8jmkgsybqgr3imdg7fv837kwvnh";
+    "1095jar3vyax0gmj7wc0w28rpjmq2j1b6wk5yfaghyl87mad5q0f";
   srcGeoLiteCityv6 = fetchDB
     "GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz" "GeoIPCityv6.dat.gz"
-    "1fksbnmda2a05cpax41h9r7jhi8102q41kl5nij4ai42d6yqy73x";
+    "0fnlznn04lpkkd7sy9r9kdl3fcp8ix7msdrncwgz26dh537ml32z";
   srcGeoIPASNum = fetchDB
     "asnum/GeoIPASNum.dat.gz" "GeoIPASNum.dat.gz"
-    "1n7zlmnaxvjljyih9yi9hns530by21h42j2kcszbcyvn7rd9rnyw";
+    "0ib93p2fwayqsxwph98rkgln7xpjrwhzzc06sc74876jpaq3g8g5";
   srcGeoIPASNumv6 = fetchDB
     "asnum/GeoIPASNumv6.dat.gz" "GeoIPASNumv6.dat.gz"
-    "1id60almra7mq4v86p37sfph8jrbdnc5pzxvy55wiyrvf6ydvk56";
+    "1izlxqcvdag66sny5zjjwkmjhai0c9m77b96j117n0x0awrrk4h9";
 
   meta = with stdenv.lib; {
     description = "GeoLite Legacy IP geolocation databases";
diff --git a/pkgs/data/misc/media-player-info/default.nix b/pkgs/data/misc/media-player-info/default.nix
index ddb53d728202..9cfb89914b11 100644
--- a/pkgs/data/misc/media-player-info/default.nix
+++ b/pkgs/data/misc/media-player-info/default.nix
@@ -27,6 +27,6 @@ in
       description = "A repository of data files describing media player capabilities";
       homepage = "http://www.freedesktop.org/wiki/Software/media-player-info/";
       license = licenses.bsd3;
-      maintainer = with maintainers; [ ttuegel ];
+      maintainers = with maintainers; [ ttuegel ];
     };
   }
diff --git a/pkgs/data/misc/wireless-regdb/default.nix b/pkgs/data/misc/wireless-regdb/default.nix
index 123cb7a62089..3c74123d605e 100644
--- a/pkgs/data/misc/wireless-regdb/default.nix
+++ b/pkgs/data/misc/wireless-regdb/default.nix
@@ -2,10 +2,10 @@
 
 stdenv.mkDerivation rec {
   name = "wireless-regdb-${version}";
-  version = "2015-12-14";
+  version = "2016-02-08";
 
   src = fetchgit {
-    sha256 = "1ldfcxn3mdb104czy78b7nj1clsbfp8fc6mshix98zq0bg4k7rsm";
+    sha256 = "0cqnkkcni27ya6apy2ba4im7xj4nrhbcgrahlarvrzbbjkp740m9";
     url = https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git;
     rev = "refs/tags/master-${version}";
   };