summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-10-17 14:54:39 -0600
committerMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-10-18 18:43:27 -0600
commit9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78 (patch)
tree7a1f29fe8a0c25cef75ba088eb0e1e93ed18703d /pkgs/data
parent1971c350df4b425cb1b6f0d6f001935feab84ad8 (diff)
downloadnixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar.gz
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar.bz2
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar.lz
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar.xz
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.tar.zst
nixlib-9cc60e1c27d4f1d1c4411ee86d972c4b5f15ce78.zip
hanazono: init at 20141012
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/hanazono/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/data/fonts/hanazono/default.nix b/pkgs/data/fonts/hanazono/default.nix
new file mode 100644
index 000000000000..01be8afd7aac
--- /dev/null
+++ b/pkgs/data/fonts/hanazono/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation rec {
+  name = "hanazono-${version}";
+  version = "20141012";
+
+  src = fetchurl {
+    url = "mirror://sourceforgejp/hanazono-font/62072/hanazono-20141012.zip";
+    sha256 = "020jhqnzm9jvkmfvvyk1my26ncwxbnb9yc8v7am252jwrifji9q6";
+  };
+
+  buildInputs = [ unzip ];
+
+  sourceRoot = ".";
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/hanazono
+    cp *.ttf $out/share/fonts/hanazono
+    mkdir -p $out/share/doc/hanazono
+    cp *.txt $out/share/doc/hanazono
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Free kanji font containing 96,327 characters";
+    homepage = http://fonts.jp/hanazono/;
+
+    # Dual-licensed under OFL and the following:
+    # This font is a free software.
+    # Unlimited permission is granted to use, copy, and distribute it, with
+    # or without modification, either commercially and noncommercially.
+    # THIS FONT IS PROVIDED "AS IS" WITHOUT WARRANTY.
+    license = [ licenses.ofl licenses.free ];
+    maintainers = with maintainers; [ mathnerd314 ];
+    platforms = platforms.all;
+  };
+}