summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2016-09-09 17:16:58 +0200
committerGitHub <noreply@github.com>2016-09-09 17:16:58 +0200
commit81b643edbe5213b6768bce97ae412a1889323a4e (patch)
treecf2995b68a28a3e3b249d66e6e59840bf2d54846 /pkgs/data
parente5a79b0eaeb10e91b002c3d710df1564c684a93b (diff)
parent03874369a38410e7bd5e78e45e26d8a9ad3ef3bb (diff)
downloadnixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar.gz
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar.bz2
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar.lz
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar.xz
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.tar.zst
nixlib-81b643edbe5213b6768bce97ae412a1889323a4e.zip
Merge pull request #18317 from Profpatsch/mustache-docs
mustache: init mustache at 1.0.2
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/documentation/mustache-spec/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/data/documentation/mustache-spec/default.nix b/pkgs/data/documentation/mustache-spec/default.nix
new file mode 100644
index 000000000000..e41b26d41fbe
--- /dev/null
+++ b/pkgs/data/documentation/mustache-spec/default.nix
@@ -0,0 +1,42 @@
+{ stdenv, lib, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "mustache-spec-${version}";
+  version = "1.0.2";
+
+  src = fetchFromGitHub {
+    owner = "mustache";
+    repo = "mustache";
+    rev = "v${version}";
+    sha256 = "03xrfyjzm5ss6zkdlpl9ypwzcglspcdcnr3f94vj1rjfqm2rxcjw";
+  };
+
+  configurePhase = "";
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/{man/man5,doc/html}
+    cp man/mustache.5 $out/man/man5
+    cp man/mustache.5.html $out/doc/html
+  '';
+
+  meta = rec {
+    description = "Logic-less templates, specification package";
+    longDescription = ''
+      Inspired by ctemplate and et, Mustache is a framework-agnostic way to
+      render logic-free views.
+
+      Provides the specification as man page and html docs.
+
+      As ctemplates says, "It emphasizes separating logic from presentation: it
+      is impossible to embed application logic in this template language."
+
+      For a list of implementations and tips, see ${homepage}.
+    '';
+
+    homepage = "http://mustache.github.io/";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ profpatsch ];
+    platforms = lib.platforms.all;
+  };
+}