summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorleenaars <leenaars@users.noreply.github.com>2018-08-01 09:57:32 +0200
committerxeji <36407913+xeji@users.noreply.github.com>2018-08-01 09:57:32 +0200
commit184a30bdc26bb0ba3d72917ffa1711ee0b76c326 (patch)
tree1fdcc93dbb23b441ab1f96408826a44383192948 /pkgs/data
parent29c10b8f7feb218faafa32b98a3ff41de810e692 (diff)
downloadnixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar.gz
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar.bz2
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar.lz
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar.xz
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.tar.zst
nixlib-184a30bdc26bb0ba3d72917ffa1711ee0b76c326.zip
inriafonts: init at 1.200 (#44280)
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/inriafonts/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/data/fonts/inriafonts/default.nix b/pkgs/data/fonts/inriafonts/default.nix
new file mode 100644
index 000000000000..a2192385abc2
--- /dev/null
+++ b/pkgs/data/fonts/inriafonts/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+
+  pname = "inriafonts";
+  version = "1.200";
+  name = "${pname}-${version}";
+
+src = fetchFromGitHub {
+  owner = "BlackFoundry";
+  repo = "InriaFonts";
+  rev = "v${version}";
+  sha256 = "06775y99lyh6hj5hzvrx56iybdck8a8xfqkipqd5c4cldg0a9hh8";
+};
+
+installPhase = ''
+  mkdir -p $out/share/fonts/truetype
+  cp fonts/*/TTF/*.ttf $out/share/fonts/truetype
+  mkdir -p $out/share/fonts/opentype
+  cp fonts/*/OTF/*.otf $out/share/fonts/opentype
+'';
+
+  meta = with stdenv.lib; {
+    homepage = https://black-foundry.com/work/inria;
+    description = "Inria Sans and Inria Serif";
+    longDescription = ''
+      Inria Sans and Inria Serif are the two members of a type family
+      design for the communication of Inria, the French national institute
+      dedicated to numeric research. The Institut needed a font
+      showing its values at the crossroad of humanity, technology,
+      excellence and creativity. Black[Foudry] created a humanist
+      typeface with a unapologetically contemporary design as the
+      Sans-serif part and a more rational axis and drawing for the
+      serif. Both members comes in 3 weights with matching italics.
+      '';
+    license = licenses.ofl;
+    maintainers = with maintainers; [ leenaars ];
+    platforms = platforms.all;
+  };
+}