summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-10-02 00:04:29 +0200
committerGitHub <noreply@github.com>2018-10-02 00:04:29 +0200
commit0229934c6686e0d5302127810fd881c38da3bca2 (patch)
tree8608f63347c653bff824edf0c6d65f79f6f2541f /pkgs/data
parentd25ce11fbc291cb31f578268877d14d0a833cf78 (diff)
parent68bdaad07801af50ae281579b21772bc0184267b (diff)
downloadnixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar.gz
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar.bz2
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar.lz
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar.xz
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.tar.zst
nixlib-0229934c6686e0d5302127810fd881c38da3bca2.zip
Merge pull request #46198 from leenaars/hyperscrypt
hyperscrypt-font: init at 1.1
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/hyperscrypt/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/data/fonts/hyperscrypt/default.nix b/pkgs/data/fonts/hyperscrypt/default.nix
new file mode 100644
index 000000000000..80516eb0293c
--- /dev/null
+++ b/pkgs/data/fonts/hyperscrypt/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchzip, lib }:
+
+let
+  version = "1.1";
+  pname = "HyperScrypt";
+in
+
+fetchzip rec {
+  name = "${lib.toLower pname}-font-${version}";
+  url = "https://gitlab.com/StudioTriple/Hyper-Scrypt/-/archive/${version}/Hyper-Scrypt-${version}.zip";
+  sha256 = "01pf5p2scmw02s0gxnibiwxbpzczphaaapv0v4s7svk9aw2gmc0m";
+  postFetch = ''
+    mkdir -p $out/share/fonts/{truetype,opentype}
+    unzip -j $downloadedFile \*.ttf -d $out/share/fonts/truetype/${pname}.ttf
+    unzip -j $downloadedFile \*${pname}.otf -d $out/share/fonts/opentype/${pname}.otf
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://velvetyne.fr/fonts/hyper-scrypt/;
+    description = "A modern stencil typeface inspired by stained glass technique";
+    longDescription = ''
+      The Hyper Scrypt typeface was designed for the Hyper Chapelle
+      exhibition. It was commissioned by AAAAA Atelier to Studio
+      Triple's designer Jérémy Landes.  Hyper Scrypt is a modern
+      stencil typeface inspired by the stained glass technique used in
+      the Metz cathedral. It borrows the stained glass method, drawing
+      holes for the light with black lead. This creates a reverse
+      typeface, where the shapes of the letters are drawn by their
+      counters. Hyper Scrypt is at the intersection between 3 metals :
+      the sacred lead of stained glass, the lead of print characters
+      and the heavy metal. Despite its organic look inherited for the
+      molted metal, Hyper Scrypt is based upon a rigorous grid,
+      allowing some neat alignements between shapes in multi lines
+      layouts.
+      '';
+    license = licenses.ofl;
+    maintainers = with maintainers; [ leenaars ];
+    platforms = platforms.all;
+  };
+}