summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorFalco Peijnenburg <falco@lumiguide.nl>2017-10-30 16:48:26 +0100
committerFalco Peijnenburg <falco@lumiguide.nl>2017-10-30 16:48:26 +0100
commitfebe376f13b7b57de26af5af271ddcb565a25d74 (patch)
tree0273f75527396eb447970f567777dd0e9981d93e /pkgs/build-support
parent4a4f6ba41878d514d7c2616c85242ff31a13a06b (diff)
downloadnixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar.gz
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar.bz2
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar.lz
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar.xz
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.tar.zst
nixlib-febe376f13b7b57de26af5af271ddcb565a25d74.zip
fetchadc: removed
It's not being used
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchadc/builder.sh7
-rw-r--r--pkgs/build-support/fetchadc/default.nix36
2 files changed, 0 insertions, 43 deletions
diff --git a/pkgs/build-support/fetchadc/builder.sh b/pkgs/build-support/fetchadc/builder.sh
deleted file mode 100644
index ceeaa9213d65..000000000000
--- a/pkgs/build-support/fetchadc/builder.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-source $stdenv/setup
-
-loginpage=`curl --insecure -s -L -b cookies.txt "$url"`
-
-[[ $loginpage =~ form[^\>]+action=\"([^\"]+)\" ]] && loginurl=${BASH_REMATCH[1]}
-
-curl  --insecure -s --output "$out" -L -b cookies.txt --data "appleId=${adc_user}&accountPassword=${adc_pass}" "https://idmsa.apple.com/IDMSWebAuth/${loginurl}"
diff --git a/pkgs/build-support/fetchadc/default.nix b/pkgs/build-support/fetchadc/default.nix
deleted file mode 100644
index 4d759e6f7f18..000000000000
--- a/pkgs/build-support/fetchadc/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ stdenv, curl, adc_user, adc_pass }:
-
-{ # Path to fetch.
-  path
-
-  # Hash of the downloaded file
-, sha256
-
-, # Additional curl options needed for the download to succeed.
-  curlOpts ? ""
-
-, # Name of the file.  If empty, use the basename of `path'.
-  name ? ""
-}:
-
-stdenv.mkDerivation {
-  url = "https://developer.apple.com/downloads/download.action?path=${path}";
-
-  name    = if name != "" then name else baseNameOf path;
-  builder = ./builder.sh;
-
-  buildInputs = [ curl ];
-
-  meta = {
-    # Password-guarded files from ADC are certainly unfree, as far as we're concerned!
-    license = stdenv.lib.licenses.unfree;
-  };
-
-  outputHashAlgo = "sha256";
-  outputHash     =  sha256;
-  outputHashMode = "flat";
-
-  inherit curlOpts adc_user adc_pass;
-
-  preferLocalBuild = true;
-}