summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-03 14:45:56 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-03 15:23:13 +0200
commitf361938b210e057906dcdd5471275ddf265e4a4e (patch)
treeea69e01503464f511e388d36fe69c3c689b42fbc /pkgs/build-support
parentf2cb132c34d115761a19728a2a6a595f4fa08761 (diff)
parentb233ecdca68e08940024da6e4e55e6ef2a20863f (diff)
downloadnixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar.gz
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar.bz2
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar.lz
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar.xz
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.tar.zst
nixlib-f361938b210e057906dcdd5471275ddf265e4a4e.zip
Merge staging into closure-size
This makes gcc5 the default builder, etc.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/build-fhs-chrootenv/env.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/build-support/build-fhs-chrootenv/env.nix b/pkgs/build-support/build-fhs-chrootenv/env.nix
index b659655f74b9..a2ac8288e8ec 100644
--- a/pkgs/build-support/build-fhs-chrootenv/env.nix
+++ b/pkgs/build-support/build-fhs-chrootenv/env.nix
@@ -182,6 +182,12 @@ let
   setupLibDirs = if isTargetBuild then setupLibDirs_target
                                   else setupLibDirs_multi;
 
+  setupIncludeDir = ''
+    if [ -x "${staticUsrProfileTarget}/include" ]
+    then
+        ln -s "${staticUsrProfileTarget}/include"
+    fi
+  '';
 
   # the target profile is the actual profile that will be used for the chroot
   setupTargetProfile = ''
@@ -192,6 +198,7 @@ let
     cd usr
     ${linkProfile staticUsrProfileTarget}
     ${setupLibDirs}
+    ${setupIncludeDir}
     cd ..
     rm -rf usr/etc usr/var
   '';