summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-09-26 21:01:05 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-09-26 21:59:04 +0200
commitef35406c09e19792d57cc3121cdcd4c43afa6f46 (patch)
tree8a4274c0f93ce2bbcb590d3434ee6ac7dcdccebb /pkgs/build-support
parent87067dc471a1592f4933f283648eb52a99f096b5 (diff)
parentd349f9a34006cc484b5e7509a3f227d52d6e2a5d (diff)
downloadnixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar.gz
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar.bz2
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar.lz
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar.xz
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.tar.zst
nixlib-ef35406c09e19792d57cc3121cdcd4c43afa6f46.zip
Merge #29617: cc-wrapper: Use stdenvNoCC to build
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index 866be9cded9e..489fb02dcb5d 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -5,15 +5,15 @@
 # script that sets up the right environment variables so that the
 # compiler and the linker just "work".
 
-{ name ? "", stdenv, nativeTools, noLibc ? false, nativeLibc, nativePrefix ? ""
-, cc ? null, libc ? null, binutils ? null, coreutils ? null, shell ? stdenv.shell
+{ name ? "", stdenvNoCC, nativeTools, noLibc ? false, nativeLibc, nativePrefix ? ""
+, cc ? null, libc ? null, binutils ? null, coreutils ? null, shell ? stdenvNoCC.shell
 , zlib ? null, extraPackages ? [], extraBuildCommands ? ""
 , isGNU ? false, isClang ? cc.isClang or false, gnugrep ? null
 , buildPackages ? {}
 , useMacosReexportHack ? false
 }:
 
-with stdenv.lib;
+with stdenvNoCC.lib;
 
 assert nativeTools -> nativePrefix != "";
 assert !nativeTools ->
@@ -25,6 +25,7 @@ assert (noLibc || nativeLibc) == (libc == null);
 assert cc.langVhdl or false -> zlib != null;
 
 let
+  stdenv = stdenvNoCC;
   inherit (stdenv) hostPlatform targetPlatform;
 
   # Prefix for binaries. Customarily ends with a dash separator.