summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-09-14 22:27:19 -0600
committerMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-09-14 22:27:19 -0600
commiteb7404d97a7e46df1f598a74982ca06e08033a45 (patch)
tree6b5752df7032ba1efc535cf884db4891f20dd786 /pkgs/build-support
parent7fb1c7efcfa34a4af9f5de5fbde9e12d15017a90 (diff)
downloadnixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.gz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.bz2
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.lz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.xz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.zst
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.zip
all-packages: Use callPackage where possible
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/builder-defs/builder-defs.nix20
-rw-r--r--pkgs/build-support/emacs/trivial.nix2
2 files changed, 11 insertions, 11 deletions
diff --git a/pkgs/build-support/builder-defs/builder-defs.nix b/pkgs/build-support/builder-defs/builder-defs.nix
index e7c64501614c..d4e7f703af9b 100644
--- a/pkgs/build-support/builder-defs/builder-defs.nix
+++ b/pkgs/build-support/builder-defs/builder-defs.nix
@@ -1,26 +1,26 @@
-args: with args; with stringsWithDeps; with lib;
+args @ {stringsWithDeps, lib, stdenv, writeScript, fetchurl, fetchmtn, fetchgit, ...}: with args; with stringsWithDeps; with lib;
 let inherit (builtins) head tail trace; in
 (rec
 {
-        inherit writeScript; 
+        inherit writeScript;
 
         src = attrByPath ["src"] "" args;
 
         addSbinPath = attrByPath ["addSbinPath"] false args;
 
         forceShare = if args ? forceShare then args.forceShare else ["man" "doc" "info"];
-        forceCopy = ["COPYING" "LICENSE" "DISTRIBUTION" "LEGAL" 
-          "README" "AUTHORS" "ChangeLog" "CHANGES" "LICENCE" "COPYRIGHT"] ++ 
-          (optional (attrByPath ["forceCopyDoc"] true args) "doc"); 
+        forceCopy = ["COPYING" "LICENSE" "DISTRIBUTION" "LEGAL"
+          "README" "AUTHORS" "ChangeLog" "CHANGES" "LICENCE" "COPYRIGHT"] ++
+          (optional (attrByPath ["forceCopyDoc"] true args) "doc");
 
         hasSuffixHack = a: b: hasSuffix (a+(substring 0 0 b)) ((substring 0 0 a)+b);
-        
-        archiveType = s: 
+
+        archiveType = s:
                 (if hasSuffixHack ".tar" s then "tar"
-                else if (hasSuffixHack ".tar.gz" s) || (hasSuffixHack ".tgz" s) then "tgz" 
-                else if (hasSuffixHack ".tar.bz2" s) || (hasSuffixHack ".tbz2" s) || 
+                else if (hasSuffixHack ".tar.gz" s) || (hasSuffixHack ".tgz" s) then "tgz"
+                else if (hasSuffixHack ".tar.bz2" s) || (hasSuffixHack ".tbz2" s) ||
 			(hasSuffixHack ".tbz" s) then "tbz2"
-                else if hasSuffixHack ".tar.Z" s then "tZ" 
+                else if hasSuffixHack ".tar.Z" s then "tZ"
                 else if hasSuffixHack ".tar.lzma" s then "tar.lzma"
                 else if hasSuffixHack ".tar.xz" s then "tar.xz"
                 else if hasSuffixHack ".rar" s then "rar"
diff --git a/pkgs/build-support/emacs/trivial.nix b/pkgs/build-support/emacs/trivial.nix
index 9c97e8bf9514..98463c56ba96 100644
--- a/pkgs/build-support/emacs/trivial.nix
+++ b/pkgs/build-support/emacs/trivial.nix
@@ -1,6 +1,6 @@
 # trivial builder for Emacs packages
 
-{ lib, ... }@envargs:
+{ lib, stdenv, texinfo, ... }@envargs:
 
 with lib;