summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-16 15:16:08 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-16 15:16:08 -0400
commitddbe9191ef1549e7695e5e02e545b1b3db46edb4 (patch)
tree90e8f4e8bf5c4410b351229cdc637333bae88024 /pkgs/build-support
parent16b6f53910f19b84c5d8c5fb58a8ce958fc8a7d3 (diff)
parentf3fcf1b0a9b0398620b5fa9b40268ef651aa373e (diff)
downloadnixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar.gz
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar.bz2
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar.lz
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar.xz
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.tar.zst
nixlib-ddbe9191ef1549e7695e5e02e545b1b3db46edb4.zip
Merge remote-tracking branch 'upstream/master' into staging
Keep the dontCheck because the test suite fails, get rid of the LDFLAGS
hack because we don't need it!
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/trivial-builders.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/build-support/trivial-builders.nix b/pkgs/build-support/trivial-builders.nix
index d092efb556e5..2ec56c94763a 100644
--- a/pkgs/build-support/trivial-builders.nix
+++ b/pkgs/build-support/trivial-builders.nix
@@ -138,6 +138,7 @@ rec {
                 , sha1 ? null
                 , url ? null
                 , message ? null
+                , hashMode ? "flat"
                 } :
     assert (message != null) || (url != null);
     assert (sha256 != null) || (sha1 != null);
@@ -158,6 +159,7 @@ rec {
     in
     stdenv.mkDerivation {
       name = name_;
+      outputHashMode = hashMode;
       outputHashAlgo = hashAlgo;
       outputHash = hash;
       preferLocalBuild = true;