summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-05-15 01:15:16 -0400
committerShea Levy <shea@shealevy.com>2013-05-15 01:15:16 -0400
commitdd42dd480b8e3b6895d0abbce9dd0e9cd7632a23 (patch)
treecbc85c351bdedca6ce0cf9f5fe47351d31f6a106 /pkgs/build-support
parent03b6fe7422fa41c4fec3536b3290079522da4f27 (diff)
downloadnixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar.gz
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar.bz2
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar.lz
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar.xz
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.tar.zst
nixlib-dd42dd480b8e3b6895d0abbce9dd0e9cd7632a23.zip
runInLinuxImage: Fix derivation overriding.
This only ever worked because runInLinuxVM happened to call
overrideDerivation, which itself erroneously passed arbitrarily-added
attributes to the new call to derivation.

Hopefully this time Eelco won't have to revert my change ;)

Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index fac85c162e8b..b1eb82ed8303 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -445,7 +445,7 @@ rec {
      etc. from the specified filesystem image, which typically is a
      filesystem containing a non-NixOS Linux distribution. */
 
-  runInLinuxImage = attrs: runInLinuxVM (attrs // {
+  runInLinuxImage = drv: runInLinuxVM (lib.overrideDerivation drv (attrs: {
     mountDisk = true;
 
     /* Mount `image' as the root FS, but use a temporary copy-on-write
@@ -470,7 +470,7 @@ rec {
 
     /* Don't run Nix-specific build steps like patchelf. */
     fixupPhase = "true";
-  });
+  }));
 
 
   /* Create a filesystem image of the specified size and fill it with