summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-08-26 11:43:30 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-01 11:44:56 -0400
commitdbf6d20d64af8572ae4a24850244befc475eea9e (patch)
treeda102645847225204b7c6e52e64ea6fb398b2a7a /pkgs/build-support
parent3f30cffa559e105017a1f88a8f3667a11a416870 (diff)
downloadnixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar.gz
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar.bz2
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar.lz
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar.xz
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.tar.zst
nixlib-dbf6d20d64af8572ae4a24850244befc475eea9e.zip
binutils-wrapper: Import separately from cc-wrapper
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/binutils-wrapper/default.nix2
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix18
2 files changed, 4 insertions, 16 deletions
diff --git a/pkgs/build-support/binutils-wrapper/default.nix b/pkgs/build-support/binutils-wrapper/default.nix
index e885078c3de7..7e255cdb2eb1 100644
--- a/pkgs/build-support/binutils-wrapper/default.nix
+++ b/pkgs/build-support/binutils-wrapper/default.nix
@@ -84,7 +84,7 @@ stdenv.mkDerivation {
   outputs = [ "out" "man" ];
 
   passthru = {
-    inherit libc nativeTools nativeLibc nativePrefix prefix;
+    inherit binutils libc nativeTools nativeLibc nativePrefix prefix;
 
     emacsBufferSetup = pkgs: ''
       ; We should handle propagation here too
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index c9820c27ea5e..30520290086c 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -6,18 +6,17 @@
 # compiler and the linker just "work".
 
 { name ? "", stdenv, nativeTools, noLibc ? false, nativeLibc, nativePrefix ? ""
-, cc ? null, libc ? null, binutils ? null, coreutils ? null, shell ? stdenv.shell
+, cc ? null, libc ? null, binutils, coreutils ? null, shell ? stdenv.shell
 , zlib ? null, extraPackages ? [], extraBuildCommands ? ""
 , isGNU ? false, isClang ? cc.isClang or false, gnugrep ? null
 , buildPackages ? {}
-, useMacosReexportHack ? false
-} @ args:
+}:
 
 with stdenv.lib;
 
 assert nativeTools -> nativePrefix != "";
 assert !nativeTools ->
-  cc != null && binutils != null && coreutils != null && gnugrep != null;
+  cc != null && coreutils != null && gnugrep != null;
 assert !(nativeLibc && noLibc);
 assert (noLibc || nativeLibc) == (libc == null);
 
@@ -27,17 +26,6 @@ assert cc.langVhdl or false -> zlib != null;
 let
   inherit (stdenv) hostPlatform targetPlatform;
 
-  binutils = import ../binutils-wrapper {
-    inherit (args) binutils;
-    inherit # name
-      stdenv nativeTools noLibc nativeLibc nativePrefix
-      libc
-      coreutils shell gnugrep
-      extraPackages extraBuildCommands
-      buildPackages
-      useMacosReexportHack;
-  };
-
   # Prefix for binaries. Customarily ends with a dash separator.
   #
   # TODO(@Ericson2314) Make unconditional, or optional but always true by