summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-23 16:00:04 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-23 16:00:04 -0400
commitd7144e708b21127f379571f72f8425cbd79bcfbf (patch)
treed41ad3f488cbabb7dd5a32e5e9b651242a4228b4 /pkgs/build-support
parent89e196d971e167867318c8fc2e08cb0782c75bec (diff)
parent78319bd948efc53b94bf942b155a8bc4060d5a08 (diff)
downloadnixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar.gz
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar.bz2
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar.lz
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar.xz
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.tar.zst
nixlib-d7144e708b21127f379571f72f8425cbd79bcfbf.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/nix-prefetch-github/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/build-support/nix-prefetch-github/default.nix b/pkgs/build-support/nix-prefetch-github/default.nix
new file mode 100644
index 000000000000..48297e583afe
--- /dev/null
+++ b/pkgs/build-support/nix-prefetch-github/default.nix
@@ -0,0 +1,30 @@
+{ python3
+, fetchFromGitHub
+, stdenv
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "nix-prefetch-github";
+  version = "1.3";
+
+  src = fetchFromGitHub {
+    owner = "seppeljordan";
+    repo = "nix-prefetch-github";
+    rev = "${version}";
+    sha256 = "1rinbv1q4q8m27ih6l81w1lsmwn6cz7q3iyjiycklywpi8684dh6";
+  };
+
+  propagatedBuildInputs = with python3.pkgs; [
+    attrs
+    click
+    effect
+    jinja2
+    requests
+  ];
+  meta = with stdenv.lib; {
+    description = "Prefetch sources from github";
+    homepage = https://github.com/seppeljordan/nix-prefetch-github;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.seppeljordan ];
+  };
+}