summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-07-14 13:47:14 +0100
committerGitHub <noreply@github.com>2017-07-14 13:47:13 +0100
commitce39a9c837d31759a28e5ab22381dbc5622c7880 (patch)
treef0847a42b28ce1dd94b44eddc5bc774383608f73 /pkgs/build-support
parentdf34c92af5f5f3df127dceb7b796d3283f3dadd2 (diff)
parent6bf72482eb2c0c5908af0395e616e80c1de7c8f9 (diff)
downloadnixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar.gz
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar.bz2
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar.lz
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar.xz
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.tar.zst
nixlib-ce39a9c837d31759a28e5ab22381dbc5622c7880.zip
Merge pull request #27160 from bkchr/makeautostartitem_fix
make-autostartitem: Use the right path for storing the desktop files
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/make-startupitem/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/build-support/make-startupitem/default.nix b/pkgs/build-support/make-startupitem/default.nix
index fad6f00d8211..da1d4105c89f 100644
--- a/pkgs/build-support/make-startupitem/default.nix
+++ b/pkgs/build-support/make-startupitem/default.nix
@@ -19,14 +19,14 @@ stdenv.mkDerivation {
   priority = 5;
 
   buildCommand = ''
-    mkdir -p $out/share/autostart
+    mkdir -p $out/etc/xdg/autostart
     target=${name}.desktop
     cp ${package}/share/applications/${srcPrefix}${name}.desktop $target
     chmod +rw $target
     echo "X-KDE-autostart-phase=${phase}" >> $target
     ${lib.optionalString (after != null) ''echo "${after}" >> $target''}
     ${lib.optionalString (condition != null) ''echo "${condition}" >> $target''}
-    cp $target $out/share/autostart
+    cp $target $out/etc/xdg/autostart
   '';
 
   # this will automatically put 'package' in the environment when you