summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorDaniel Peebles <pumpkin@me.com>2014-10-01 21:57:27 -0400
committerMateusz Kowalczyk <fuuzetsu@fuuzetsu.co.uk>2014-10-02 06:50:09 +0100
commitc55c435ade3090f3c23dfbe46dfe26781cb1476c (patch)
tree512220d1dfd45d9bf9457e0b4f1e4479e1c24cba /pkgs/build-support
parent59418454e615e14938eeaeb3357912049bc44ef1 (diff)
downloadnixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar.gz
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar.bz2
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar.lz
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar.xz
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.tar.zst
nixlib-c55c435ade3090f3c23dfbe46dfe26781cb1476c.zip
Add Apple command-line tools
Closes #4365
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchadc/default.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/pkgs/build-support/fetchadc/default.nix b/pkgs/build-support/fetchadc/default.nix
index efd477d59889..ac7a442de315 100644
--- a/pkgs/build-support/fetchadc/default.nix
+++ b/pkgs/build-support/fetchadc/default.nix
@@ -10,8 +10,8 @@ let
   ];
 in
 
-{ # URL to fetch.
-  url
+{ # Path to fetch.
+  path
 
   # Hash of the downloaded file
 , sha256
@@ -19,13 +19,14 @@ in
 , # Additional curl options needed for the download to succeed.
   curlOpts ? ""
 
-, # Name of the file.  If empty, use the basename of `url' (or of the
-  # first element of `urls').
+, # Name of the file.  If empty, use the basename of `path'.
   name ? ""
 }:
 
 stdenv.mkDerivation {
-  name    = if name != "" then name else baseNameOf (toString url);
+  url = "https://developer.apple.com/downloads/download.action?path=${path}";
+
+  name    = if name != "" then name else baseNameOf path;
   builder = ./builder.sh;
 
   buildInputs = [ curl ];
@@ -39,7 +40,7 @@ stdenv.mkDerivation {
   outputHash     =  sha256;
   outputHashMode = "flat";
 
-  inherit curlOpts url adc_user adc_pass;
+  inherit curlOpts adc_user adc_pass;
 
   preferLocalBuild = true;
-}
\ No newline at end of file
+}