summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2015-05-24 13:52:12 +0000
committerJan Malakhovski <oxij@oxij.org>2015-05-24 14:26:39 +0000
commitbdf32ed2ab1ed0f627a6217d85be942763c2bb1a (patch)
tree0ecc7adea436608c20754d58020886da282348d0 /pkgs/build-support
parent59ab07351b87ad1fbaf234f1a1109f82bee4e03e (diff)
downloadnixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar.gz
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar.bz2
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar.lz
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar.xz
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.tar.zst
nixlib-bdf32ed2ab1ed0f627a6217d85be942763c2bb1a.zip
fetchurl: allow adding meta info; fetchFrom*: add meta.homepage
The point of this is to be able to do `meta.homepage = src.meta.homepage;`
instead of the usual copy-paste for the packages that are hosted
on these hosting services.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchurl/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/build-support/fetchurl/default.nix b/pkgs/build-support/fetchurl/default.nix
index 0d7534e67587..b1dc6e7be31b 100644
--- a/pkgs/build-support/fetchurl/default.nix
+++ b/pkgs/build-support/fetchurl/default.nix
@@ -76,6 +76,9 @@ in
 , # If set, don't download the file, but write a list of all possible
   # URLs (resulting from resolving mirror:// URLs) to $out.
   showURLs ? false
+
+, # Meta information, if any.
+  meta ? {}
 }:
 
 assert builtins.isList urls;
@@ -120,4 +123,6 @@ if (!hasHash) then throw "Specify hash for fetchurl fixed-output derivation: ${s
   # Doing the download on a remote machine just duplicates network
   # traffic, so don't do that.
   preferLocalBuild = true;
+
+  inherit meta;
 }