summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2014-10-22 00:23:12 +0200
committerPeter Simons <simons@cryp.to>2014-10-22 00:23:12 +0200
commitbddf342631ce417dac99f6f222075c51cf4109de (patch)
tree16ba2d8e3af939915fa8468ca95c58eb2257a074 /pkgs/build-support
parent7a20d764827f12bdd783a63a14ff0b2b9fcfeb96 (diff)
downloadnixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar.gz
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar.bz2
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar.lz
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar.xz
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.tar.zst
nixlib-bddf342631ce417dac99f6f222075c51cf4109de.zip
Patch 7a20d76 failed when the Haskell expression lacked a meta attribute. This commit fixes that issue.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cabal/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/cabal/default.nix b/pkgs/build-support/cabal/default.nix
index 2b06adf3490c..3fa833876921 100644
--- a/pkgs/build-support/cabal/default.nix
+++ b/pkgs/build-support/cabal/default.nix
@@ -58,7 +58,7 @@ assert !enableStaticLibraries -> versionOlder "7.7" ghc.version;
                 doCheck               = enableCheckPhase && x.doCheck;
                 hyperlinkSource       = enableHyperlinkSource && x.hyperlinkSource;
                 # Disable Darwin builds: <https://github.com/NixOS/nixpkgs/issues/2689>.
-                meta                  = let meta = x.meta;
+                meta                  = let meta = x.meta or {};
                                             hydraPlatforms = meta.hydraPlatforms or meta.platforms or [];
                                             noElem         = p: ps: !stdenv.lib.elem p ps;
                                             noDarwin       = p: noElem p stdenv.lib.platforms.darwin;