summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2006-03-10 16:12:46 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2006-03-10 16:12:46 +0000
commitbaec8f5b38e83a456eebdf742834efc2c22386c6 (patch)
treeecd654568b44dba0a8a0fb0c6abebbc7b1c5feda /pkgs/build-support
parent4c63a4a97a56d992ccc83e77ce477d3b22906240 (diff)
downloadnixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar.gz
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar.bz2
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar.lz
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar.xz
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.tar.zst
nixlib-baec8f5b38e83a456eebdf742834efc2c22386c6.zip
* stdenv.mkDerivation now takes an optional attribute "meta" that
  contains arbitrary information about a package, like this:

  meta = {
    homepage = "http://gcc.gnu.org/";
    license = "GPL/LGPL";
    description = "GNU Compiler Collection, 4.0.x";
  };

  The "meta" attribute is not passed to the actual derivation
  operation, so it's not a dependency --- changes to "meta" attributes
  don't trigger a recompilation.

  Now we have to standardise some useful attributes ;-)

svn path=/nixpkgs/branches/usability/; revision=5024
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/gcc-cross-wrapper/default.nix3
-rw-r--r--pkgs/build-support/gcc-wrapper/default.nix3
2 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/build-support/gcc-cross-wrapper/default.nix b/pkgs/build-support/gcc-cross-wrapper/default.nix
index 0ceab44ee27c..09f7f006928e 100644
--- a/pkgs/build-support/gcc-cross-wrapper/default.nix
+++ b/pkgs/build-support/gcc-cross-wrapper/default.nix
@@ -27,4 +27,7 @@ stdenv.mkDerivation {
   langCC = if nativeTools then true else gcc.langCC;
   langF77 = if nativeTools then false else gcc.langF77;
   shell = if shell == "" then stdenv.shell else shell;
+  meta = if gcc != null then gcc.meta else
+    { description = "System C compiler wrapper";
+    };
 }
diff --git a/pkgs/build-support/gcc-wrapper/default.nix b/pkgs/build-support/gcc-wrapper/default.nix
index 4296aef67c8b..22d023951293 100644
--- a/pkgs/build-support/gcc-wrapper/default.nix
+++ b/pkgs/build-support/gcc-wrapper/default.nix
@@ -27,4 +27,7 @@ stdenv.mkDerivation {
   langCC = if nativeTools then true else gcc.langCC;
   langF77 = if nativeTools then false else gcc.langF77;
   shell = if shell == "" then stdenv.shell else shell;
+  meta = if gcc != null then gcc.meta else
+    { description = "System C compiler wrapper";
+    };
 }