summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-05 00:11:47 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-05 00:17:04 +0200
commit9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c (patch)
tree992d04f173012e9d98bd7bb26e532f4f4c339c9c /pkgs/build-support
parent0e386d0c1373809d3459d09532ad36be0faf6dfb (diff)
downloadnixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar.gz
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar.bz2
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar.lz
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar.xz
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.tar.zst
nixlib-9f5f30a7e6efe42b2e6ccddebaf710706dd6a73c.zip
Remove runInGenericVM
It's not used anywhere and probably doesn't work anymore.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix50
-rw-r--r--pkgs/build-support/vm/test.nix35
2 files changed, 0 insertions, 85 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index 4e02118edff1..097fcf21c1b6 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -345,56 +345,6 @@ rec {
     });
 
 
-  qemuCommandGeneric = ''
-    PATH="${samba}/sbin:$PATH" \
-    ${qemuProg} \
-      -enable-kvm \
-      -nographic -no-reboot \
-      -smb $(pwd) -hda $diskImage \
-      $QEMU_OPTS
-  '';
-
-
-  /* Run a command in an x86 virtual machine image containing an
-     arbitrary OS.  The VM should be configured to do the following:
-
-     - Write log output to the serial port.
-
-     - Mount //10.0.2.4/qemu via SMB.
-
-     - Execute the command "cmd" on the SMB share.  It can access the
-       original derivation attributes in "saved-env" on the share.
-
-     - Produce output under "out" on the SMB share.
-
-     - Write an exit code to "in-vm-exit" on the SMB share ("0"
-       meaning success).
-
-     - Power-off or reboot the machine.
-  */
-  runInGenericVM = drv: lib.overrideDerivation drv (attrs: {
-    requiredSystemFeatures = [ "kvm" ];
-    builder = "${bash}/bin/sh";
-    args = ["-e" (vmRunCommand qemuCommandGeneric)];
-    QEMU_OPTS = "-m ${toString (if attrs ? memSize then attrs.memSize else 256)}";
-
-    preVM = ''
-      diskImage=$(pwd)/disk-image.qcow2
-      origImage=${attrs.diskImage}
-      if test -d "$origImage"; then origImage="$origImage/disk-image.qcow2"; fi
-      ${kvm}/bin/qemu-img create -b "$origImage" -f qcow2 $diskImage
-
-      echo "$buildCommand" > cmd
-
-      eval "$postPreVM"
-    '';
-
-    postVM = ''
-      cp -prvd out $out
-    '';
-  });
-
-
   /* Like runInLinuxVM, but run the build not using the stdenv from
      the Nix store, but using the tools provided by /bin, /usr/bin
      etc. from the specified filesystem image, which typically is a
diff --git a/pkgs/build-support/vm/test.nix b/pkgs/build-support/vm/test.nix
index 798c283a1774..d0d85fce3662 100644
--- a/pkgs/build-support/vm/test.nix
+++ b/pkgs/build-support/vm/test.nix
@@ -36,39 +36,4 @@ rec {
     '';
   });
 
-/*
-  testFreeBSD = runInGenericVM {
-    name = "aterm-freebsd";
-    src = aterm242fixes.src;
-    diskImage = "/tmp/freebsd-7.0.qcow";
-
-    postPreVM = ''
-      cp $src aterm.tar.bz2
-    '';
-
-    buildCommand = ''
-      set > /tmp/my-env
-      . /mnt/saved-env
-      . /tmp/my-env
-      unset TEMP
-      unset TEMPDIR
-      unset TMP
-      unset TMPDIR
-
-      set -x
-
-      echo "Hello World!!!"
-      mkdir /mnt/out
-      echo "bar" > /mnt/out/foo
-
-      cd /tmp
-      tar xvf /mnt/aterm.tar.bz2
-      cd aterm-*
-      ./configure --prefix=/mnt/out
-      make
-      make install
-    '';
-  };
-*/
-
 }