summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2011-12-11 19:39:16 +0000
committerPeter Simons <simons@cryp.to>2011-12-11 19:39:16 +0000
commit9dab7db8a2750196d5f4b9aeae7e88871bd965ac (patch)
treed308cb3cb7a9db7c7531a14db1fa96d31595637d /pkgs/build-support
parentba935dcbc03b8a51f91bb62fb131830b99e66855 (diff)
downloadnixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar.gz
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar.bz2
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar.lz
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar.xz
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.tar.zst
nixlib-9dab7db8a2750196d5f4b9aeae7e88871bd965ac.zip
added git support to builder-defs
svn path=/nixpkgs/trunk/; revision=30840
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/builder-defs/builder-defs.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/build-support/builder-defs/builder-defs.nix b/pkgs/build-support/builder-defs/builder-defs.nix
index 58c439e4316e..ba13a0911f7a 100644
--- a/pkgs/build-support/builder-defs/builder-defs.nix
+++ b/pkgs/build-support/builder-defs/builder-defs.nix
@@ -25,6 +25,7 @@ let inherit (builtins) head tail trace; in
                 else if (hasSuffixHack ".tar.xz" s) then "tar.xz"
                 else if (hasSuffixHack ".zip" s) || (hasSuffixHack ".ZIP" s) then "zip"
                 else if (hasSuffixHack "-cvs-export" s) then "cvs-dir"
+                else if (hasSuffixHack "-git-export" s) then "git-dir"
                 else if (hasSuffixHack ".nar.bz2" s) then "narbz2"
                 else if (hasSuffixHack ".rpm" s) then "rpm"
 
@@ -228,6 +229,10 @@ let inherit (builtins) head tail trace; in
                 cp -r '${s}' .
                 cd \$(basename ${s})
                 chmod u+rwX -R .
+        " else if (archiveType s) == "git-dir" then "
+                cp -r '${s}' .
+                cd \$(basename ${s})
+                chmod u+rwX -R .
         " else if (archiveType s) == "dir" then "
                 cp -r '${s}' .
                 cd \$(basename ${s})