summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2013-04-23 15:03:46 +0200
committerPeter Simons <simons@cryp.to>2013-04-24 13:21:05 +0200
commit944ae2e5ff8ef7973b4a417e3d3b551eba9704e6 (patch)
tree1a9c46e7f8ce686c055efc2a9ea9c13906d00d21 /pkgs/build-support
parente0b57c9fb91be00f7e1026a9afe82b90d1ac8ba4 (diff)
downloadnixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar.gz
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar.bz2
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar.lz
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar.xz
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.tar.zst
nixlib-944ae2e5ff8ef7973b4a417e3d3b551eba9704e6.zip
pkgs/build-support/cabal: disable split-objects for GHC 7.7 builds to work around broken compiler
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cabal/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/build-support/cabal/default.nix b/pkgs/build-support/cabal/default.nix
index 7706e849f504..ca985181a532 100644
--- a/pkgs/build-support/cabal/default.nix
+++ b/pkgs/build-support/cabal/default.nix
@@ -96,7 +96,9 @@ assert enableCheckPhase -> stdenv.lib.versionOlder "7" ghc.ghcVersion;
             jailbreak = false;
 
             # pass the '--enable-split-objs' flag to cabal in the configure stage
-            enableSplitObjs = !stdenv.isDarwin;         # http://hackage.haskell.org/trac/ghc/ticket/4013
+            enableSplitObjs = !(  stdenv.isDarwin         # http://hackage.haskell.org/trac/ghc/ticket/4013
+                               || stdenv.lib.versionOlder "7.6.99" ghc.ghcVersion  # -fsplit-ojbs is broken in 7.7 snapshot
+                               );
 
             # pass the '--enable-tests' flag to cabal in the configure stage
             # and run any regression test suites the package might have