summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-03-06 18:49:44 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-03-06 18:49:44 +0000
commit5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10 (patch)
tree88e71450daab325a99ab54f54eb0fbcfadb551a8 /pkgs/build-support
parent0be4183bd518a3a80d9b5c8ae513e3348f3f5be5 (diff)
downloadnixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar.gz
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar.bz2
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar.lz
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar.xz
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.tar.zst
nixlib-5e4c7aa8f31351c8b34ce94ffc6da0fe8278cb10.zip
* This substitution causes bash to hang. Urgh. Bash's pattern
  substitutions aren't very reliable.

svn path=/nixpkgs/trunk/; revision=32830
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index eaea4d190f19..1d1f6b435ec5 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -348,6 +348,7 @@ rec {
     QEMU_OPTS = "-m ${toString (if attrs ? memSize then attrs.memSize else 256)}";
   });
 
+  
   extractFs = {file, fs ? null} :
     with pkgs; runInLinuxVM (
     stdenv.mkDerivation {
@@ -373,6 +374,7 @@ rec {
       '';
     });
 
+    
   extractMTDfs = {file, fs ? null} :
     with pkgs; runInLinuxVM (
     stdenv.mkDerivation {
@@ -399,6 +401,7 @@ rec {
       '';
     });
 
+    
   qemuCommandGeneric = ''
     ${kvm}/bin/qemu-system-x86_64 \
       -nographic -no-reboot \
@@ -755,7 +758,7 @@ rec {
       bunzip2 < ${packagesList} > ./Packages
 
       # Work around this bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452279
-      substituteInPlace ./Packages --replace x86_64-linux-gnu x86-64-linux-gnu
+      sed -i ./Packages -e s/x86_64-linux-gnu/x86-64-linux-gnu/g
 
       ${perl}/bin/perl -I${dpkg} -w ${deb/deb-closure.pl} \
         ./Packages ${urlPrefix} ${toString packages} > $out